aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-04-19 15:21:33 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-04-19 15:21:33 +0000
commite8a7428097e6512bd78c689bfae5a4a2b76b3849 (patch)
tree136881fba9bd389096dbf732489f66cfd1f8eae7 /security
parent769f665523d14757e09c033291b0b095edcc5510 (diff)
downloadports-e8a7428097e6512bd78c689bfae5a4a2b76b3849.tar.gz
ports-e8a7428097e6512bd78c689bfae5a4a2b76b3849.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile7
-rw-r--r--security/clamav/distinfo4
-rw-r--r--security/clamav/files/clamav-clamd.sh10
3 files changed, 7 insertions, 14 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 76ce1384b9b5..b4b0c233c311 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= ${DISTVERSION:S/-rc//g:S/-/./g}
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= clamav
@@ -23,11 +24,12 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
arc:${PORTSDIR}/archivers/arc \
unzip:${PORTSDIR}/archivers/unzip
-DISTVERSION= 0.70-rc
+DISTVERSION= 0.70
CLAMAVUSER?= clamav
CLAMAVGROUP?= clamav
+OPTIONS= MILTER "Compile the milter interface" off
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -79,7 +81,8 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(ScanMail)$$|\1|' \
-e 's|^\#?(DatabaseDirectory) .*$$|\1 ${DATADIR}|' \
-e 's|^\#?(DatabaseOwner) .*$$|\1 ${CLAMAVUSER}|' \
- -e 's|^\#?(UpdateLogFile) .*$$|\1 /var/log/clamav/freshclam.log|'
+ -e 's|^\#?(UpdateLogFile) .*$$|\1 /var/log/clamav/freshclam.log|' \
+ -e 's|^\#?(FixStaleSocket)$$|\1|'
PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
CLAMAVGROUP=${CLAMAVGROUP}
diff --git a/security/clamav/distinfo b/security/clamav/distinfo
index 7059faeea616..07b57eb713e7 100644
--- a/security/clamav/distinfo
+++ b/security/clamav/distinfo
@@ -1,2 +1,2 @@
-MD5 (clamav-0.70-rc.tar.gz) = a5c296221fac9e05b865ed29f93e8718
-SIZE (clamav-0.70-rc.tar.gz) = 2251095
+MD5 (clamav-0.70.tar.gz) = 2599a2e6b06d1f8ca09fdef8bc17625c
+SIZE (clamav-0.70.tar.gz) = 2347104
diff --git a/security/clamav/files/clamav-clamd.sh b/security/clamav/files/clamav-clamd.sh
index 154ecc436b1c..243a3fba871b 100644
--- a/security/clamav/files/clamav-clamd.sh
+++ b/security/clamav/files/clamav-clamd.sh
@@ -26,16 +26,6 @@ pidfile=/var/run/clamav/clamd.pid
required_dirs=%%DATADIR%%
required_files=%%PREFIX%%/etc/clamav.conf
-start_precmd=start_precmd
-
-start_precmd()
-{
- if [ -S "$clamav_clamd_socket" ]; then
- warn "Stale socket $clamav_clamd_socket removed."
- rm "$clamav_clamd_socket"
- fi
-}
-
stop_postcmd=stop_postcmd
stop_postcmd()