aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:27:24 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:27:24 +0000
commit0c2bf8e94a3344c2eb7236e2c2872a1e2ac9a264 (patch)
treea9d3fe39f9eff614a352e0c285cc6e6c4b1768f9 /security
parentf86de4a07e99c31b6d2c8cfb630b3b341ea26d32 (diff)
downloadports-0c2bf8e94a3344c2eb7236e2c2872a1e2ac9a264.tar.gz
ports-0c2bf8e94a3344c2eb7236e2c2872a1e2ac9a264.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Twofish/Makefile24
-rw-r--r--security/p5-Crypt-Twofish/distinfo1
-rw-r--r--security/p5-Crypt-Twofish/pkg-comment1
-rw-r--r--security/p5-Crypt-Twofish/pkg-descr5
-rw-r--r--security/p5-Crypt-Twofish/pkg-plist7
6 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4218035aaa7c..ffee2622d832 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -82,6 +82,7 @@
SUBDIR += p5-Crypt-Rijndael
SUBDIR += p5-Crypt-SSLeay
SUBDIR += p5-Crypt-TripleDES
+ SUBDIR += p5-Crypt-Twofish
SUBDIR += p5-Digest-MD5
SUBDIR += p5-GnuPG-Interface
SUBDIR += p5-IO-Socket-SSL
diff --git a/security/p5-Crypt-Twofish/Makefile b/security/p5-Crypt-Twofish/Makefile
new file mode 100644
index 000000000000..9a3097710261
--- /dev/null
+++ b/security/p5-Crypt-Twofish/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Twofish
+# Date created: Wed Jan 3 16:29:03 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Twofish
+PORTVERSION= 1.0
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/Crypt/Twofish
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::Twofish.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Twofish/distinfo b/security/p5-Crypt-Twofish/distinfo
new file mode 100644
index 000000000000..f23bacf70b7e
--- /dev/null
+++ b/security/p5-Crypt-Twofish/distinfo
@@ -0,0 +1 @@
+MD5 (Twofish-1.0.tar.gz) = 0c4d916aee5f0978bca2314a84b23b2c
diff --git a/security/p5-Crypt-Twofish/pkg-comment b/security/p5-Crypt-Twofish/pkg-comment
new file mode 100644
index 000000000000..c01c0b1e6308
--- /dev/null
+++ b/security/p5-Crypt-Twofish/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing the Twofish cipher
diff --git a/security/p5-Crypt-Twofish/pkg-descr b/security/p5-Crypt-Twofish/pkg-descr
new file mode 100644
index 000000000000..f5b246ad853e
--- /dev/null
+++ b/security/p5-Crypt-Twofish/pkg-descr
@@ -0,0 +1,5 @@
+Crypt::Twofish is a perl module implementing the Twofish cipher.
+
+Author: Nishant Kakani <nishantkakani@hotmail.com>
+
+--will
diff --git a/security/p5-Crypt-Twofish/pkg-plist b/security/p5-Crypt-Twofish/pkg-plist
new file mode 100644
index 000000000000..e87c131dfd8a
--- /dev/null
+++ b/security/p5-Crypt-Twofish/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/Twofish.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/Twofish.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/Twofish.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/Twofish.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish