aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-26 10:17:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-26 10:17:08 +0000
commit0f8cd626f7ada3e4a4c091a763dcb8fe261ebb14 (patch)
tree1d3f4dd55235b18fdda388f76ef0d5e6b579b17c /security
parentd9f4265ee24a8c57e69988c0307cc3cd2ff30551 (diff)
downloadports-0f8cd626f7ada3e4a4c091a763dcb8fe261ebb14.tar.gz
ports-0f8cd626f7ada3e4a4c091a763dcb8fe261ebb14.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/barnyard/Makefile23
-rw-r--r--security/barnyard/files/barnyard.sh.in (renamed from security/barnyard/files/barnyard.sh)0
-rw-r--r--security/barnyard/files/pkg-message.in (renamed from security/barnyard/pkg-message)0
-rw-r--r--security/barnyard/pkg-plist19
4 files changed, 15 insertions, 27 deletions
diff --git a/security/barnyard/Makefile b/security/barnyard/Makefile
index 164adf21acb2..7ac229cb1dda 100644
--- a/security/barnyard/Makefile
+++ b/security/barnyard/Makefile
@@ -10,27 +10,25 @@ PORTVERSION= 0.2.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= barnyard
-#DISTNAME= barnyard
MAINTAINER= pauls@utdallas.edu
-COMMENT= An output system for Snort
+COMMENT?= An output system for Snort
-RUN_DEPENDS= ${LOCALBASE}/bin/snort:${PORTSDIR}/security/snort
+RUN_DEPENDS+= ${LOCALBASE}/bin/snort:${PORTSDIR}/security/snort
OPTIONS= MYSQL "Enable MySQL support" off \
POSTGRESQL "Enable PostgreSQL support" off
USE_AUTOTOOLS= autoheader:259 autoconf:259
-USE_REINPLACE= yes
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
-
+USE_RC_SUBR= barnyard.sh
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+SLAVEDIRS= security/barnyard-sguil6
+SUB_FILES= pkg-message
-DOCS= AUTHORS COPYING LICENSE.QPL README docs/BUGS docs/ChangeLog \
- docs/FAQ docs/INSTALL docs/NEWS docs/USAGE
+DOCS= AUTHORS COPYING LICENSE.QPL README
+PORTDOCS= BUGS ChangeLog FAQ INSTALL NEWS USAGE
.include <bsd.port.pre.mk>
@@ -44,12 +42,8 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-postgres
.endif
-post-patch:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/barnyard.sh > ${WRKDIR}/barnyard.sh
-
post-install:
- ${INSTALL_SCRIPT} -m 751 ${WRKDIR}/barnyard.sh ${PREFIX}/etc/rc.d/barnyard.sh
+
.for f in barnyard.conf
${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}-sample
[ -f ${PREFIX}/etc/${f} ] || \
@@ -58,6 +52,7 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/security/barnyard/files/barnyard.sh b/security/barnyard/files/barnyard.sh.in
index 0f295bea90e9..0f295bea90e9 100644
--- a/security/barnyard/files/barnyard.sh
+++ b/security/barnyard/files/barnyard.sh.in
diff --git a/security/barnyard/pkg-message b/security/barnyard/files/pkg-message.in
index 7012f28c1f06..7012f28c1f06 100644
--- a/security/barnyard/pkg-message
+++ b/security/barnyard/files/pkg-message.in
diff --git a/security/barnyard/pkg-plist b/security/barnyard/pkg-plist
index ac1d11949336..0bb410bc92ba 100644
--- a/security/barnyard/pkg-plist
+++ b/security/barnyard/pkg-plist
@@ -1,15 +1,8 @@
-@unexec if [ -f %D/etc/barnyard.conf ] && cmp -s %D/etc/barnyard.conf %D/etc/barnyard.conf-sample; then rm -f %D/etc/barnyard.conf; fi
bin/barnyard
+@unexec if [ -f %D/etc/barnyard.conf ] && cmp -s %D/etc/barnyard.conf %D/etc/barnyard.conf-sample; then rm -f %D/etc/barnyard.conf; fi
etc/barnyard.conf-sample
-etc/rc.d/barnyard.sh
-share/doc/barnyard/AUTHORS
-share/doc/barnyard/BUGS
-share/doc/barnyard/COPYING
-share/doc/barnyard/ChangeLog
-share/doc/barnyard/FAQ
-share/doc/barnyard/INSTALL
-share/doc/barnyard/LICENSE.QPL
-share/doc/barnyard/NEWS
-share/doc/barnyard/README
-share/doc/barnyard/USAGE
-@dirrm share/doc/barnyard
+@exec if [ ! -f %D/etc/barnyard.conf ] ; then cp -p %D/%F %B/barnyard.conf; fi
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/LICENSE.QPL
+%%DOCSDIR%%/README