aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-02 17:00:00 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-02 17:00:00 +0000
commitb159d8aee97d679337d35514ccaf45c6017e3614 (patch)
tree9b6e0015fd1f233ef1d5be64e72dbc6ca245b4a0 /security
parent223ce54df156c5dc91be3a7f729803c77deaa0cb (diff)
downloadports-b159d8aee97d679337d35514ccaf45c6017e3614.tar.gz
ports-b159d8aee97d679337d35514ccaf45c6017e3614.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/ipsec-tools/distinfo1
-rw-r--r--security/ipsec-tools/files/patch-configure25
-rw-r--r--security/ipsec-tools/files/patch-src__racoon__eaytest.c20
-rw-r--r--security/ipsec-tools/files/patch-src__racoon__plog.c7
-rw-r--r--security/ipsec-tools/files/patch-src__racoon__var.h23
5 files changed, 65 insertions, 11 deletions
diff --git a/security/ipsec-tools/distinfo b/security/ipsec-tools/distinfo
index e7dc814918c3..749e34689f56 100644
--- a/security/ipsec-tools/distinfo
+++ b/security/ipsec-tools/distinfo
@@ -1,4 +1,3 @@
MD5 (ipsec-tools-0.6.7.tar.bz2) = 4fb764f282dc21cf9a656c58e13dacbb
SHA256 (ipsec-tools-0.6.7.tar.bz2) = 4239f836dc610a2443ded7ba35cb3b87de9d582c800e5d9eb5eed37defd61ef2
SIZE (ipsec-tools-0.6.7.tar.bz2) = 723032
-
diff --git a/security/ipsec-tools/files/patch-configure b/security/ipsec-tools/files/patch-configure
index ce675f9cf664..ad34279e0a67 100644
--- a/security/ipsec-tools/files/patch-configure
+++ b/security/ipsec-tools/files/patch-configure
@@ -1,9 +1,23 @@
---- configure.orig Wed Apr 26 15:28:47 2006
-+++ configure Wed Apr 26 15:28:56 2006
-@@ -25122,6 +25122,74 @@
- fi
+--- ./configure.orig Fri Apr 6 17:07:12 2007
++++ ./configure Wed Jun 6 00:49:21 2007
+@@ -19969,10 +19969,10 @@
+
+
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS=" /usr/local/share/libtool/ltmain.sh"
+ # Always use our own libtool.
+-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
++LIBTOOL='$(SHELL) /usr/local/bin/libtool'
+ # Prevent multiple expansion
+
+@@ -24702,6 +24702,74 @@
+ { (exit 1); exit 1; }; }
+ fi
+
++
+ echo "$as_me:$LINENO: checking for iconv_open in -liconv" >&5
+echo $ECHO_N "checking for iconv_open in -liconv... $ECHO_C" >&6
+if test "${ac_cv_lib_iconv_iconv_open+set}" = set; then
@@ -71,7 +85,6 @@
+if test $ac_cv_lib_iconv_iconv_open = yes; then
+ LIBS="$LIBS -liconv"
+fi
-+
+
echo "$as_me:$LINENO: checking if iconv second argument needs const" >&5
echo $ECHO_N "checking if iconv second argument needs const... $ECHO_C" >&6
- saved_CFLAGS=$CFLAGS
diff --git a/security/ipsec-tools/files/patch-src__racoon__eaytest.c b/security/ipsec-tools/files/patch-src__racoon__eaytest.c
new file mode 100644
index 000000000000..5e4b39740475
--- /dev/null
+++ b/security/ipsec-tools/files/patch-src__racoon__eaytest.c
@@ -0,0 +1,20 @@
+--- ./src/racoon/eaytest.c.orig Wed Jun 6 01:07:11 2007
++++ ./src/racoon/eaytest.c Wed Jun 6 01:07:22 2007
+@@ -311,7 +311,7 @@
+
+ printf("exact match: succeed.\n");
+
+- if (dnstr_w1) {
++ if (dnstr_w1 != NULL) {
+ asn1dn = eay_str2asn1dn(dnstr_w1, strlen(dnstr_w1));
+ if (asn1dn == NULL || asn1dn->l == asn1dn0.l)
+ errx(1, "asn1dn length wrong for wildcard 1\n");
+@@ -321,7 +321,7 @@
+ printf("wildcard 1 match: succeed.\n");
+ }
+
+- if (dnstr_w1) {
++ if (dnstr_w1 != NULL) {
+ asn1dn = eay_str2asn1dn(dnstr_w2, strlen(dnstr_w2));
+ if (asn1dn == NULL || asn1dn->l == asn1dn0.l)
+ errx(1, "asn1dn length wrong for wildcard 2\n");
diff --git a/security/ipsec-tools/files/patch-src__racoon__plog.c b/security/ipsec-tools/files/patch-src__racoon__plog.c
index 72c9df5d5612..b03a99eafa49 100644
--- a/security/ipsec-tools/files/patch-src__racoon__plog.c
+++ b/security/ipsec-tools/files/patch-src__racoon__plog.c
@@ -1,6 +1,6 @@
---- src/racoon/plog.c.orig Fri Dec 30 11:28:03 2005
-+++ src/racoon/plog.c Fri Dec 30 11:28:18 2005
-@@ -224,7 +224,7 @@ ploginit()
+--- ./src/racoon/plog.c.orig Wed Dec 7 18:19:51 2005
++++ ./src/racoon/plog.c Wed Jun 6 00:49:18 2007
+@@ -224,7 +224,7 @@
return;
}
@@ -9,4 +9,3 @@
}
void
-
diff --git a/security/ipsec-tools/files/patch-src__racoon__var.h b/security/ipsec-tools/files/patch-src__racoon__var.h
new file mode 100644
index 000000000000..39c946b7aec5
--- /dev/null
+++ b/security/ipsec-tools/files/patch-src__racoon__var.h
@@ -0,0 +1,23 @@
+--- ./src/racoon/var.h.orig Wed Jun 6 01:06:51 2007
++++ ./src/racoon/var.h Wed Jun 6 01:07:00 2007
+@@ -76,9 +76,9 @@
+ do { \
+ if (getnameinfo((x), sysdep_sa_len(x), (y), sizeof(y), (z), sizeof(z), \
+ NIFLAGS) != 0) { \
+- if (y) \
++ if (y != NULL) \
+ strncpy((y), "(invalid)", sizeof(y)); \
+- if (z) \
++ if (z != NULL) \
+ strncpy((z), "(invalid)", sizeof(z)); \
+ } \
+ } while (0);
+@@ -87,7 +87,7 @@
+ do { \
+ if (getnameinfo((x), sysdep_sa_len(x), (y), sizeof(y), NULL, 0, \
+ NIFLAGS) != 0) { \
+- if (y) \
++ if (y != NULL) \
+ strncpy((y), "(invalid)", sizeof(y)); \
+ } \
+ } while (0);