aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:25:49 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:25:49 +0000
commite3e9508087a5531a3fb56d31c3351404dac4e046 (patch)
treee5a0cb926de4765ded835a0523b4c969eaa212d2 /security
parent0a7dddb50027579f23326b34f974895c27b6259b (diff)
downloadports-e3e9508087a5531a3fb56d31c3351404dac4e046.tar.gz
ports-e3e9508087a5531a3fb56d31c3351404dac4e046.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/vlog/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/security/vlog/Makefile b/security/vlog/Makefile
index 11b71a4cd6ba..e71f08508a6c 100644
--- a/security/vlog/Makefile
+++ b/security/vlog/Makefile
@@ -6,24 +6,31 @@ PORTVERSION= 1.1f
PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://inc2.com/download/
-DISTNAME= vlog-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A curses based real-time logfile viewer esp. useful for ipflog
+COMMENT= Curses based real-time logfile viewer esp. useful for ipflog
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
-ALL_TARGET= it
-MAKE_ARGS= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${PTHREAD_LIBS} -lcurses"
-WRKSRC= ${WRKDIR}/vlog
USES= perl5
+USE_PERL5= build
+MAKE_ENV= LIBS="-lcurses -pthread"
+ALL_TARGET= it
-MAN1= vlog.1
-MANCOMPRESSED= no
-PLIST_FILES= bin/vlog
+PLIST_FILES= bin/vlog man/man1/vlog.1.gz
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e "s@/usr/local@${PREFIX}@g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ '/^CC/s|\([[:space:]]\)=|\1?=| ; \
+ /strip/s|^|#|' ${WRKSRC}/Makefile
+
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} vlog \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} vlog.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1)
.include <bsd.port.mk>