aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-09-22 17:06:17 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-09-22 17:06:17 +0000
commit183ebc7b4dfa7aee110e073ca73fd61284109fdb (patch)
treef7e0c1999042596c4876ce3e48daa10a7fd1adaf /security
parente20b8f349973bf2bc4d5e492041f0be9c232b369 (diff)
downloadports-183ebc7b4dfa7aee110e073ca73fd61284109fdb.tar.gz
ports-183ebc7b4dfa7aee110e073ca73fd61284109fdb.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/mindterm-binary/Makefile31
-rw-r--r--security/mindterm-binary/distinfo2
-rw-r--r--security/mindterm-binary/pkg-comment1
-rw-r--r--security/mindterm-binary/pkg-descr15
-rw-r--r--security/mindterm-binary/pkg-plist11
6 files changed, 61 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 0fd34aa2c082..c44c0fb44925 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -48,6 +48,7 @@
SUBDIR += lsh
SUBDIR += lxnb
SUBDIR += mhash
+ SUBDIR += mindterm-binary
SUBDIR += nbaudit
SUBDIR += nessus
SUBDIR += nessus-libraries
diff --git a/security/mindterm-binary/Makefile b/security/mindterm-binary/Makefile
new file mode 100644
index 000000000000..d50a2aa522bb
--- /dev/null
+++ b/security/mindterm-binary/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mindterm-binary
+# Date created: 22 Sep 2000
+# Whom: alex@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= mindterm-binary
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= http://www.mindbright.se/mindterm/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alex
+DISTNAME= mindtermbin-v121
+DISTFILES= mindterm-ssh.html ${EXTRACT_ONLY}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= alex@FreeBSD.org
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-extract:
+ @${CP} ${DISTDIR}/mindterm-ssh.html ${WRKSRC}
+ @${MV} ${WRKSRC}/mindtermfull.jar ${WRKSRC}/mindterm.jar
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/java/mindterm
+ @${INSTALL_DATA} ${WRKSRC}/* ${PREFIX}/share/java/mindterm/
+
+.include <bsd.port.mk>
diff --git a/security/mindterm-binary/distinfo b/security/mindterm-binary/distinfo
new file mode 100644
index 000000000000..090417137bc7
--- /dev/null
+++ b/security/mindterm-binary/distinfo
@@ -0,0 +1,2 @@
+MD5 (mindterm-ssh.html) = 9c7330315b018d58476b16c1cb30eb02
+MD5 (mindtermbin-v121.zip) = 7e9da7322fcae183e6821b26b5acc61b
diff --git a/security/mindterm-binary/pkg-comment b/security/mindterm-binary/pkg-comment
new file mode 100644
index 000000000000..5c8540e50cf2
--- /dev/null
+++ b/security/mindterm-binary/pkg-comment
@@ -0,0 +1 @@
+A full vt220 compatible Java SSH client (not only for website)
diff --git a/security/mindterm-binary/pkg-descr b/security/mindterm-binary/pkg-descr
new file mode 100644
index 000000000000..28c7275c2ad3
--- /dev/null
+++ b/security/mindterm-binary/pkg-descr
@@ -0,0 +1,15 @@
+This is a Java SSH Client, which has a whole bunch of features.
+You should take a look at the following URL to find out:
+
+http://www.mindbright.se/mindterm/FEATURES.txt
+
+However, this version does _not_ depend on the Java Development
+Kit, since it is the binary version, which runs out-of-the-box
+in webbrowsers that support Java. A minimal sample HTML page
+is installed as well.
+If you want to use the client from shell, you have to install
+the JDK first (${PORTSDIR}/java/jdk/).
+
+WWW: http://www.mindbright.se/mindterm/
+
+- Alexander Langer <alex@FreeBSD.org>
diff --git a/security/mindterm-binary/pkg-plist b/security/mindterm-binary/pkg-plist
new file mode 100644
index 000000000000..724aee5de315
--- /dev/null
+++ b/security/mindterm-binary/pkg-plist
@@ -0,0 +1,11 @@
+share/java/mindterm/CHANGES
+share/java/mindterm/COPYING
+share/java/mindterm/FAQ
+share/java/mindterm/FEATURES
+share/java/mindterm/PLATFORMS
+share/java/mindterm/TODO
+share/java/mindterm/mindterm.jar
+share/java/mindterm/mindterm-ssh.html
+@dirrm share/java/mindterm
+@unexec rmdir %D/share/java || true
+