aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:24 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:24 +0000
commit23e6a2b3da60fd03fb9e392af59450056c09f9a5 (patch)
tree3b7e9ffbd68b82f181ccb4b1d327b834b4994adf /security
parent9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0 (diff)
downloadports-23e6a2b3da60fd03fb9e392af59450056c09f9a5.tar.gz
ports-23e6a2b3da60fd03fb9e392af59450056c09f9a5.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/libfwbuilder-devel/Makefile8
-rw-r--r--security/libfwbuilder/Makefile8
-rw-r--r--security/libfwbuilder2/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/security/libfwbuilder-devel/Makefile b/security/libfwbuilder-devel/Makefile
index 7a678627f90c..5908f3361e38 100644
--- a/security/libfwbuilder-devel/Makefile
+++ b/security/libfwbuilder-devel/Makefile
@@ -17,10 +17,16 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
xslt.1:${PORTSDIR}/textproc/libxslt \
sigc.1:${PORTSDIR}/devel/libsigc++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_GNOME= gtk12
INSTALLS_SHLIB= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/libfwbuilder/Makefile b/security/libfwbuilder/Makefile
index 7a678627f90c..5908f3361e38 100644
--- a/security/libfwbuilder/Makefile
+++ b/security/libfwbuilder/Makefile
@@ -17,10 +17,16 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
xslt.1:${PORTSDIR}/textproc/libxslt \
sigc.1:${PORTSDIR}/devel/libsigc++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_GNOME= gtk12
INSTALLS_SHLIB= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/libfwbuilder2/Makefile b/security/libfwbuilder2/Makefile
index 7a678627f90c..5908f3361e38 100644
--- a/security/libfwbuilder2/Makefile
+++ b/security/libfwbuilder2/Makefile
@@ -17,10 +17,16 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
xslt.1:${PORTSDIR}/textproc/libxslt \
sigc.1:${PORTSDIR}/devel/libsigc++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_GNOME= gtk12
INSTALLS_SHLIB= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>