aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-04 10:58:00 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-04 10:58:00 +0000
commit4f84500517a573926b33c43577cf73d4b7b7e4a2 (patch)
tree0f22114344bd945440090434b93ea6399b058eef /security
parent8affea9887e1a9c9c4aa11bb82bfeec36c496b62 (diff)
downloadports-4f84500517a573926b33c43577cf73d4b7b7e4a2.tar.gz
ports-4f84500517a573926b33c43577cf73d4b7b7e4a2.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-OpenSSL-Bignum/Makefile22
-rw-r--r--security/p5-Crypt-OpenSSL-Bignum/distinfo1
-rw-r--r--security/p5-Crypt-OpenSSL-Bignum/pkg-descr9
-rw-r--r--security/p5-Crypt-OpenSSL-Bignum/pkg-plist11
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6b255a973423..14fc00e2de1f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -208,6 +208,7 @@
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-OTP
SUBDIR += p5-Crypt-OpenPGP
+ SUBDIR += p5-Crypt-OpenSSL-Bignum
SUBDIR += p5-Crypt-OpenSSL-DSA
SUBDIR += p5-Crypt-OpenSSL-RSA
SUBDIR += p5-Crypt-OpenSSL-Random
diff --git a/security/p5-Crypt-OpenSSL-Bignum/Makefile b/security/p5-Crypt-OpenSSL-Bignum/Makefile
new file mode 100644
index 000000000000..070cdd555b55
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Bignum/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Crypt-OpenSSL-Bignum
+# Date created: Sep. 4, 2003
+# Whom: erwin@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OpenSSL-Bignum
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@FreeBSD.org
+COMMENT= OpenSSL's multiprecision integer arithmetic
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OpenSSL::Bignum::CTX.3 Crypt::OpenSSL::Bignum.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-Bignum/distinfo b/security/p5-Crypt-OpenSSL-Bignum/distinfo
new file mode 100644
index 000000000000..f029bd0cc6f4
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Bignum/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-OpenSSL-Bignum-0.03.tar.gz) = b526c1554b2f3bf7d94bf0c8c474fd2d
diff --git a/security/p5-Crypt-OpenSSL-Bignum/pkg-descr b/security/p5-Crypt-OpenSSL-Bignum/pkg-descr
new file mode 100644
index 000000000000..c17bb821d6fe
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Bignum/pkg-descr
@@ -0,0 +1,9 @@
+Crypt::OpenSSL::Bignum provides access to OpenSSL
+multiprecision integer arithmetic libraries. Presently,
+many though not all of the arithmetic operations that
+OpenSSL provides are exposed to perl. In addition,
+this module can be used to provide access to bignum
+values produced by other OpenSSL modules, such as key
+parameters from Crypt::OpenSSL::RSA.
+
+WWW: http://search.cpan.org/dist/Crypt-OpenSSL-Bignum/
diff --git a/security/p5-Crypt-OpenSSL-Bignum/pkg-plist b/security/p5-Crypt-OpenSSL-Bignum/pkg-plist
new file mode 100644
index 000000000000..300f2a888853
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Bignum/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Bignum/Bignum.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Bignum/Bignum.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Bignum/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/Bignum/CTX.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/Bignum.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/Bignum
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/Bignum
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true