aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-03-06 20:45:47 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-03-06 20:45:47 +0000
commit8b8a6523a51398f4198e4262f1c237ed0d89f91c (patch)
tree861d44c4216f447b4c981b246cb0222ab065bd5f /security
parentcf915cd0ddf2ecad23b53b6b460a23d586a300f2 (diff)
downloadports-8b8a6523a51398f4198e4262f1c237ed0d89f91c.tar.gz
ports-8b8a6523a51398f4198e4262f1c237ed0d89f91c.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile30
-rw-r--r--security/clamav/distinfo3
-rw-r--r--security/clamav/files/patch-clamav-milter::Makefile.in9
-rw-r--r--security/clamav/files/patch-configure28
-rw-r--r--security/clamav/files/patch-etc::Makefile.in13
-rw-r--r--security/clamav/files/patch-libclamav::message.c27
-rw-r--r--security/clamav/pkg-plist7
7 files changed, 65 insertions, 52 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 8a810db2e92d..70d00d524abf 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= clamav
-PORTVERSION= 0.65
-PORTREVISION= 7
+#PORTVERSION= ${DISTVERSION:S/-/./g}
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= clamav
+#DISTNAME= ${PORTNAME}-${DISTVERSION}
MAINTAINER= markun@onohara.to
COMMENT= Command line virus scanner written entirely in C
@@ -23,6 +23,8 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
arc:${PORTSDIR}/archivers/arc \
unzip:${PORTSDIR}/archivers/unzip
+DISTVERSION= 0.67-1
+
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -57,6 +59,7 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(LocalSocket) .*$$|\1 ${CLAMAV_CLAMD_SOCKET}|' \
-e 's|^\#?(User) .*$$|\1 clamav|' \
-e 's|^\#?(AllowSupplementaryGroups)$$|\1|' \
+ -e 's|^\#?(FixStaleSocket)$$|\1|' \
-e 's|^\#?(ScanMail)$$|\1|'
.include <bsd.port.pre.mk>
@@ -88,17 +91,11 @@ post-patch:
${WRKSRC}/clamav-milter/clamav-milter.c
pre-configure:
- @${REINPLACE_CMD} -e 's|clamav.conf|&.default|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
- ${CONFIGURE_WRKSRC}/etc/Makefile.in
-.ifdef USE_LIBTOOL_VER
@${REINPLACE_CMD} -e '/^LIBTOOL=/s|\$$(top_builddir)/libtool|${LIBTOOL}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
post-build:
- @${SED} ${SED_CONF} ${BUILD_WRKSRC}/etc/clamav.conf \
- >${BUILD_WRKSRC}/etc/clamav.conf.default
+ @${REINPLACE_CMD} ${SED_CONF} ${BUILD_WRKSRC}/etc/clamav.conf
@${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-install >${PKGINSTALL}
@${SED} ${SED_SCRIPT} ${FILESDIR}/clamav-clamd.sh \
>${WRKDIR}/clamav-clamd.sh
@@ -114,19 +111,24 @@ pre-install:
${SH} ${PKGINSTALL} ${PREFIX} PRE-INSTALL
post-install:
- @${INSTALL_DATA} ${BUILD_WRKSRC}/etc/clamav.conf.default \
- ${PREFIX}/etc/clamav.conf.default
@${INSTALL_SCRIPT} ${WRKDIR}/clamav-clamd.sh \
${RC_DIR}/clamav-clamd${RC_SUFX}
@${INSTALL_SCRIPT} ${WRKDIR}/clamav-freshclam.sh \
${RC_DIR}/clamav-freshclam${RC_SUFX}
@${CHOWN} -R clamav:clamav ${DATADIR}
- @[ -f ${PREFIX}/etc/clamav.conf ] || \
- ${CP} ${PREFIX}/etc/clamav.conf.default ${PREFIX}/etc/clamav.conf
+.for c in clamav freshclam
+ @[ -f ${PREFIX}/etc/${c}.conf ] || \
+ ${CP} ${PREFIX}/etc/${c}.conf.default ${PREFIX}/etc/${c}.conf
+.endfor
.if defined(WITH_MILTER)
@${INSTALL_SCRIPT} ${WRKDIR}/clamav-milter.sh \
${RC_DIR}/clamav-milter${RC_SUFX}
.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/NEWS ${INSTALL_WRKSRC}/ChangeLog \
+ ${DOCSDIR}
+.endif
@${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL
diff --git a/security/clamav/distinfo b/security/clamav/distinfo
index 423c88369fc7..d9d963bab63d 100644
--- a/security/clamav/distinfo
+++ b/security/clamav/distinfo
@@ -1 +1,2 @@
-MD5 (clamav-0.65.tar.gz) = f2b8473190b6dc1fd9c64b9ebc49a5ad
+MD5 (clamav-0.67-1.tar.gz) = e53d65fe2f7d4146f146c5720313381e
+SIZE (clamav-0.67-1.tar.gz) = 2282367
diff --git a/security/clamav/files/patch-clamav-milter::Makefile.in b/security/clamav/files/patch-clamav-milter::Makefile.in
index bcdc3f2c964c..d6a1bd3f5597 100644
--- a/security/clamav/files/patch-clamav-milter::Makefile.in
+++ b/security/clamav/files/patch-clamav-milter::Makefile.in
@@ -1,14 +1,5 @@
--- clamav-milter/Makefile.in.orig Wed Nov 12 02:36:48 2003
+++ clamav-milter/Makefile.in Fri Nov 21 18:23:35 2003
-@@ -122,7 +122,7 @@
-
- @BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@clamav_milter_LDADD = ../clamd/cfgfile.o ../clamd/others.o ../clamscan/getopt.o
-
--@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@man_MANS = ../docs/clamav-milter.8
-+@BUILD_CLAMD_TRUE@@HAVE_MILTER_TRUE@man_MANS = ../docs/man/clamav-milter.8
-
- DEFS = @DEFS@
- # CLAMD_LIBS is used, because clamav-milter requires the same libraries as clamd
@@ -162,7 +162,7 @@
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
diff --git a/security/clamav/files/patch-configure b/security/clamav/files/patch-configure
new file mode 100644
index 000000000000..ab505db6d68f
--- /dev/null
+++ b/security/clamav/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Thu Feb 19 14:18:40 2004
++++ configure Thu Feb 19 14:19:31 2004
+@@ -9317,7 +9317,7 @@
+
+
+
+-if test ! -r "$cfg_dir/clamav.conf"; then
++if true; then
+ INSTALL_CLAMAV_CONF_TRUE=
+ INSTALL_CLAMAV_CONF_FALSE='#'
+ else
+@@ -9327,7 +9327,7 @@
+
+
+
+-if test ! -r "$cfg_dir/freshclam.conf"; then
++if true; then
+ INSTALL_FRESHCLAM_CONF_TRUE=
+ INSTALL_FRESHCLAM_CONF_FALSE='#'
+ else
+@@ -9564,6 +9564,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
++#include <sys/types.h>
+ #include <netinet/in.h>
+ int main(int argc, char **argv) { in_port_t pt; pt = 0; return pt; }
+ _ACEOF
diff --git a/security/clamav/files/patch-etc::Makefile.in b/security/clamav/files/patch-etc::Makefile.in
new file mode 100644
index 000000000000..d91e60928682
--- /dev/null
+++ b/security/clamav/files/patch-etc::Makefile.in
@@ -0,0 +1,13 @@
+--- etc/Makefile.in.orig Thu Feb 19 14:17:02 2004
++++ etc/Makefile.in Thu Feb 19 14:17:36 2004
+@@ -248,8 +248,8 @@
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(CFGINST)
+-@INSTALL_CLAMAV_CONF_TRUE@ @$(INSTALL_DATA) clamav.conf $(DESTDIR)$(CFGINST)
+-@INSTALL_FRESHCLAM_CONF_TRUE@ @$(INSTALL_DATA) freshclam.conf $(DESTDIR)$(CFGINST)
++@INSTALL_CLAMAV_CONF_TRUE@ @$(INSTALL_DATA) clamav.conf $(DESTDIR)$(CFGINST)/clamav.conf.default
++@INSTALL_FRESHCLAM_CONF_TRUE@ @$(INSTALL_DATA) freshclam.conf $(DESTDIR)$(CFGINST)/freshclam.conf.default
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/security/clamav/files/patch-libclamav::message.c b/security/clamav/files/patch-libclamav::message.c
deleted file mode 100644
index eb322ffb1b3e..000000000000
--- a/security/clamav/files/patch-libclamav::message.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- libclamav/message.c.orig Wed Nov 5 11:59:53 2003
-+++ libclamav/message.c Tue Feb 10 14:39:23 2004
-@@ -878,15 +878,20 @@
- if(strcasecmp(line, "end") == 0)
- break;
-
-- assert(strlen(line) <= 62);
- if((line[0] & 0x3F) == ' ')
- break;
-
- len = *line++ - ' ';
-
-- assert((len >= 0) && (len <= 63));
--
-- ptr = decode(line, ptr, uudecode, (len & 3) == 0);
-+ if(len < 0 || len > 63)
-+ /*
-+ * In practice this should never occur since
-+ * the maximum length of a uuencoded line is
-+ * 62 characters
-+ */
-+ cli_warnmsg("uudecode: buffer overflow stopped, attempting to ignore but decoding may fail");
-+ else
-+ ptr = decode(line, ptr, uudecode, (len & 3) == 0);
- break;
-
- case BINARY:
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 552820d185c6..83671904d942 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -14,13 +14,18 @@ lib/libclamav.a
@unexec if cmp -s %D/etc/clamav.conf %D/etc/clamav.conf.default; then rm -f %D/etc/clamav.conf; fi
etc/clamav.conf.default
@exec [ -f %B/clamav.conf ] || cp %B/%f %B/clamav.conf
+@unexec if cmp -s %D/etc/freshclam.conf %D/etc/freshclam.conf.default; then rm -f %D/etc/freshclam.conf; fi
+etc/freshclam.conf.default
+@exec [ -f %B/freshclam.conf ] || cp %B/%f %B/freshclam.conf
etc/rc.d/clamav-clamd%%RC_SUFX%%
etc/rc.d/clamav-freshclam%%RC_SUFX%%
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@owner clamav
@group clamav
%%DATADIR%%/daily.cvd
%%DATADIR%%/main.cvd
-%%DATADIR%%/mirrors.txt
@exec chown clamav:clamav %B
@dirrm %%DATADIR%%
@unexec rmdir /var/run/clamav 2>/dev/null || true