aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-25 04:13:33 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-25 04:13:33 +0000
commit00dbce631081fc4c7f54a48dff6495db7eba7752 (patch)
tree46b1f55787a18d07c21073a71f10977d130597f7 /security
parent8c8e57ea388ae2447919d7b57478182772ddd03f (diff)
downloadports-00dbce631081fc4c7f54a48dff6495db7eba7752.tar.gz
ports-00dbce631081fc4c7f54a48dff6495db7eba7752.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/cryptstring/Makefile23
-rw-r--r--security/cryptstring/distinfo3
-rw-r--r--security/cryptstring/pkg-descr4
-rw-r--r--security/cryptstring/pkg-plist3
5 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 849853ee959e..aded4b437ac6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -83,6 +83,7 @@
SUBDIR += cryptlib
SUBDIR += cryptopp
SUBDIR += cryptplug
+ SUBDIR += cryptstring
SUBDIR += cutlass
SUBDIR += cvm
SUBDIR += cyrus-sasl
diff --git a/security/cryptstring/Makefile b/security/cryptstring/Makefile
new file mode 100644
index 000000000000..d0551fd67544
--- /dev/null
+++ b/security/cryptstring/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: cryptstring
+# Date created: 2007-02-23
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptstring
+PORTVERSION= 0.2
+CATEGORIES= security
+MASTER_SITES= http://cryptstring.googlecode.com/files/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Crypto Strings for PHP
+
+NO_BUILD= yes
+USE_PHP= mcrypt mhash
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/cs.inc.php ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/security/cryptstring/distinfo b/security/cryptstring/distinfo
new file mode 100644
index 000000000000..f6770da366f8
--- /dev/null
+++ b/security/cryptstring/distinfo
@@ -0,0 +1,3 @@
+MD5 (cryptstring-0.2.tar.gz) = 4c4179abefdb99bb8c9a3abe81dc10be
+SHA256 (cryptstring-0.2.tar.gz) = d89f8d6084f684486d4f31ca333dcf49ba6edda80f7b818835996e75354dbd60
+SIZE (cryptstring-0.2.tar.gz) = 1456
diff --git a/security/cryptstring/pkg-descr b/security/cryptstring/pkg-descr
new file mode 100644
index 000000000000..7854c15894be
--- /dev/null
+++ b/security/cryptstring/pkg-descr
@@ -0,0 +1,4 @@
+Very simple PHP functions for encrypting and signing (and reverse,
+decrypting and verifying) on string under BSD license.
+
+WWW: http://code.google.com/p/cryptstring/
diff --git a/security/cryptstring/pkg-plist b/security/cryptstring/pkg-plist
new file mode 100644
index 000000000000..b42d7ce02b40
--- /dev/null
+++ b/security/cryptstring/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%DATADIR%%/cs.inc.php
+@dirrm %%DATADIR%%