aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
commit5005b67362a735dc18d3d85170eae34e1fb6feab (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /security
parente4eefd3f1e344c567f932fef63a6f04a0bb4eba4 (diff)
downloadports-5005b67362a735dc18d3d85170eae34e1fb6feab.tar.gz
ports-5005b67362a735dc18d3d85170eae34e1fb6feab.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/ccrypt/Makefile3
-rw-r--r--security/duo/Makefile3
-rw-r--r--security/fuzzdb/Makefile3
-rw-r--r--security/gnutls-devel/Makefile3
-rw-r--r--security/identify/Makefile3
-rw-r--r--security/mac-robber/Makefile2
-rw-r--r--security/nettle/Makefile2
-rw-r--r--security/orthrus/Makefile3
-rw-r--r--security/pam-pgsql/Makefile3
-rw-r--r--security/pam_krb5-rh/Makefile2
-rw-r--r--security/pidgin-encryption/Makefile3
-rw-r--r--security/polarssl/Makefile2
-rw-r--r--security/pulledpork/Makefile2
-rw-r--r--security/slurpie/Makefile3
-rw-r--r--security/sslsniffer/Makefile3
-rw-r--r--security/sslwrap/Makefile3
-rw-r--r--security/super/Makefile3
-rw-r--r--security/xyssl/Makefile3
-rw-r--r--security/zxid/Makefile3
19 files changed, 52 insertions, 0 deletions
diff --git a/security/ccrypt/Makefile b/security/ccrypt/Makefile
index f4655cf9be68..33d43c680b1d 100644
--- a/security/ccrypt/Makefile
+++ b/security/ccrypt/Makefile
@@ -12,6 +12,9 @@ COMMENT= Command-line utility for encrypting and decrypting files and streams
USES= gmake
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/security/duo/Makefile b/security/duo/Makefile
index 9659df5913e5..aa11c877be42 100644
--- a/security/duo/Makefile
+++ b/security/duo/Makefile
@@ -27,6 +27,9 @@ MAN8= login_duo.8 pam_duo.8
OPTIONS= DOCS
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${OSVERSION} >= 1000000
diff --git a/security/fuzzdb/Makefile b/security/fuzzdb/Makefile
index ffb1ce65d220..0df6afa6a677 100644
--- a/security/fuzzdb/Makefile
+++ b/security/fuzzdb/Makefile
@@ -17,6 +17,9 @@ PORTDIRS= attack-payloads wordlists-misc Discovery \
web-backdoors wordlists-user-passwd regex
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index ca2e49798341..5172597ffc67 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -32,6 +32,9 @@ CONFIGURE_ARGS+= --disable-guile --disable-silent-rules \
MANCOMPRESSED= no
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if (defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.7)) && !defined(WITHOUT_LIBTASN1)
diff --git a/security/identify/Makefile b/security/identify/Makefile
index 120d88f02091..9d8965bf5a35 100644
--- a/security/identify/Makefile
+++ b/security/identify/Makefile
@@ -16,6 +16,9 @@ PORTDOCS= README
PLIST_FILES= libexec/identify
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/security/mac-robber/Makefile b/security/mac-robber/Makefile
index e1ae7d489900..12bd9654bf3e 100644
--- a/security/mac-robber/Makefile
+++ b/security/mac-robber/Makefile
@@ -20,6 +20,8 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mac-robber ${STAGEDIR}${PREFIX}/bin
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 539175591672..b10afa678aac 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -38,6 +38,8 @@ INFO= nettle
CONFIGURE_ENV+= CCPIC=-fPIC
.endif
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/security/orthrus/Makefile b/security/orthrus/Makefile
index e9b402888c68..00406a1b54c7 100644
--- a/security/orthrus/Makefile
+++ b/security/orthrus/Makefile
@@ -21,6 +21,9 @@ USES= iconv
PORTDOCS= *
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
index eed839551eba..da19afd89135 100644
--- a/security/pam-pgsql/Makefile
+++ b/security/pam-pgsql/Makefile
@@ -20,6 +20,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --libdir=/usr/lib
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/security/pam_krb5-rh/Makefile b/security/pam_krb5-rh/Makefile
index ead167aad099..a304fe65389f 100644
--- a/security/pam_krb5-rh/Makefile
+++ b/security/pam_krb5-rh/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} --without-afs \
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index 92e220046b13..1632796b5d74 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -28,6 +28,9 @@ CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nss-libs=${LOCALBASE}/lib/nss
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index ce3fbd05965d..24d556c7d4fb 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -44,6 +44,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
.endfor
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/security/pulledpork/Makefile b/security/pulledpork/Makefile
index 901ad2f658ee..bb378636db5a 100644
--- a/security/pulledpork/Makefile
+++ b/security/pulledpork/Makefile
@@ -33,6 +33,8 @@ PLIST_FILES= bin/pulledpork.pl \
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
PORTDOCS= README README.CATEGORIES README.CHANGES README.RULESET README.SHAREDOBJECTS
diff --git a/security/slurpie/Makefile b/security/slurpie/Makefile
index c2a57dee4aa8..63f9edc09942 100644
--- a/security/slurpie/Makefile
+++ b/security/slurpie/Makefile
@@ -16,6 +16,9 @@ PLIST_FILES= sbin/slurp sbin/slurpie
PORTDOCS= README
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/security/sslsniffer/Makefile b/security/sslsniffer/Makefile
index 2fe2951e1fbf..9558bbad8bf8 100644
--- a/security/sslsniffer/Makefile
+++ b/security/sslsniffer/Makefile
@@ -19,6 +19,9 @@ PORTDOCS= README
PLIST_FILES= bin/sslsniffer
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index 4284a1c298d1..0e73d83640f1 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -19,6 +19,9 @@ PORTDOCS= README docs.html
PLIST_FILES= bin/sslwrap
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/security/super/Makefile b/security/super/Makefile
index e170ec7367d1..9386d451afb8 100644
--- a/security/super/Makefile
+++ b/security/super/Makefile
@@ -20,6 +20,9 @@ MAN1= super.1 setuid.1
MAN5= super.5
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/security/xyssl/Makefile b/security/xyssl/Makefile
index f9addb618383..889954d4dd14 100644
--- a/security/xyssl/Makefile
+++ b/security/xyssl/Makefile
@@ -24,6 +24,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index 55a126b2bf2a..17eb809cd4ac 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -28,6 +28,9 @@ ZXID_BINS= smime zxcall zxcot zxdecode zxencdectest zxid zxidhlo \
zxidwsctool zxlogview zxpasswd
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch: