aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-02 11:58:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-02 11:58:21 +0000
commit8b4093cba5775260e98d51f74cd187fb9af825a8 (patch)
tree4a28bf50f532fa82a149cbc3f9c041d48a23921b /security
parentf38d6cb92bbd96d100bae02b23ace94acea1cf8e (diff)
downloadports-8b4093cba5775260e98d51f74cd187fb9af825a8.tar.gz
ports-8b4093cba5775260e98d51f74cd187fb9af825a8.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/fwknop/Makefile2
-rw-r--r--security/libressl-devel/Makefile8
-rw-r--r--security/libressl/Makefile8
-rw-r--r--security/openca-tools-forked/Makefile2
-rw-r--r--security/p5-Crypt-GCrypt/Makefile2
-rw-r--r--security/p5-Crypt-OpenSSL-X509/Makefile2
-rw-r--r--security/p5-Crypt-SMIME/Makefile2
-rw-r--r--security/p5-Digest-GOST/Makefile2
-rw-r--r--security/p5-openxpki/Makefile9
9 files changed, 18 insertions, 19 deletions
diff --git a/security/fwknop/Makefile b/security/fwknop/Makefile
index c01babfca60a..cf8e92a810c5 100644
--- a/security/fwknop/Makefile
+++ b/security/fwknop/Makefile
@@ -42,7 +42,7 @@ PF_CONFIGURE_WITH= pf=/sbin/pfctl
GPGME_LIB_DEPENDS= libgpgme.so:security/gpgme
GPGME_CONFIGURE_WITH= gpgme
-post-stage:
+post-install:
(cd ${STAGEDIR}${PREFIX}/etc/fwknop && ${MV} access.conf access.conf.sample)
(cd ${STAGEDIR}${PREFIX}/etc/fwknop && ${MV} fwknopd.conf fwknopd.conf.sample)
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index 2fea72f544ff..c766a109f1a5 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -33,13 +33,13 @@ CFLAGS+= -fpic -DPIC
INSTALL_TARGET= install-strip
TEST_TARGET= check
-post-stage-NC-on:
+post-install:
+ ${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+
+post-install-NC-on:
${INSTALL_PROGRAM} ${WRKSRC}/apps/nc/.libs/nc ${STAGEDIR}/${PREFIX}/bin/nc
${INSTALL_MAN} ${WRKSRC}/apps/nc/nc.1 ${STAGEDIR}/${PREFIX}/man/man1/nc.1
-post-stage:
- ${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
-
post-install-MAN3-off:
${RM} -r ${STAGEDIR}/${PREFIX}/man/man3
${REINPLACE_CMD} -e '/^man\/man3/d' ${TMPPLIST}
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 767605485442..02ce5fe98895 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -34,11 +34,11 @@ CFLAGS+= -fpic -DPIC
INSTALL_TARGET= install-strip
TEST_TARGET= check
-post-stage-NC-on:
+post-install:
+ ${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+
+post-install-NC-on:
${INSTALL_PROGRAM} ${WRKSRC}/apps/nc/.libs/nc ${STAGEDIR}/${PREFIX}/bin/nc
${INSTALL_MAN} ${WRKSRC}/apps/nc/nc.1 ${STAGEDIR}/${PREFIX}/man/man1/nc.1
-post-stage:
- ${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
-
.include <bsd.port.mk>
diff --git a/security/openca-tools-forked/Makefile b/security/openca-tools-forked/Makefile
index 6a126f6727bc..5c02c2deac28 100644
--- a/security/openca-tools-forked/Makefile
+++ b/security/openca-tools-forked/Makefile
@@ -21,7 +21,7 @@ USES= gmake perl5 ssl
CONFIGURE_ARGS+= --with-openssl-prefix=${OPENSSLBASE}
# security/openssl already has a verify.1 manpage.
-post-stage:
+post-install:
.for f in sign.1 verify.1
@${MV} ${STAGEDIR}${PREFIX}/man/man1/${f} ${STAGEDIR}${PREFIX}/man/man1/openca-${f}
.endfor
diff --git a/security/p5-Crypt-GCrypt/Makefile b/security/p5-Crypt-GCrypt/Makefile
index 1116f5bf3ce7..f04289c706c3 100644
--- a/security/p5-Crypt-GCrypt/Makefile
+++ b/security/p5-Crypt-GCrypt/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt
USE_PERL5= configure
USES= localbase perl5
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/GCrypt/GCrypt.so
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-X509/Makefile b/security/p5-Crypt-OpenSSL-X509/Makefile
index f46f3908a5ee..293f0742ddc8 100644
--- a/security/p5-Crypt-OpenSSL-X509/Makefile
+++ b/security/p5-Crypt-OpenSSL-X509/Makefile
@@ -22,7 +22,7 @@ MAKE_ARGS+= PASTHRU_INC=-I${OPENSSLINC}
post-patch:
@${REINPLACE_CMD} -e '/cc_optimize_flags/ s| -Werror||' ${WRKSRC}/Makefile.PL
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${SITE_ARCH}/auto/Crypt/OpenSSL/X509/X509.so
.include <bsd.port.pre.mk>
diff --git a/security/p5-Crypt-SMIME/Makefile b/security/p5-Crypt-SMIME/Makefile
index 6ea7f6e11e20..acffbd6e7780 100644
--- a/security/p5-Crypt-SMIME/Makefile
+++ b/security/p5-Crypt-SMIME/Makefile
@@ -26,7 +26,7 @@ USE_PERL5= configure
CONFIGURE_ENV= LIBCRYPTO_CFLAGS="-I${OPENSSLINC}" LIBCRYPTO_LIBS="-L${OPENSSLLIB} -lcrypto"
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/SMIME/SMIME.so
.include <bsd.port.mk>
diff --git a/security/p5-Digest-GOST/Makefile b/security/p5-Digest-GOST/Makefile
index fcb8ca13f66b..223226bedb10 100644
--- a/security/p5-Digest-GOST/Makefile
+++ b/security/p5-Digest-GOST/Makefile
@@ -18,7 +18,7 @@ BROKEN_mips64= fails to build: Cannot detect CPU architechture
USES= perl5
USE_PERL5= configure
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${SITE_ARCH}/auto/Digest/GOST/GOST.so
.include <bsd.port.mk>
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index af9d078baca3..786890d7494d 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -108,11 +108,6 @@ post-patch:
)
@${MKDIR} ${WRKSRC}/t/var/log/openxpki
-post-stage:
- @${MKDIR} ${STAGEDIR}/var/openxpki/session
- @${MKDIR} ${STAGEDIR}/var/log/openxpki
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/openxpki
-
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT:Mlibressl*}
@@ -124,6 +119,10 @@ OXLIB= ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/OpenXPKI/OpenXPKI.so
post-install:
${STRIP_CMD} ${OXLIB}
+ @${MKDIR} ${STAGEDIR}/var/openxpki/session
+ @${MKDIR} ${STAGEDIR}/var/log/openxpki
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/openxpki
+
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/../.. && ${COPYTREE_SHARE} config ${STAGEDIR}${EXAMPLESDIR})