aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-02 01:34:09 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-02 01:34:09 +0000
commit5021f93e01fde553e46f16ed35835c14a41fbc75 (patch)
tree61a20f365aad5ce464317e52a68281d87f599b08 /security
parent35829d51c45d7c4f886f40a239de486f030c1856 (diff)
downloadports-5021f93e01fde553e46f16ed35835c14a41fbc75.tar.gz
ports-5021f93e01fde553e46f16ed35835c14a41fbc75.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Data-Password/Makefile22
-rw-r--r--security/p5-Data-Password/distinfo2
-rw-r--r--security/p5-Data-Password/pkg-descr7
-rw-r--r--security/p5-Data-Password/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8307a0c1aa18..7bff0805f04e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -309,6 +309,7 @@
SUBDIR += p5-Crypt-Twofish2
SUBDIR += p5-Crypt-UnixCrypt
SUBDIR += p5-Crypt-xDBM_File
+ SUBDIR += p5-Data-Password
SUBDIR += p5-Digest
SUBDIR += p5-Digest-BubbleBabble
SUBDIR += p5-Digest-HMAC
diff --git a/security/p5-Data-Password/Makefile b/security/p5-Data-Password/Makefile
new file mode 100644
index 000000000000..10fa6a1eec25
--- /dev/null
+++ b/security/p5-Data-Password/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Data-Password
+# Date created: 2005-08-02
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Password
+PORTVERSION= 1.05
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= A Perl extension for assessing password quality
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Password.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Data-Password/distinfo b/security/p5-Data-Password/distinfo
new file mode 100644
index 000000000000..f5860fc9d021
--- /dev/null
+++ b/security/p5-Data-Password/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Password-1.05.tar.gz) = 0fa2f19f5e4dbf3366396214a30ff634
+SIZE (Data-Password-1.05.tar.gz) = 4610
diff --git a/security/p5-Data-Password/pkg-descr b/security/p5-Data-Password/pkg-descr
new file mode 100644
index 000000000000..d61249511837
--- /dev/null
+++ b/security/p5-Data-Password/pkg-descr
@@ -0,0 +1,7 @@
+Data::Password checks potential passwords for crackability. It checks that the
+password has the appropriate length, that it has enough character groups, that
+it does not contain the same characters repeatedly, that it does not contain
+ascending or descending characters, or characters close to each other on the
+keyboard. It also searches for the password in the ispell word file.
+
+WWW: http://search.cpan.org/~razinf/Data-Password/
diff --git a/security/p5-Data-Password/pkg-plist b/security/p5-Data-Password/pkg-plist
new file mode 100644
index 000000000000..dac7875ae2d1
--- /dev/null
+++ b/security/p5-Data-Password/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/Password.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Password/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Password
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true