aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-11 15:48:48 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-11 15:48:48 +0000
commit8c945941d80c8df243b2f3cf01c4e1b61601b4fb (patch)
treeeddd46482b28d514cf1f89d3eeaeb0ab7d125468 /security
parenteb724048d8a6c02d57894d5ede90d55854491b6c (diff)
downloadports-8c945941d80c8df243b2f3cf01c4e1b61601b4fb.tar.gz
ports-8c945941d80c8df243b2f3cf01c4e1b61601b4fb.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile3
-rw-r--r--security/p5-Crypt-Format/Makefile18
-rw-r--r--security/p5-Crypt-Format/distinfo2
-rw-r--r--security/p5-Crypt-Format/pkg-descr3
-rw-r--r--security/p5-Crypt-Format/pkg-plist2
-rw-r--r--security/p5-Crypt-RSA-Parse/Makefile21
-rw-r--r--security/p5-Crypt-RSA-Parse/distinfo2
-rw-r--r--security/p5-Crypt-RSA-Parse/pkg-descr3
-rw-r--r--security/p5-Crypt-RSA-Parse/pkg-plist9
-rw-r--r--security/p5-Protocol-ACME/Makefile27
-rw-r--r--security/p5-Protocol-ACME/distinfo2
-rw-r--r--security/p5-Protocol-ACME/pkg-descr3
-rw-r--r--security/p5-Protocol-ACME/pkg-plist19
13 files changed, 114 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8a9d039d8e2c..f169f9fc24f7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -502,6 +502,7 @@
SUBDIR += p5-Crypt-ECB
SUBDIR += p5-Crypt-Eksblowfish
SUBDIR += p5-Crypt-Enigma
+ SUBDIR += p5-Crypt-Format
SUBDIR += p5-Crypt-GCrypt
SUBDIR += p5-Crypt-GOST
SUBDIR += p5-Crypt-GOST_PP
@@ -546,6 +547,7 @@
SUBDIR += p5-Crypt-RHash
SUBDIR += p5-Crypt-RIPEMD160
SUBDIR += p5-Crypt-RSA
+ SUBDIR += p5-Crypt-RSA-Parse
SUBDIR += p5-Crypt-RSA-Yandex
SUBDIR += p5-Crypt-Rabbit
SUBDIR += p5-Crypt-RandPasswd
@@ -668,6 +670,7 @@
SUBDIR += p5-POE-Filter-SSL
SUBDIR += p5-Parse-Snort
SUBDIR += p5-PerlCryptLib
+ SUBDIR += p5-Protocol-ACME
SUBDIR += p5-SAVI-Perl
SUBDIR += p5-SHA
SUBDIR += p5-Safe-Hole
diff --git a/security/p5-Crypt-Format/Makefile b/security/p5-Crypt-Format/Makefile
new file mode 100644
index 000000000000..1df4e29280d8
--- /dev/null
+++ b/security/p5-Crypt-Format/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= Crypt-Format
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Conversion utilities for encryption applications
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Format/distinfo b/security/p5-Crypt-Format/distinfo
new file mode 100644
index 000000000000..9700de2495eb
--- /dev/null
+++ b/security/p5-Crypt-Format/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Format-0.06.tar.gz) = 821c7a729706ca5e919770289df57403d14d421ffc47cc9f52137515f6f282c1
+SIZE (Crypt-Format-0.06.tar.gz) = 13938
diff --git a/security/p5-Crypt-Format/pkg-descr b/security/p5-Crypt-Format/pkg-descr
new file mode 100644
index 000000000000..8fffdf6872a4
--- /dev/null
+++ b/security/p5-Crypt-Format/pkg-descr
@@ -0,0 +1,3 @@
+Conversion utilities for encryption applications
+
+WWW: http://search.cpan.org/dist/Crypt-Format/
diff --git a/security/p5-Crypt-Format/pkg-plist b/security/p5-Crypt-Format/pkg-plist
new file mode 100644
index 000000000000..c8631b4517ec
--- /dev/null
+++ b/security/p5-Crypt-Format/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Crypt/Format.pm
+%%PERL5_MAN3%%/Crypt::Format.3.gz
diff --git a/security/p5-Crypt-RSA-Parse/Makefile b/security/p5-Crypt-RSA-Parse/Makefile
new file mode 100644
index 000000000000..71b0caa93591
--- /dev/null
+++ b/security/p5-Crypt-RSA-Parse/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Crypt-RSA-Parse
+PORTVERSION= 0.041
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Parse RSA keys
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Crypt-Format>=0.06:security/p5-Crypt-Format
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-RSA-Parse/distinfo b/security/p5-Crypt-RSA-Parse/distinfo
new file mode 100644
index 000000000000..0eade83f1dd1
--- /dev/null
+++ b/security/p5-Crypt-RSA-Parse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-RSA-Parse-0.041.tar.gz) = fc5dfed374c44b5eb0291042221c00461e253b46642cb75323ddd10b482fc101
+SIZE (Crypt-RSA-Parse-0.041.tar.gz) = 15525
diff --git a/security/p5-Crypt-RSA-Parse/pkg-descr b/security/p5-Crypt-RSA-Parse/pkg-descr
new file mode 100644
index 000000000000..ce54158da0b6
--- /dev/null
+++ b/security/p5-Crypt-RSA-Parse/pkg-descr
@@ -0,0 +1,3 @@
+Parse RSA keys for useful information
+
+WWW: http://search.cpan.org/dist/Crypt-RSA-Parse/
diff --git a/security/p5-Crypt-RSA-Parse/pkg-plist b/security/p5-Crypt-RSA-Parse/pkg-plist
new file mode 100644
index 000000000000..e1ae76e2de42
--- /dev/null
+++ b/security/p5-Crypt-RSA-Parse/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Crypt/RSA/Parse.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/Convert_ASN1.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/KeyBase.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/Parser.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/Parser/MathBigInt.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/Private.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/Public.pm
+%%SITE_PERL%%/Crypt/RSA/Parse/Template.pm
+%%PERL5_MAN3%%/Crypt::RSA::Parse.3.gz
diff --git a/security/p5-Protocol-ACME/Makefile b/security/p5-Protocol-ACME/Makefile
new file mode 100644
index 000000000000..7d5cce1003d0
--- /dev/null
+++ b/security/p5-Protocol-ACME/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Protocol-ACME
+PORTVERSION= 0.11
+DISTVERSIONPREFIX=v
+CATEGORIES= security perl5
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Interface to the Let's Encrypt ACME API
+
+LICENSE= ART20
+
+RUN_DEPENDS= p5-Crypt-Format>=0.06:security/p5-Crypt-Format \
+ p5-Crypt-OpenSSL-Bignum>=0.06:security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-RSA>=0.28:security/p5-Crypt-OpenSSL-RSA \
+ p5-Digest-SHA>=5.95:security/p5-Digest-SHA \
+ p5-Log-Any>=1.032:devel/p5-Log-Any \
+ p5-JSON>=2.90:converters/p5-JSON \
+ p5-libwww>=6.13:www/p5-libwww
+
+USES= perl5
+USE_GITHUB= yes
+GH_ACCOUNT= sludin
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Protocol-ACME/distinfo b/security/p5-Protocol-ACME/distinfo
new file mode 100644
index 000000000000..45d92e66b13a
--- /dev/null
+++ b/security/p5-Protocol-ACME/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sludin-Protocol-ACME-v0.11_GH0.tar.gz) = 32c0cd807c6480ff96b926ed07bd755afbfcd5034b78a6ed839aa1e4fb316f5a
+SIZE (sludin-Protocol-ACME-v0.11_GH0.tar.gz) = 27545
diff --git a/security/p5-Protocol-ACME/pkg-descr b/security/p5-Protocol-ACME/pkg-descr
new file mode 100644
index 000000000000..e6d891fe476a
--- /dev/null
+++ b/security/p5-Protocol-ACME/pkg-descr
@@ -0,0 +1,3 @@
+Interface to the Let's Encrypt ACME API
+
+WWW: http://search.cpan.org/dist/Protocol-ACME/
diff --git a/security/p5-Protocol-ACME/pkg-plist b/security/p5-Protocol-ACME/pkg-plist
new file mode 100644
index 000000000000..499283711237
--- /dev/null
+++ b/security/p5-Protocol-ACME/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/Protocol/ACME.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge/LocalFile.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge/Manual.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge/SimpleSSH.pm
+%%SITE_PERL%%/Protocol/ACME/Exception.pm
+%%SITE_PERL%%/Protocol/ACME/Key.pm
+%%SITE_PERL%%/Protocol/ACME/Logger.pm
+%%SITE_PERL%%/Protocol/ACME/OpenSSL.pm
+%%SITE_PERL%%/Protocol/ACME/Utils.pm
+%%SITE_PERL%%/Protocol/README.pod
+%%SITE_PERL%%/Protocol/client.pl
+%%SITE_PERL%%/Protocol/revoke.pl
+%%PERL5_MAN3%%/Protocol::ACME.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge::LocalFile.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge::Manual.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge::SimpleSSH.3.gz
+%%PERL5_MAN3%%/Protocol::README.3.gz