aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-07-14 08:19:00 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-07-14 08:19:00 +0000
commitc383c90ce5aec733e3ee255c5ecec3bcd8c88d09 (patch)
tree939d74a95b80f366c0e2956287a9b0c319eba760 /security
parent0d06d2359a6bf726197ff6e981ea8c0c782d4fb9 (diff)
Add a patch to handle an ABI change relative to libgcrypt 1.5
Confirmed upstream: http://lists.gnupg.org/pipermail/gnupg-users/2011-July/042333.html PR: ports/158674 Submitted by: Mark Atkinson <atkin901@gmail.com> Approved by: early maintainer timeout/portmgr (pav)
Notes
Notes: svn path=/head/; revision=277672
Diffstat (limited to 'security')
-rw-r--r--security/gnupg/Makefile2
-rw-r--r--security/gnupg/files/patch-g10__pkglue.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index b7040113dc0a..e5706a2ef746 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 2.0.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
diff --git a/security/gnupg/files/patch-g10__pkglue.c b/security/gnupg/files/patch-g10__pkglue.c
new file mode 100644
index 000000000000..cd1a8c3aed89
--- /dev/null
+++ b/security/gnupg/files/patch-g10__pkglue.c
@@ -0,0 +1,24 @@
+--- g10/pkglue.c.orig 2011-01-09 14:06:16.000000000 -0800
++++ g10/pkglue.c 2011-07-12 21:32:41.000000000 -0700
+@@ -34,10 +34,10 @@
+ {
+ gcry_sexp_t list;
+ gcry_mpi_t data;
+-
++
+ list = gcry_sexp_find_token (sexp, item, 0);
+ assert (list);
+- data = gcry_sexp_nth_mpi (list, 1, 0);
++ data = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
+ assert (data);
+ gcry_sexp_release (list);
+ return data;
+@@ -293,7 +293,7 @@
+ if (rc)
+ return rc;
+
+- *result = gcry_sexp_nth_mpi (s_plain, 0, 0);
++ *result = gcry_sexp_nth_mpi (s_plain, 0, GCRYMPI_FMT_USG);
+ gcry_sexp_release (s_plain);
+ if (!*result)
+ return -1; /* oops */