aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-03-02 12:10:16 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-03-02 12:10:16 +0000
commitc52a6bbd3a0835bcd5c4146f1dd0cad5b3ee7041 (patch)
tree5eb365ba9d2e17eaf6193304f54c4efb603565f9 /security
parentd4305d6fc613597cac0d8c8ff18b4483f64b169f (diff)
downloadports-c52a6bbd3a0835bcd5c4146f1dd0cad5b3ee7041.tar.gz
ports-c52a6bbd3a0835bcd5c4146f1dd0cad5b3ee7041.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/logcheck/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 066eda12368b..8396d4a6c43f 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -33,7 +33,7 @@ OPTIONS_DEFAULT=CRON
.endif
# Enable Perl dependency for logtail script
-USES= perl5
+USES= perl5 shebangfix
WRKSRC= ${WRKDIR}/${DISTNAME:S!_!-!}
BINMODE= 755
@@ -45,6 +45,7 @@ SUB_LIST+= LOGCHECK_USER=${LOGCHECK_USER} \
PW=${PW} CRON=${PORT_OPTIONS:MCRON}
SUB_FILES= pkg-install pkg-deinstall pkg-message
PLIST_SUB+= DBDIR=${DBDIR} RUNDIR=${RUNDIR}
+SHEBANG_FILES= src/logtail src/logtail2
CONFIG_DIRS= cracking.d ignore.d.paranoid ignore.d.server \
ignore.d.workstation violations.d violations.ignore.d
DOCS= AUTHORS CHANGES CREDITS LICENSE TODO docs/README*
@@ -72,8 +73,6 @@ post-patch:
do-build:
@${REINPLACE_CMD} -e 's!/var/log/syslog!/var/log/messages!' \
${WRKSRC}/etc/logcheck.logfiles
- @${REINPLACE_CMD} -e "s|#!/usr/bin/perl|#!${PERL}|" \
- ${WRKSRC}/src/logtail
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/src/logcheck ${PREFIX}/sbin