aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-05-16 08:26:41 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-05-16 08:26:41 +0000
commitf0e454a7628db8b5dc43a0cb395cbf94ae485478 (patch)
treeda063acc5c3247c3b7d5f48373b0bcb4525aa795 /security
parent6c5643deb17468f287b5231750f9b54630dc7f56 (diff)
downloadports-f0e454a7628db8b5dc43a0cb395cbf94ae485478.tar.gz
ports-f0e454a7628db8b5dc43a0cb395cbf94ae485478.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-Anubis/Makefile5
-rw-r--r--security/p5-Crypt-Anubis/files/patch-anubis.c11
2 files changed, 14 insertions, 2 deletions
diff --git a/security/p5-Crypt-Anubis/Makefile b/security/p5-Crypt-Anubis/Makefile
index 8465f5d6bf50..25df7b52a108 100644
--- a/security/p5-Crypt-Anubis/Makefile
+++ b/security/p5-Crypt-Anubis/Makefile
@@ -21,8 +21,9 @@ MAN3= Crypt::Anubis.3
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile"
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw{$$1};$$1/g' ${WRKSRC}/Anubis.pm
.endif
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Anubis/files/patch-anubis.c b/security/p5-Crypt-Anubis/files/patch-anubis.c
new file mode 100644
index 000000000000..fe281f2af154
--- /dev/null
+++ b/security/p5-Crypt-Anubis/files/patch-anubis.c
@@ -0,0 +1,11 @@
+--- _anubis.c.orig Sun May 16 10:04:36 2004
++++ _anubis.c Sun May 16 10:05:13 2004
+@@ -976,7 +976,7 @@
+ void print_data(char *str, u8 *val, int len);
+ int compare_blocks(u8 *m1, u8 *m2, int len_bits); /* 0=equal, 1=not eq. */
+
+-int main(void)
++int main _((int argc, char** argv, char** env))
+ {
+ struct NESSIEstruct subkeys;
+ u8 key[KEYSIZEB];