aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:30:21 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:30:21 +0000
commit2259b7c0e8a8fd278d2077a3404a240d6c7a3b0f (patch)
tree73f9fb3d719daf5cce5763ad1d47c147649e17ee /security
parent9f6ee59f794c529f65d5c4ef0a5196b3df241d78 (diff)
downloadports-2259b7c0e8a8fd278d2077a3404a240d6c7a3b0f.tar.gz
ports-2259b7c0e8a8fd278d2077a3404a240d6c7a3b0f.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-openxpki-client-html-mason/Makefile32
-rw-r--r--security/p5-openxpki-client-html-mason/distinfo3
-rw-r--r--security/p5-openxpki-client-html-mason/pkg-descr24
-rw-r--r--security/p5-openxpki-client-html-mason/pkg-plist12
5 files changed, 72 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index baa2b1a91e7c..102534bd2c24 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -466,6 +466,7 @@
SUBDIR += p5-openxpki
SUBDIR += p5-openxpki-client
SUBDIR += p5-openxpki-client-cli
+ SUBDIR += p5-openxpki-client-html-mason
SUBDIR += pad
SUBDIR += pam-mysql
SUBDIR += pam-pgsql
diff --git a/security/p5-openxpki-client-html-mason/Makefile b/security/p5-openxpki-client-html-mason/Makefile
new file mode 100644
index 000000000000..c7ae34769e80
--- /dev/null
+++ b/security/p5-openxpki-client-html-mason/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-openxpki-client-html-mason
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-client-html-mason
+PORTVERSION= 0.9.546
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DISTNAME= OpenXPKI-Client-HTML-Mason-${PORTVERSION}
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Web interface for local openxpki daemon
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/OpenXPKI/Client.pm:${PORTSDIR}/security/p5-openxpki-client \
+ ${SITE_PERL}/Apache/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= OpenXPKI::Client::HTML::Mason.3 \
+ OpenXPKI::Client::HTML::Mason::Javascript.3 \
+ OpenXPKI::Client::HTML::Mason::Menu.3
+USE_PERL5= yes
+USE_GMAKE= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-openxpki-client-html-mason/distinfo b/security/p5-openxpki-client-html-mason/distinfo
new file mode 100644
index 000000000000..38ecb5f96a5d
--- /dev/null
+++ b/security/p5-openxpki-client-html-mason/distinfo
@@ -0,0 +1,3 @@
+MD5 (openxpki/OpenXPKI-Client-HTML-Mason-0.9.546.tar.gz) = f3ef5026485ff4a22bfe742ae9e01234
+SHA256 (openxpki/OpenXPKI-Client-HTML-Mason-0.9.546.tar.gz) = a6906e954609c703256af614f511208f64df88d4649840d9b8550996b9993015
+SIZE (openxpki/OpenXPKI-Client-HTML-Mason-0.9.546.tar.gz) = 44253
diff --git a/security/p5-openxpki-client-html-mason/pkg-descr b/security/p5-openxpki-client-html-mason/pkg-descr
new file mode 100644
index 000000000000..dccf2ae39cd6
--- /dev/null
+++ b/security/p5-openxpki-client-html-mason/pkg-descr
@@ -0,0 +1,24 @@
+A collection of ports for the OpenXPKI suite - Perl based trustcenter
+software for PKI: server and client parts along with deployment tools.
+
+p5-openxpki: core for server part
+p5-openxpki-client: base class for actual clients
+p5-openxpki-i18n: internationalization of the user interface
+p5-openxpki-client-cli: command line interface to local OpenXPKI daemon
+p5-openxpki-client-html-mason: web interface to local OpenXPKI daemon
+p5-openxpki-client-scep: set of SCEP tools
+p5-openxpki-client-soap-lite: set of SOAP-Lite tools
+p5-openxpki-deployment: set or deployment tools
+
+Dependencies of OpenXPKI ports ("A --> B" means that port B depends on port A):
+
+ p5-openxpki-client <-- p5-openxpki (server) --> p5-openxpki-i18n
+ \
+ \ | p5-openxpki-client-cli, p5-openxpki-client-html-mason,
+ \--> | p5-openxpki-client-scep, p5-openxpki-client-soap-lite,
+ | p5-openxpki-deployment.
+Notes:
+I18n is needed for the English interface too. For effective use of deployment,
+it is recommended to install at least one of the clients: ...-cli or ...-mason.
+
+WWW: http://www.openxpki.org/
diff --git a/security/p5-openxpki-client-html-mason/pkg-plist b/security/p5-openxpki-client-html-mason/pkg-plist
new file mode 100644
index 000000000000..979e82927dfc
--- /dev/null
+++ b/security/p5-openxpki-client-html-mason/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/OpenXPKI/Client/HTML/Mason.pm
+%%SITE_PERL%%/OpenXPKI/Client/HTML/Mason/Javascript.pm
+%%SITE_PERL%%/OpenXPKI/Client/HTML/Mason/Menu.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/HTML/Mason/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/HTML/Mason
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/HTML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client/HTML/Mason
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client/HTML
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/OpenXPKI