aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-10-08 18:06:54 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-10-08 18:06:54 +0000
commitef0ecb1c3620d04a11e956ecabb220f558aff58c (patch)
tree72e08a6e6eb49ae14d1ac5e2df5fef7a566e47b3 /security
parent871a680720fd5e47ef74eb8dd8da8de67a03521c (diff)
downloadports-ef0ecb1c3620d04a11e956ecabb220f558aff58c.tar.gz
ports-ef0ecb1c3620d04a11e956ecabb220f558aff58c.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/stunnel/Makefile1
-rw-r--r--security/stunnel/pkg-deinstall63
2 files changed, 1 insertions, 63 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index e100f4db80f0..009cac3f9405 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stunnel
PORTVERSION= 4.18
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
diff --git a/security/stunnel/pkg-deinstall b/security/stunnel/pkg-deinstall
deleted file mode 100644
index bef875e0bc34..000000000000
--- a/security/stunnel/pkg-deinstall
+++ /dev/null
@@ -1,63 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-# taken from net/cvsup-mirror
-
-PATH=/bin:/usr/sbin
-
-STUNNEL_USER=${STUNNEL_USER:-stunnel}
-STUNNEL_GROUP=${STUNNEL_GROUP:-stunnel}
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-delete_account() {
- local u g home
-
- u=$1
- g=$2
- if yesno "Do you want me to remove group \"${g}\"" y; then
- pw groupdel -n ${g}
- echo "Done."
- fi
- if yesno "Do you want me to remove user \"${u}\"" y; then
- eval home=~${u}
- pw userdel -n ${u}
- echo "Done."
- if [ -d "${home}" ]; then
- echo "Please remember to remove the home directory \"${home}\""
- fi
- fi
-}
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-delete_account ${STUNNEL_USER} ${STUNNEL_GROUP}