aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-12-05 10:10:40 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-12-05 10:10:40 +0000
commit9500212fbeb9d5536cde7517f28ef72fbc4206f4 (patch)
tree6f575feec66a9ac7fd4712a5af212277604ad6bd /security
parent3e24c1069926be0ea346fe24222f829b7deca496 (diff)
downloadports-9500212fbeb9d5536cde7517f28ef72fbc4206f4.tar.gz
ports-9500212fbeb9d5536cde7517f28ef72fbc4206f4.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/seal/Makefile21
-rw-r--r--security/seal/distinfo3
-rw-r--r--security/seal/pkg-descr7
-rw-r--r--security/seal/pkg-plist53
5 files changed, 85 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5bac89a30f2a..1ededd8e1ad2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1228,6 +1228,7 @@
SUBDIR += scanssh
SUBDIR += scrypt
SUBDIR += seahorse
+ SUBDIR += seal
SUBDIR += seccure
SUBDIR += secpanel
SUBDIR += sectok
diff --git a/security/seal/Makefile b/security/seal/Makefile
new file mode 100644
index 000000000000..ab3c522729d6
--- /dev/null
+++ b/security/seal/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= seal
+PORTVERSION= 3.1.0
+CATEGORIES= security
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Microsoft Simple Encrypted Arithmetic Library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
+
+USE_GITHUB= yes
+GH_ACCOUNT= Microsoft
+GH_PROJECT= SEAL
+
+.include <bsd.port.mk>
diff --git a/security/seal/distinfo b/security/seal/distinfo
new file mode 100644
index 000000000000..b0fbe79645e1
--- /dev/null
+++ b/security/seal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543982381
+SHA256 (Microsoft-SEAL-3.1.0_GH0.tar.gz) = 5f8f846f8b715dec7d5ff1ae4d1256d86a88925f1b39179dc5ac3e0b7a2d39e3
+SIZE (Microsoft-SEAL-3.1.0_GH0.tar.gz) = 248141
diff --git a/security/seal/pkg-descr b/security/seal/pkg-descr
new file mode 100644
index 000000000000..5be27379577d
--- /dev/null
+++ b/security/seal/pkg-descr
@@ -0,0 +1,7 @@
+The Simple Encrypted Arithmetic Library (SEAL) is an easy-to-use but powerful
+open-source homomorphic encryption library, developed by researchers in the
+Cryptography Research Group at Microsoft Research. SEAL is written in standard
+C++; it has no external dependencies, so it is easy to compile in many
+different environments. SEAL is licensed under the MIT license.
+
+WWW: http://sealcrypto.org
diff --git a/security/seal/pkg-plist b/security/seal/pkg-plist
new file mode 100644
index 000000000000..39bbab9ea1ea
--- /dev/null
+++ b/security/seal/pkg-plist
@@ -0,0 +1,53 @@
+include/seal/batchencoder.h
+include/seal/biguint.h
+include/seal/ciphertext.h
+include/seal/ckks.h
+include/seal/context.h
+include/seal/decryptor.h
+include/seal/defaultparams.h
+include/seal/encoder.h
+include/seal/encryptionparams.h
+include/seal/encryptor.h
+include/seal/evaluator.h
+include/seal/galoiskeys.h
+include/seal/intarray.h
+include/seal/keygenerator.h
+include/seal/memorymanager.h
+include/seal/plaintext.h
+include/seal/publickey.h
+include/seal/randomgen.h
+include/seal/relinkeys.h
+include/seal/seal.h
+include/seal/secretkey.h
+include/seal/smallmodulus.h
+include/seal/util/aes.h
+include/seal/util/baseconverter.h
+include/seal/util/clang.h
+include/seal/util/clipnormal.h
+include/seal/util/common.h
+include/seal/util/config.h
+include/seal/util/defines.h
+include/seal/util/gcc.h
+include/seal/util/globals.h
+include/seal/util/hash.h
+include/seal/util/hestdparms.h
+include/seal/util/locks.h
+include/seal/util/mempool.h
+include/seal/util/msvc.h
+include/seal/util/numth.h
+include/seal/util/pointer.h
+include/seal/util/polyarith.h
+include/seal/util/polyarithmod.h
+include/seal/util/polyarithsmallmod.h
+include/seal/util/polycore.h
+include/seal/util/randomtostd.h
+include/seal/util/smallntt.h
+include/seal/util/uintarith.h
+include/seal/util/uintarithmod.h
+include/seal/util/uintarithsmallmod.h
+include/seal/util/uintcore.h
+lib/cmake/SEAL/SEALConfig.cmake
+lib/cmake/SEAL/SEALConfigVersion.cmake
+lib/cmake/SEAL/SEALTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/SEAL/SEALTargets.cmake
+lib/libseal.a