aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
commit053520453dc374b6c02b15ad78efd7e0e52867f6 (patch)
tree9715c5e142788fa00b976d2c5a75b984e005be15 /security
parent353346c8f2676860eb119c92298802aa94479b3a (diff)
downloadports-053520453dc374b6c02b15ad78efd7e0e52867f6.tar.gz
ports-053520453dc374b6c02b15ad78efd7e0e52867f6.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/newpki-client/Makefile8
-rw-r--r--security/newpki-lib/Makefile4
-rw-r--r--security/newpki-server/Makefile4
-rw-r--r--security/openssh/Makefile21
-rw-r--r--security/py-pycrypto/Makefile6
-rw-r--r--security/sfs/Makefile12
-rw-r--r--security/ssh/Makefile10
-rw-r--r--security/vpnd/Makefile12
8 files changed, 11 insertions, 66 deletions
diff --git a/security/newpki-client/Makefile b/security/newpki-client/Makefile
index 4bb838e9b459..a93c3b9a235b 100644
--- a/security/newpki-client/Makefile
+++ b/security/newpki-client/Makefile
@@ -42,13 +42,7 @@ PLIST_FILES+= share/locale/fr/LC_MESSAGES/newpki-client.mo
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "does not compile (C++ libraries compiled with conflicting gcc versions)"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/newpki-lib/Makefile b/security/newpki-lib/Makefile
index 5a0c8d1f20be..b6d4fac19ebd 100644
--- a/security/newpki-lib/Makefile
+++ b/security/newpki-lib/Makefile
@@ -37,10 +37,6 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
.if ${OSVERSION} >= 700019
BROKEN= does not compile with OpenSSL 0.9.8b
.endif
diff --git a/security/newpki-server/Makefile b/security/newpki-server/Makefile
index bbf1c65c6819..02eff223c4ff 100644
--- a/security/newpki-server/Makefile
+++ b/security/newpki-server/Makefile
@@ -46,10 +46,6 @@ CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
.if ${OSVERSION} >= 700019
BROKEN= does not compile with OpenSSL 0.9.8b
.endif
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 2d21b84dd1ce..d514f71cc3a5 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -58,13 +58,6 @@ CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV+= LIBDATADIR=${PREFIX}/libdata MANDIR=${MANPREFIX}/man/man CRYPTOLIBS="${CRYPTOLIBS}"
-.if ${OSVERSION} < 400014
-MAKE_ENV+= COMPAT_GETADDRINFO=yes
-ADDME+= netdb.h
-.else
-MAKE_ENV+= INET6FLAGS=-DINET6
-.endif
-
.if !exists(/usr/include/tcpd.h)
MAKE_ENV+= TCP_WRAPPERS=no
.endif
@@ -126,20 +119,6 @@ pre-configure:
${WRKSRC}/${i}.sed >${WRKSRC}/${i}
.endfor
-.if ${OSVERSION} < 430000
-post-configure:
-.for i in ${FIXME}
- @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
- ${SED} -e "s=KERBEROS[:]L=KERBEROS=" \
- -e "s=KERBEROS5[:]L=KERBEROS5=" \
- -e "s=AFS[:]L=AFS=" \
- -e "s=TCP_WRAPPERS[:]L=TCP_WRAPPERS=" \
- -e "s=SKEY[:]L=SKEY=" \
- -e "s=PAM[:]L=PAM=" \
- ${WRKSRC}/${i}.sed >${WRKSRC}/${i}
-.endfor
-.endif
-
pre-install:
-${MKDIR} ${EMPTYDIR}
if ! pw groupshow sshd; then pw groupadd sshd -g 22; fi
diff --git a/security/py-pycrypto/Makefile b/security/py-pycrypto/Makefile
index 825047c20672..7ac26bd45021 100644
--- a/security/py-pycrypto/Makefile
+++ b/security/py-pycrypto/Makefile
@@ -18,13 +18,9 @@ COMMENT= The Python Cryptography Toolkit
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-.endif
pre-configure:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/setup.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/sfs/Makefile b/security/sfs/Makefile
index 69ddde307f9c..f97a5144c90d 100644
--- a/security/sfs/Makefile
+++ b/security/sfs/Makefile
@@ -25,7 +25,10 @@ CONFIGURE_ARGS+=--with-sfsuser=sfs \
--with-sfsgroup=sfs \
--with-sfsdir=/var/spool/sfs \
--with-etcdir=${PREFIX}/etc/sfs \
- --disable-uvfs
+ --disable-uvfs \
+ --with-gmp=${LOCALBASE}
+
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
.include <bsd.port.pre.mk>
@@ -33,13 +36,6 @@ CONFIGURE_ARGS+=--with-sfsuser=sfs \
IGNORE= nfsmounter component fails to execute correctly on ${ARCH} systems
.endif
-.if ${OSVERSION} > 500000
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--with-gmp=/usr
-.endif
-
MAN1= \
dirsearch.1 \
newaid.1 \
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index e6ddaa99cf20..79e91a119e66 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -60,15 +60,13 @@ CONFIGURE_ARGS+= --with-secureid
CONFIGURE_ARGS+= --without-idea
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500023
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
MAKE_ENV+= GMPINCDIR="${LOCALBASE}/include" \
GMPLIBDIR="${LOCALBASE}/lib"
-.endif
-.if (${OSVERSION} >= 400016 && !defined(REALLY_WANT_SSH))
+.include <bsd.port.pre.mk>
+
+.if !defined(REALLY_WANT_SSH)
IGNORE= is now deprecated: OpenSSH is a superior version of SSH which has been included in the FreeBSD base system since 4.0-RELEASE. To override this warning set the REALLY_WANT_SSH environment variable and rebuild
.endif
@@ -110,7 +108,7 @@ CONFIGURE_ARGS+= --with-libwrap
# ssh-1.2.27-IPv6-1.5-patch.gz
# We still use WITH_INET6 here and try to support pre 4.0 machines with kame
# IPv6 stack
-.if ${OSVERSION} >= 400014 || ( ${OSVERSION} < 400014 && defined(WITH_INET6) )
+.if defined(WITH_INET6)
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
diff --git a/security/vpnd/Makefile b/security/vpnd/Makefile
index 811c5674df32..fe4c7ff2985e 100644
--- a/security/vpnd/Makefile
+++ b/security/vpnd/Makefile
@@ -40,14 +40,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-post-install:
-.if ${OSVERSION} < 500000
- @${ECHO} "================================================================================"
- @${ECHO} "Make sure you set up a few IRQ's for random generation with rndcontrol before"
- @${ECHO} "trying to generate a master key file."
- @${ECHO} "================================================================================"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>