aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2009-12-18 03:57:54 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2009-12-18 03:57:54 +0000
commit0db1ed5e69467fad36da23768a745afaf7e8ca90 (patch)
tree9c9e5bcc4a1e9227dd129f803b609521c1ab4f83 /security
parentc3b1322179b64dffe73eb21b86360f3a5eb267a9 (diff)
downloadports-0db1ed5e69467fad36da23768a745afaf7e8ca90.tar.gz
ports-0db1ed5e69467fad36da23768a745afaf7e8ca90.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/zxid/Makefile15
-rw-r--r--security/zxid/distinfo6
-rw-r--r--security/zxid/files/patch-Makefile52
-rw-r--r--security/zxid/files/patch-smime.c12
-rw-r--r--security/zxid/files/patch-zxlib.c10
-rw-r--r--security/zxid/pkg-plist9
6 files changed, 57 insertions, 47 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index d21ba5b43984..4bc4d671345e 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zxid
-PORTVERSION= 0.25
-PORTREVISION= 1
+PORTVERSION= 0.38
CATEGORIES= security www
MASTER_SITES= http://zxid.org/
EXTRACT_SUFX= .tgz
@@ -24,7 +23,17 @@ USE_LDCONFIG= yes
USE_OPENSSL= yes
post-install:
- ${LN} -s libzxid.so.0.0 ${PREFIX}/lib/libzxid.so.0
+
+ ${MKDIR} ${PREFIX}/include/zxid
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/zxidhlo ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/zxididp ${PREFIX}/bin/
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/libzxid.a ${PREFIX}/lib/
+ ${INSTALL_PROGRAM} ${WRKSRC}/libzxid.so.0.0 ${PREFIX}/lib/libzxid.so.0
+ ${LN} -sf libzxid.so.0 ${PREFIX}/lib/libzxid.so
+
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.h c/*.h ${PREFIX}/include/zxid/)
.include <bsd.port.pre.mk>
diff --git a/security/zxid/distinfo b/security/zxid/distinfo
index 46b23df2ac55..ee057f575eb0 100644
--- a/security/zxid/distinfo
+++ b/security/zxid/distinfo
@@ -1,3 +1,3 @@
-MD5 (zxid-0.25.tgz) = 118a0873632dc1186a37702586c4119c
-SHA256 (zxid-0.25.tgz) = feb68f1d646f6b792834c7d99eb9d8b9a20cb90af81f15037d0f5343b6c1b906
-SIZE (zxid-0.25.tgz) = 2803264
+MD5 (zxid-0.38.tgz) = 986cb023e321d52d7522e24d27979830
+SHA256 (zxid-0.38.tgz) = b6883fb5771b2d16591ab4e624fa78ceaceec45bc608b8c348947773bb2a6b91
+SIZE (zxid-0.38.tgz) = 3091109
diff --git a/security/zxid/files/patch-Makefile b/security/zxid/files/patch-Makefile
index c419cd714f71..06e87bbc5492 100644
--- a/security/zxid/files/patch-Makefile
+++ b/security/zxid/files/patch-Makefile
@@ -1,22 +1,22 @@
---- Makefile.orig 2008-04-17 09:47:50.000000000 +0800
-+++ Makefile 2008-04-18 15:30:13.000000000 +0800
-@@ -26,13 +26,13 @@
+--- Makefile.orig 2009-10-16 19:37:47.000000000 +0400
++++ Makefile 2009-10-30 00:02:20.000000000 +0300
+@@ -31,13 +31,13 @@
- default: seehelp zxid zxidsp zxidhlo zxidhlowsf zxidsimple zxidwsctool zxlogview zxidhrxmlwsc zxidhrxmlwsp
+ default: seehelp precheck zxid zxidhlo zxididp zxidhlowsf zxidsimple zxidwsctool zxlogview zxidhrxmlwsc zxidhrxmlwsp zxdecode zxcot
--all: seehelp zxid zxidsp zxidhlo zxidsimple zxlogview samlmod phpzxid javazxid apachezxid
-+all: seehelp zxid zxidsp zxidhlo zxidsimple zxlogview
+-all: seehelp precheck precheck_apache zxid zxidhlo zxididp zxidsimple zxlogview samlmod phpzxid javazxid apachezxid zxdecode zxcot smime
++all: seehelp precheck zxid zxidhlo zxididp zxidsimple zxlogview zxdecode zxcot smime
- ZXIDREL=0.25
- ZXIDVERSION=0x000025
+ ZXIDREL=0.38
+ ZXIDVERSION=0x000038
### Where package is installed (use `make PREFIX=/your/path' to change)
-PREFIX=/usr/local/zxid/$(ZXIDREL)
+PREFIX?=/usr/local/zxid/$(ZXIDREL)
### Where runtime configuration and temporary data is kept.
- ### If you change the following, be sure to edit zxidconf.h as well. N.B. Trailing / is needed.
-@@ -60,8 +60,8 @@
+ ### If you change the following, be sure to edit zxidconf.h as
+@@ -64,8 +64,8 @@
###
TOP=$(shell pwd)
@@ -25,9 +25,9 @@
+CURL_ROOT?=/usr/local
+OPENSSL_ROOT?=/usr/local/ssl
PHP_CONFIG=php-config
- APACHE_ROOT=/usr/local/httpd
-
-@@ -75,11 +75,11 @@
+ CSHARP_CONFIG=true
+ PY_CONFIG=true
+@@ -82,11 +82,11 @@
SWIG=swig
AR=ar -crs
ARX=ar -x
@@ -43,22 +43,16 @@
+CFLAGS+=-g -fpic -fmessage-length=0 -Wno-unused-label -Wno-unknown-pragmas -fno-strict-aliasing
#CFLAGS += -Os # gcc-3.4.6 miscompiles with -Os on ix86
CFLAGS += -Wall -Wno-parentheses -DMAYBE_UNUSED='__attribute__ ((unused))'
-
-@@ -112,7 +112,7 @@
- CDEF+= -DUSE_CURL
- # Without OpenSSL signing and signature verification are not possible
- CDEF+= -DUSE_OPENSSL
--LIBS=-lpthread -L$(CURL_ROOT)/lib -L$(OPENSSL_ROOT)/lib -lcrypto -ldl -lcurl -lz
-+LIBS=-lpthread -L$(CURL_ROOT)/lib -L$(OPENSSL_ROOT)/lib -lcrypto -lcurl -lz
-
- # Following ld flags as well as C flag -ffunction-sections are a quest to
- # eliminate unused functions from final link.
-@@ -848,7 +848,7 @@
- @$(ECHO)
- @$(ECHO) "to make sure the zxid CGI script can write to the $(ZXID_PATH)"
- @$(ECHO) "directory (substitute nobody with the user your web server runs as)."
-- @$(ECHO)/
-+ @$(ECHO)
+ CFLAGS += -ffunction-sections -fdata-sections
+@@ -1090,11 +1090,6 @@
install: zxid libzxid.a libzxid.so.0.0 dir
@$(ECHO) "===== Installing in $(PREFIX) (to change do make install PREFIX=/your/path)"
+- -mkdir -p $(PREFIX) $(PREFIX)/bin $(PREFIX)/lib $(PREFIX)/include/zxid
+- cp zxidhlo zxididp $(PREFIX)/bin
+- cp libzxid.a libzxid.so* $(PREFIX)/lib
+- cp libzxid.so.0.0 $(PREFIX)/lib
+- cp *.h c/*.h $(PREFIX)/include/zxid
+ @$(ECHO) "You will need to copy zxidhlo binary where your web server can find it and"
+ @$(ECHO) "make sure your web server is configured to recognize zxidhlo as a CGI script."
+ @$(ECHO)
diff --git a/security/zxid/files/patch-smime.c b/security/zxid/files/patch-smime.c
new file mode 100644
index 000000000000..94b2728ce673
--- /dev/null
+++ b/security/zxid/files/patch-smime.c
@@ -0,0 +1,12 @@
+--- smime.c.orig 2009-10-16 19:37:47.000000000 +0400
++++ smime.c 2009-10-29 23:46:33.000000000 +0300
+@@ -94,9 +94,6 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+-#ifndef macintosh
+-# include <malloc.h>
+-#endif
+
+ #define DETACHED_SIG_TYPE_FILE "application/x-detached-file-signature-file"
+
diff --git a/security/zxid/files/patch-zxlib.c b/security/zxid/files/patch-zxlib.c
deleted file mode 100644
index 1e75c4615760..000000000000
--- a/security/zxid/files/patch-zxlib.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- zxlib.c.orig Fri Jul 6 06:46:05 2007
-+++ zxlib.c Fri Jul 6 06:46:17 2007
-@@ -15,7 +15,6 @@
-
- //#include <pthread.h>
- #ifndef MACOSX
--#include <malloc.h>
- #endif
- #include <memory.h>
- #include <string.h>
diff --git a/security/zxid/pkg-plist b/security/zxid/pkg-plist
index 973e57142d68..a852b90ab7f8 100644
--- a/security/zxid/pkg-plist
+++ b/security/zxid/pkg-plist
@@ -1,7 +1,12 @@
@comment $FreeBSD$
-bin/zxid
+bin/zxidhlo
+bin/zxididp
include/zxid/errmac.h
+include/zxid/logprint.h
+include/zxid/macglue.h
+include/zxid/platform.h
include/zxid/saml2.h
+include/zxid/smimeutil.h
include/zxid/wsf.h
include/zxid/zx-a-data.h
include/zxid/zx-ac-data.h
@@ -68,6 +73,6 @@ include/zxid/zxidnoswig.h
include/zxid/zxidvers.h
include/zxid/zxwsc.h
lib/libzxid.a
+lib/libzxid.so
lib/libzxid.so.0
-lib/libzxid.so.0.0
@dirrmtry include/zxid