aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-27 21:42:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-27 21:42:39 +0000
commit10c800077edeb14937a316c18a3afec155ae3494 (patch)
tree8a6525b938e45a7aa89dfe1299fb5eb11887a436 /security
parent28639fd6b1576451e9dc73618554f63131eb43d1 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile2
-rw-r--r--security/py-yubioath-desktop/Makefile24
-rw-r--r--security/py-yubioath-desktop/distinfo3
-rw-r--r--security/py-yubioath-desktop/pkg-descr6
-rw-r--r--security/yubioath-desktop/Makefile49
-rw-r--r--security/yubioath-desktop/distinfo3
-rw-r--r--security/yubioath-desktop/pkg-descr5
7 files changed, 58 insertions, 34 deletions
diff --git a/security/Makefile b/security/Makefile
index 3e0c4c7ae0ee..72d32d9a3449 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1057,7 +1057,6 @@
SUBDIR += py-vulndb
SUBDIR += py-yara
SUBDIR += py-yubikey-manager
- SUBDIR += py-yubioath-desktop
SUBDIR += py-zope.app.authentication
SUBDIR += py-zope.app.localpermission
SUBDIR += py-zope.app.principalannotation
@@ -1363,6 +1362,7 @@
SUBDIR += yubico-piv-tool
SUBDIR += yubikey-personalization-gui
SUBDIR += yubikey-piv-manager
+ SUBDIR += yubioath-desktop
SUBDIR += zebedee
SUBDIR += zenmap
SUBDIR += zeronet
diff --git a/security/py-yubioath-desktop/Makefile b/security/py-yubioath-desktop/Makefile
deleted file mode 100644
index 66fae57eca9a..000000000000
--- a/security/py-yubioath-desktop/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= yubioath-desktop
-PORTVERSION= 3.1.0
-CATEGORIES= security python
-MASTER_SITES= CHEESESHOP
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GUI for displaying OATH codes with a Yubikey
-
-LICENSE= GPLv3
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
- pyside${PYTHON_PKGNAMESUFFIX}>0:devel/pyside@${PY_FLAVOR} \
- pcsc-spy:devel/pcsc-lite \
- ${LOCALBASE}/lib/pcsc/drivers/ifd-ccid.bundle/Contents/${OPSYS}/libccid.so:devel/libccid
-
-USES= python:2.7
-USE_PYTHON= autoplist distutils
-
-.include <bsd.port.mk>
diff --git a/security/py-yubioath-desktop/distinfo b/security/py-yubioath-desktop/distinfo
deleted file mode 100644
index 849c91cc1d42..000000000000
--- a/security/py-yubioath-desktop/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1490194353
-SHA256 (yubioath-desktop-3.1.0.tar.gz) = 7caae0fd3b14529476eda3a5660bc050584b298ddc3c8d1adfe221041fa5db49
-SIZE (yubioath-desktop-3.1.0.tar.gz) = 268909
diff --git a/security/py-yubioath-desktop/pkg-descr b/security/py-yubioath-desktop/pkg-descr
deleted file mode 100644
index e4b277b23485..000000000000
--- a/security/py-yubioath-desktop/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-The Yubico Authenticator is a graphical desktop tool and command line tool for
-generating Open AuTHentication (OATH) event-based HOTP and time-based TOTP
-one-time password codes, with the help of a YubiKey that protects the shared
-secrets.
-
-WWW: https://developers.yubico.com/yubioath-desktop/
diff --git a/security/yubioath-desktop/Makefile b/security/yubioath-desktop/Makefile
new file mode 100644
index 000000000000..d3e8705f28ba
--- /dev/null
+++ b/security/yubioath-desktop/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= yubioath-desktop
+DISTVERSIONPREFIX= yubioath-desktop-
+DISTVERSION= 4.3.4
+CATEGORIES= security
+
+MAINTAINER= daniel@shafer.cc
+COMMENT= GUI for displaying OATH codes with a Yubikey
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yubikey-manager>=0.7.0:security/py-yubikey-manager@${PY_FLAVOR} \
+ pyotherside-qt5>0:devel/pyotherside-qt5 \
+ RSA_SecurID_getpasswd:devel/libccid \
+ libffi>0:devel/libffi \
+ pcscd:devel/pcsc-lite \
+ swig30>0:devel/swig30
+
+USES= desktop-file-utils gl python:3.5+ qmake qt:5 shebangfix ssl
+USE_GL= gl
+USE_QT= core declarative gui network quickcontrols svg widgets buildtools_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= Yubico
+
+SHEBANG_FILES= build_qrc.py \
+ py/yubikey.py \
+ compute-version.py
+
+PLIST_FILES= bin/yubioath-desktop \
+ share/applications/yubioath-desktop.desktop \
+ share/pixmaps/yubioath.png
+
+post-patch:
+ @${REINPLACE_CMD} -e '/buildqrc.commands/s|python|${PYTHON_CMD}|g' \
+ -e '/PYTHON3_BINARY_NAME/s|python3|${PYTHON_CMD}|g' \
+ -e '/system(python/s|python|${PYTHON_CMD}|g' \
+ -e '/VERSION =/s|VERSION|#VERSION|g' \
+ ${WRKSRC}/yubioath-desktop.pro
+ @${REINPLACE_CMD} -e '/version/s|python3|${PYTHON_CMD}|g' ${WRKSRC}/dev-util/package-sources.sh
+ @${REINPLACE_CMD} -e 's|target.path = /usr/bin|target.path = ${PREFIX}/bin|g' ${WRKSRC}/deployment.pri
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/resources/yubioath-desktop.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/resources/icons/yubioath.png ${STAGEDIR}${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/security/yubioath-desktop/distinfo b/security/yubioath-desktop/distinfo
new file mode 100644
index 000000000000..2d5b23268d05
--- /dev/null
+++ b/security/yubioath-desktop/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543816167
+SHA256 (Yubico-yubioath-desktop-yubioath-desktop-4.3.4_GH0.tar.gz) = b7d7843e396ae7de489df1693ef0dbc6e5576897ffd8196cbb53f83c116d3605
+SIZE (Yubico-yubioath-desktop-yubioath-desktop-4.3.4_GH0.tar.gz) = 237503
diff --git a/security/yubioath-desktop/pkg-descr b/security/yubioath-desktop/pkg-descr
new file mode 100644
index 000000000000..874225875fee
--- /dev/null
+++ b/security/yubioath-desktop/pkg-descr
@@ -0,0 +1,5 @@
+Cross-platform application for generating Open Authentication (OATH) time-based
+TOTP and event-based HOTP one-time password codes, with the help of a YubiKey
+that protects the shared secrets.
+
+WWW: https://developers.yubico.com/yubioath-desktop/