aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-05-25 15:17:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-05-25 15:17:34 +0000
commit225ef8f48e33486928e78775609cfde05ed8d0dc (patch)
treeb4b5c0e2736f82372e9c0383072018e2a2216cbf /security
parent270f22115d34e4001d0ccb13d7aed63906455dd2 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 652e98da6823..23008e30ae4c 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,14 +6,6 @@
#
PORTNAME= openssl
-.if !defined(WITHOUT_OPENSSL_097) && !defined(WITH_OPENSSL_BETA)
-.if !defined(OSVERSION6)
-OSVERSION6!= make OSVERSION6=0 -V OSVERSION
-.endif
-.if ( ${OSVERSION6} >= 600000 ) && ( ${OSVERSION6} < 600100 )
-WITH_OPENSSL_097= yes
-.endif
-.endif
.if defined(WITH_OPENSSL_SNAPSHOT)
PORTVERSION= 0.9.8
PORTREVISION!= date -v-1d +%Y%m%d
@@ -23,7 +15,7 @@ PORTVERSION= 0.9.7j
PORTREVISION?= 0
.else
PORTVERSION= 0.9.8b
-PORTREVISION?= 0
+PORTREVISION?= 1
.endif
.endif
CATEGORIES= security devel
@@ -60,13 +52,11 @@ NO_LATEST_LINK= yes
BETA_SUFFIX= -stable
PLIST_SUB+= OPENSSL_BETA="@comment "
PLIST_SUB+= OPENSSL_STABLE=""
-OPENSSL_SHLIBVER?= 3
CONFLICTS?= openssl-0.* openssl-beta-0.*
.else
PATCHDIR= ${MASTERDIR}/files-beta
PLIST_SUB+= OPENSSL_BETA=""
PLIST_SUB+= OPENSSL_STABLE="@comment "
-OPENSSL_SHLIBVER?= 4
CONFLICTS?= openssl-beta-0.* openssl-stable-0.*
.endif
@@ -898,6 +888,20 @@ MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=-Bforcearchive
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
.endif
+.if defined(WITH_OPENSSL_097) || defined(WITH_OPENSSL_STABLE)
+.if ( ${OSVERSION} >= 600100 )
+OPENSSL_SHLIBVER?= 4
+.else
+OPENSSL_SHLIBVER?= 3
+.endif
+.else
+.if ( ${OSVERSION} >= 600100 )
+OPENSSL_SHLIBVER?= 5
+.else
+OPENSSL_SHLIBVER?= 4
+.endif
+.endif
+
# disable runtime SSE2 detection
.if defined(WITHOUT_OPENSSL_SSE2)
EXTRACONFIGURE+= no-sse2