aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-12-07 17:03:31 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-12-07 17:03:31 +0000
commit3cb3192a5a2879ca28123d481e86ea57f5cbb10c (patch)
tree26b3d2a62fdaf623fac8f2637e0386780b00b305 /security
parent8492d9b7145987f43f057d86dadfc98dc8641802 (diff)
downloadports-3cb3192a5a2879ca28123d481e86ea57f5cbb10c.tar.gz
ports-3cb3192a5a2879ca28123d481e86ea57f5cbb10c.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/smurflog/Makefile28
-rw-r--r--security/smurflog/pkg-plist2
2 files changed, 19 insertions, 11 deletions
diff --git a/security/smurflog/Makefile b/security/smurflog/Makefile
index 0ae23cc584b6..ac487cb444c8 100644
--- a/security/smurflog/Makefile
+++ b/security/smurflog/Makefile
@@ -1,22 +1,32 @@
-# Ports collection Makefile for: smurflog
-# Date created: 7/06/1998
-# Whom: nectar@FreeBSD.org
-#
+# Created by: nectar@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= smurflog
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= security
-#MASTER_SITES= None available anymore, so this is stored locally
+MASTER_SITES= PACKETSTORM/UNIX/loggers
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to assist logging of smurf attacks
-GNU_CONFIGURE= YES
+USE_CSTD= gnu89
+GNU_CONFIGURE= yes
+
+PORTDOCS= README
+PLIST_FILES= sbin/smurflog
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS=|#CFLAGS=|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/strip/d' ${WRKSRC}/Makefile.in
do-install:
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.smurflog
- ${INSTALL_PROGRAM} ${WRKSRC}/smurflog ${PREFIX}/sbin/smurflog
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} smurflog ${PREFIX}/sbin)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR})
+.endif
.include <bsd.port.mk>
diff --git a/security/smurflog/pkg-plist b/security/smurflog/pkg-plist
index 123091e8ba40..e69de29bb2d1 100644
--- a/security/smurflog/pkg-plist
+++ b/security/smurflog/pkg-plist
@@ -1,2 +0,0 @@
-sbin/smurflog
-share/doc/README.smurflog