aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-05-03 20:22:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-05-03 20:22:55 +0000
commit71a7a974130b6d94683dfed3d62a02beed03ed08 (patch)
tree80ecde3640f6c22c3539a5d3fd995832480462cf /security
parente8dfa6b40375280a56d666fb3bbb96bb8a46c928 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/clamav-devel/Makefile33
-rw-r--r--security/clamav-devel/distinfo4
-rw-r--r--security/clamav-devel/pkg-descr10
-rw-r--r--security/clamav-devel/pkg-plist5
4 files changed, 29 insertions, 23 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 6afd984d9845..55f3cea7f941 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clamav
-PORTVERSION= 20040419
+PORTVERSION= 20040503
CATEGORIES= security
MASTER_SITES= http://clamav.sourceforge.net/snapshot/
PKGNAMESUFFIX= -devel
@@ -31,9 +31,14 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_AUTOCONF_VER=257
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
+USE_RC_SUBR= yes
CONFIGURE_ARGS= --with-dbdir=${DATADIR} \
- --disable-clamav --enable-bigstack
+ --disable-clamuko \
+ --disable-clamav \
+ --enable-bigstack \
+ --disable-dependency-tracking
+CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
@@ -65,6 +70,7 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(PidFile) .*$$|\1 /var/run/clamav/clamd.pid|' \
-e 's|^\#?(LocalSocket) .*$$|\1 ${CLAMAV_CLAMD_SOCKET}|' \
-e 's|^\#?(User) .*$$|\1 ${CLAMAVUSER}|' \
+ -e 's|^\#?(AllowSupplementaryGroups)$$|\1|' \
-e 's|^\#?(ScanMail)$$|\1|' \
-e 's|^\#?(Checks)$$|\#\1|' \
-e 's|^\#?(DatabaseDirectory) .*$$|\1 ${DATADIR}|' \
@@ -72,9 +78,6 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(UpdateLogFile) .*$$|\1 /var/log/clamav/freshclam.log|' \
-e 's|^\#?(FixStaleSocket)$$|\1|'
-.include <bsd.port.pre.mk>
-
-USE_RC_SUBR= yes
RC_DIR= ${PREFIX}/etc/rc.d
RC_SUFX= .sh
SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
@@ -83,21 +86,23 @@ SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
PLIST_SUB+= RC_DIR=${RC_DIR} \
RC_SUFX=${RC_SUFX}
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 501001
-# compiles only with optimizer
-CFLAGS+= -O
+# compiles only with libcipher
LDFLAGS+= -lcipher
.endif
.if defined(WITH_MILTER)
-.if exists(${LOCALBASE}/lib/libmilter.a)
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
-.endif
+.if exists(/usr/lib/libmilter.a) || exists(${LOCALBASE}/lib/libmilter.a)
CONFIGURE_ARGS+= --enable-milter
-PLIST_SUB+= CLAMAV-MILTER:=""
+PLIST_SUB+= CLAMAV-MILTER=""
+.else
+BROKEN= requires Sendmail 8.12
+PLIST_SUB+= CLAMAV-MILTER="@comment "
+.endif
.else
-PLIST_SUB+= CLAMAV-MILTER:="@comment "
+PLIST_SUB+= CLAMAV-MILTER="@comment "
.endif
post-patch:
@@ -121,7 +126,7 @@ post-build:
@${SED} ${SED_SCRIPT} ${FILESDIR}/freshclam.sh > ${WRKDIR}/freshclam.sh
pre-install:
- ${SETENV} PKG_PREFIX=${PREFIX} \
+ @${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PREFIX} PRE-INSTALL
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/security/clamav-devel/distinfo b/security/clamav-devel/distinfo
index 3e45fa92d43c..78df3325b2ad 100644
--- a/security/clamav-devel/distinfo
+++ b/security/clamav-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (clamav-devel-20040419.tar.gz) = 57e4348a60ff7e779b74d92be5bf8513
-SIZE (clamav-devel-20040419.tar.gz) = 1313229
+MD5 (clamav-devel-20040503.tar.gz) = 26de36cc374df6e076dc489b2c1ad0ef
+SIZE (clamav-devel-20040503.tar.gz) = 1338089
diff --git a/security/clamav-devel/pkg-descr b/security/clamav-devel/pkg-descr
index cb4a225ffc75..fa040724200a 100644
--- a/security/clamav-devel/pkg-descr
+++ b/security/clamav-devel/pkg-descr
@@ -1,8 +1,8 @@
-This is a snapshot version of Clam Antivirus. Clam Antivirus
-is a command line virus scanner written entirely in C its
-database is kept up to date. It also detects polymorphic
-viruses, scans compressed files and is supported by AMaViS.
+This is a snapshot version of Clam Antivirus.
+Clam Antivirus is command line virus scanner written entirely in C
+and its database is kept up to date. It also detects polymorphic
+viruses, scans compressed files and supported by AMaViS.
Optionally you can use the clamav-milter interface to connect
clamav with sendmail.
-WWW: http://clamav.net/
+WWW: http://www.clamav.net/
diff --git a/security/clamav-devel/pkg-plist b/security/clamav-devel/pkg-plist
index 6913f9152a7a..1e2afa155eeb 100644
--- a/security/clamav-devel/pkg-plist
+++ b/security/clamav-devel/pkg-plist
@@ -1,11 +1,12 @@
+@unexec [ ! -f /var/run/clamav/clamd.pid ] || %%RC_DIR%%/clamd%%RC_SUFX%% stop || true
bin/clamscan
bin/clamdscan
bin/freshclam
bin/sigtool
etc/rc.d/clamav-clamd%%RC_SUFX%%
etc/rc.d/freshclam%%RC_SUFX%%
-%%CLAMAV-MILTER:%%etc/rc.d/clamav-milter%%RC_SUFX%%
-%%CLAMAV-MILTER:%%sbin/clamav-milter
+%%CLAMAV-MILTER%%etc/rc.d/clamav-milter%%RC_SUFX%%
+%%CLAMAV-MILTER%%sbin/clamav-milter
sbin/clamd
include/clamav.h
lib/libclamav.so.1