aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-29 22:05:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-29 22:05:48 +0000
commit818d69239dd9f96c6100c7201c104f03ff957f5d (patch)
treecf2f86091ccde3930b800fa4b961e0e885ef13e6 /security
parent77abe4a2f099909b75ab26ee0bbd0492ae1aa33b (diff)
downloadports-818d69239dd9f96c6100c7201c104f03ff957f5d.tar.gz
ports-818d69239dd9f96c6100c7201c104f03ff957f5d.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/rkhunter/Makefile2
-rw-r--r--security/rkhunter/distinfo4
-rw-r--r--security/rkhunter/files/patch-installer.sh24
-rw-r--r--security/rkhunter/files/patch-rkhunter.conf13
4 files changed, 26 insertions, 17 deletions
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
index c63a5c6734c8..a7a60b51d4c6 100644
--- a/security/rkhunter/Makefile
+++ b/security/rkhunter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rkhunter
-PORTVERSION= 1.1.4
+PORTVERSION= 1.1.7
CATEGORIES= security
MASTER_SITES= http://downloads.rootkit.nl/
diff --git a/security/rkhunter/distinfo b/security/rkhunter/distinfo
index c4c4871ed3c2..f0461e963014 100644
--- a/security/rkhunter/distinfo
+++ b/security/rkhunter/distinfo
@@ -1,2 +1,2 @@
-MD5 (rkhunter-1.1.4.tar.gz) = 08938c110c8363c62c82dad0571517d0
-SIZE (rkhunter-1.1.4.tar.gz) = 102147
+MD5 (rkhunter-1.1.7.tar.gz) = 95e8eeb46f0f2cd928180ac9cfb2dbb0
+SIZE (rkhunter-1.1.7.tar.gz) = 108223
diff --git a/security/rkhunter/files/patch-installer.sh b/security/rkhunter/files/patch-installer.sh
index 287a1f3249ae..609c597ef181 100644
--- a/security/rkhunter/files/patch-installer.sh
+++ b/security/rkhunter/files/patch-installer.sh
@@ -1,5 +1,5 @@
---- installer.sh.old Sun Aug 8 00:16:28 2004
-+++ installer.sh Sun Aug 8 00:21:52 2004
+--- installer.sh.orig Fri Aug 20 15:11:04 2004
++++ installer.sh Sun Aug 29 23:56:46 2004
@@ -120,15 +120,12 @@
overwrite:programs_good.dat:/db/programs_good.dat:Database%%Program%%versions
overwrite:defaulthashes.dat:/db/defaulthashes.dat:Database%%Default%%file%%hashes
@@ -11,7 +11,7 @@
# Prefix: INSTALLDIR
INSTALLFILES2="
--overwrite:rkhunter.conf:/usr/local/etc/rkhunter.conf:RK%%Hunter%%configuration%%file
+-nooverwrite:rkhunter.conf:/usr/local/etc/rkhunter.conf:RK%%Hunter%%configuration%%file
-overwrite:rkhunter:/usr/local/bin/rkhunter:RK%%Hunter%%binary
+overwrite:rkhunter.conf:/etc/rkhunter.conf.sample:RK%%Hunter%%configuration%%file
+overwrite:rkhunter:/bin/rkhunter:RK%%Hunter%%binary
@@ -39,34 +39,36 @@
echo "${INSTALLER_NAME} ${INSTALLER_VERSION} (${INSTALLER_COPYRIGHT})"
echo $ECHOOPT "---------------"
echo "Starting installation/update"
-@@ -470,7 +461,7 @@
- if [ -f ${INSTALLPREFIX}${CURFILE} ]
- then
+@@ -469,7 +460,7 @@
+ echo "Skipped (no overwrite)"
+ else
#error redirection in .rkhunter it's just for a clear display if user run not as root
- cp -f ${INSTALLPREFIX}${CURFILE} ${NEWFILE} 2> ~/.rkhunter.log
+ cp -f ${INSTALLPREFIX}${CURFILE} "${INSTALLDIR}/${NEWFILE}" 2> ~/.rkhunter.log
if [ $? -eq 0 ]
then
echo $E "OK"
-@@ -485,10 +476,10 @@
-
+@@ -483,11 +474,11 @@
done
+ # Installation dir to configuration file
-INSTALLDIRCHECK=`cat /usr/local/etc/rkhunter.conf | grep "INSTALLDIR="`
-+INSTALLDIRCHECK=`cat $INSTALLDIR/etc/rkhunter.conf.sample | grep "INSTALLDIR="`
++INSTALLDIRCHECK=`cat $INSTALLDIR/etc/rkhunter.conf | grep "INSTALLDIR="`
if [ "${INSTALLDIRCHECK}" = "" ]
then
+- echo "" >> /usr/local/etc/rkhunter.conf
- echo "INSTALLDIR=${INSTALLDIR}" >> /usr/local/etc/rkhunter.conf
++ echo "" >> $INSTALLDIR/etc/rkhunter.conf
+ echo "INSTALLDIR=${INSTALLDIR}" >> $INSTALLDIR/etc/rkhunter.conf.sample
echo "Configuration updated with installation path (${INSTALLDIR})"
else
echo "Configuration already updated."
-@@ -498,7 +489,7 @@
+@@ -497,7 +488,7 @@
then
echo ""
echo $E "$t17"
- echo "$t18 (/usr/local/bin/rkhunter)"
-+ echo "$t18 (${INSTALLDIR}/bin/rkhunter)"
++ echo "$t18 ($INSTALLDIR/bin/rkhunter)"
else
echo ""
echo $E "$t19"
diff --git a/security/rkhunter/files/patch-rkhunter.conf b/security/rkhunter/files/patch-rkhunter.conf
index 63b7628460d9..3c84b3a4bb29 100644
--- a/security/rkhunter/files/patch-rkhunter.conf
+++ b/security/rkhunter/files/patch-rkhunter.conf
@@ -1,6 +1,6 @@
---- files/rkhunter.conf.orig Sun Jul 25 17:08:25 2004
-+++ files/rkhunter.conf Sun Jul 25 17:08:48 2004
-@@ -8,7 +8,7 @@
+--- files/rkhunter.conf Fri Aug 20 15:02:59 2004
++++ files/rkhunter.conf Sun Aug 29 23:22:13 2004
+@@ -14,7 +14,7 @@
# Use a custom temporary directory (you can override it with the
# --tmpdir parameter)
@@ -9,3 +9,10 @@
# Use a custom database directory (you can override it with the
# --dbdir parameter)
+@@ -25,4 +25,4 @@
+ #MD5WHITELIST=/bin/ps:9bd8bf260adc81d3a43a086fce6b430a
+ #MD5WHITELIST=/bin/ps:404583a6b166c2f7ac1287445a9de6b3
+
+-# The End
+\ No newline at end of file
++# The End