aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-07 09:18:40 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-07 09:18:40 +0000
commit8345350ec1b7bab9b3afd9dc9c472c7b572f91b1 (patch)
tree070a49a059aad8f09ca3bf955eab76fa33a0ef16 /security
parentf8020c7a0ac5316a5ed025df9bdb16a1e2360615 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/fressh/Makefile2
-rw-r--r--security/hpn-ssh/Makefile2
-rw-r--r--security/openssh-portable/Makefile2
-rw-r--r--security/openssh/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/security/fressh/Makefile b/security/fressh/Makefile
index bd9b170a8851..862568c0ca4d 100644
--- a/security/fressh/Makefile
+++ b/security/fressh/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
.if !exists(/usr/lib/libssl.a) || !exists(/usr/lib/libcrypto.a)
.if exists(${LOCALBASE}/lib/libssl.a) && exists(${LOCALBASE}/lib/libcrypto.a)
-LIB_DEPENDS+= ssl.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
MAKE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
RSAGLUE="${RSAGLUE}"
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index ca1133761e69..207cee2ee151 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -86,7 +86,7 @@ post-install:
.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ca1133761e69..207cee2ee151 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -86,7 +86,7 @@ post-install:
.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index a449e9bb666d..5f7db3968b88 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -35,7 +35,7 @@ FIXME= lib/Makefile scp/Makefile sftp/Makefile sftp-server/Makefile \
.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \