aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-05-04 20:14:23 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-05-04 20:14:23 +0000
commit183ab1ee113941574a7d018595a9804a51fc3349 (patch)
treec03dbadbcc63b63a82238b911d2ee68b22496a1e /security
parentd7f32dd1e95fc6e12c1ff4c4e8017e1eb04524f7 (diff)
downloadports-183ab1ee113941574a7d018595a9804a51fc3349.tar.gz
ports-183ab1ee113941574a7d018595a9804a51fc3349.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/vpnc/Makefile4
-rw-r--r--security/vpnc/distinfo4
-rw-r--r--security/vpnc/files/patch-vpnc.c28
-rw-r--r--security/vpnc/pkg-message6
4 files changed, 33 insertions, 9 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 806aed911cff..6251bc77838a 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -7,11 +7,11 @@
PORTNAME= vpnc
PORTVERSION= 0.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
http://dragon.roe.ch/mirrors/distfiles/vpnc/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-rm+zomb-pre8
+DISTNAME= ${PORTNAME}-${PORTVERSION}-rm+zomb-pre9
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${STARTSCRIPT}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/security/vpnc/distinfo b/security/vpnc/distinfo
index ba33476b34d0..5a742f663677 100644
--- a/security/vpnc/distinfo
+++ b/security/vpnc/distinfo
@@ -1,4 +1,4 @@
-MD5 (vpnc-0.2-rm+zomb-pre8.tar.gz) = f6b5c2ffbc0b18df1b56667261d3643b
-SIZE (vpnc-0.2-rm+zomb-pre8.tar.gz) = 51147
+MD5 (vpnc-0.2-rm+zomb-pre9.tar.gz) = 252b565a4cb8a85644fa00fc96d4c3c2
+SIZE (vpnc-0.2-rm+zomb-pre9.tar.gz) = 52182
MD5 (vpnc-wrapper-1.9) = 85ec82bd75095c19d55d29cdfa499d4c
SIZE (vpnc-wrapper-1.9) = 6213
diff --git a/security/vpnc/files/patch-vpnc.c b/security/vpnc/files/patch-vpnc.c
index ea5659a0ac0e..d41d96db8901 100644
--- a/security/vpnc/files/patch-vpnc.c
+++ b/security/vpnc/files/patch-vpnc.c
@@ -1,6 +1,28 @@
---- vpnc.c.orig Sun Apr 25 02:46:23 2004
-+++ vpnc.c Sun Apr 25 02:46:50 2004
-@@ -2036,8 +2036,8 @@
+--- vpnc.c.dist Mon May 3 14:13:05 2004
++++ vpnc.c Mon May 3 14:13:41 2004
+@@ -1527,10 +1527,10 @@
+ reject = ISAKMP_N_ATTRIBUTES_NOT_SUPPORTED;
+ break;
+ }
+- strbuf = xallocc(a->u.lots.length)+1;
++ strbuf = xallocc(a->u.lots.length+1);
+ memcpy(strbuf, a->u.lots.data, a->u.lots.length);
+ addenv("CISCO_DEF_DOMAIN", strbuf);
+- /*free(strbuf); free(): invalid pointer 0x80593f9! FIXME */
++ free(strbuf);
+ break;
+
+ case ISAKMP_MODECFG_ATTRIB_CISCO_BANNER:
+@@ -1538,7 +1538,7 @@
+ reject = ISAKMP_N_ATTRIBUTES_NOT_SUPPORTED;
+ break;
+ }
+- strbuf = xallocc(a->u.lots.length)+1;
++ strbuf = xallocc(a->u.lots.length+1);
+ memcpy(strbuf, a->u.lots.data, a->u.lots.length);
+ addenv("CISCO_BANNER", strbuf);
+ free(strbuf);
+@@ -2162,8 +2162,8 @@
else
read_config_file (argv[i], config, 0);
diff --git a/security/vpnc/pkg-message b/security/vpnc/pkg-message
index 556970dcb16c..25b7f0377345 100644
--- a/security/vpnc/pkg-message
+++ b/security/vpnc/pkg-message
@@ -1,7 +1,9 @@
-If vpnc fails with
+If vpnc under FreeBSD 4 fails with
socket(SOCK_RAW): Protocol not supported
-check your kernel configuration. The ESP protocol is only
+check your kernel configuration. The ESP protocol may be only
enabled for FAST_IPSEC (this cannot be configured together with
IPSEC). See LINT for further details.
+
+Under FreeBSD 5 vpnc should work without any IPSEC enabled.