aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-09 09:07:58 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-09 09:07:58 +0000
commit1d0ed1a69bd517627e602ac5791cf3b50b01ce80 (patch)
tree78b9ff528af13563d04255b5b101812d844fdfcd /security
parent1d83b817cb289c20a6ced077596725053b197d22 (diff)
downloadports-1d0ed1a69bd517627e602ac5791cf3b50b01ce80.tar.gz
ports-1d0ed1a69bd517627e602ac5791cf3b50b01ce80.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/horde-jeta/Makefile65
-rw-r--r--security/horde-jeta/files/pkg-deinstall.in23
-rw-r--r--security/horde-jeta/files/pkg-install.in23
-rw-r--r--security/horde-jeta/files/pkg-message.in20
-rw-r--r--security/horde-jeta/pkg-plist120
-rw-r--r--security/jeta/Makefile65
-rw-r--r--security/jeta/files/pkg-deinstall.in23
-rw-r--r--security/jeta/files/pkg-install.in23
-rw-r--r--security/jeta/files/pkg-message.in20
-rw-r--r--security/jeta/pkg-plist120
10 files changed, 126 insertions, 376 deletions
diff --git a/security/horde-jeta/Makefile b/security/horde-jeta/Makefile
index 4c2160ef6e17..ca764eb12513 100644
--- a/security/horde-jeta/Makefile
+++ b/security/horde-jeta/Makefile
@@ -8,72 +8,13 @@
PORTNAME= jeta
PORTVERSION= 1.0
CATEGORIES= security www
-MASTER_SITES= HORDE
-DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
COMMENT= Horde wrapper around various Java SSH applets
-RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
-
-NO_BUILD= yes
-USE_APACHE= 1.3+ # needed to test APACHE_VERSION
+USE_HORDE= base pkg-message
USE_GETTEXT= yes
-REINPLACE_ARGS= -i.beforeJETA
-
PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES
-CONFFILE= prefs.php conf.xml .htaccess conf.xml.beforeJETA
-SUB_DIRS= config jar lib locale po templates themes
-
-LHORDEDIR?= www/horde
-LJETADIR= ${LHORDEDIR}/jeta
-PEARDIR?= ${LOCALBASE}/share/pear
-
-PLIST_SUB= JETADIR=${LJETADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-install pkg-deinstall
-SUB_LIST= JETADIR=${JETADIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
-
-JETADIR= ${PREFIX}/${LJETADIR}
-CONFDIR= ${JETADIR}/config
-
-PORTREV_H?= ${LOCALBASE}/include/c-client/portrevision.h
-
-.include <bsd.port.pre.mk>
-
-.if ${APACHE_VERSION} >= 20
-HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
-.else
-HORDE_INC= ${LOCALBASE}/etc/horde/
-.endif
-
-post-extract:
- @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
-
-pre-configure:
- @${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
-
-do-install:
- @${INSTALL} -d ${JETADIR}/
-.for REP in ${SUB_DIRS}
- @${CP} -Rp ${WRKSRC}/${REP} ${JETADIR}/
-.endfor
- @${CP} -p ${WRKSRC}/*.php ${JETADIR}/
- @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${JETADIR}/
- @${CHMOD} -R o-rwx ${CONFDIR}/
-
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
-
-post-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
+.include <bsd.port.mk>
diff --git a/security/horde-jeta/files/pkg-deinstall.in b/security/horde-jeta/files/pkg-deinstall.in
deleted file mode 100644
index 9767bd6ef0f7..000000000000
--- a/security/horde-jeta/files/pkg-deinstall.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD:
-#
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls %%JETADIR%%/config/*php`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
- case $? in
- 0) # original config file, delete it
- rm -f $cf
- ;;
- 1) # config file has been updated, leave it alone
- ;;
- *) # not found?
- ;;
- esac
- done
-fi
diff --git a/security/horde-jeta/files/pkg-install.in b/security/horde-jeta/files/pkg-install.in
deleted file mode 100644
index aece92a67bd8..000000000000
--- a/security/horde-jeta/files/pkg-install.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD:
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-case $2 in
- PRE-INSTALL)
- ;;
-
- POST-INSTALL)
- if [ -z "${PACKAGE_BUILDING}" ]; then
- # Copy over sample config files unless they already exist
-
- for cf in `ls %%JETADIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
- if [ ! -f $cf ]; then
- cp -p $cf.dist $cf
- fi
- done
- fi
- ;;
-esac
diff --git a/security/horde-jeta/files/pkg-message.in b/security/horde-jeta/files/pkg-message.in
deleted file mode 100644
index eb5587e696b0..000000000000
--- a/security/horde-jeta/files/pkg-message.in
+++ /dev/null
@@ -1,20 +0,0 @@
-************************************************************************
-Jeta has been installed in %%JETADIR%% with your blank
-configuration files.
-
-Horde must be configured and the tables created; if not, see
-`pkg_info -D -x horde'.
-
-Then, you might have to tune the configuration files located in
-%%CONFDIR%%/.
-
-Then, you must login to Horde as a Horde Administrator to finish the
-configuration. Please read %%DOCSDIR%%/INSTALL.
-
-To protect your configuration files, you have to restart your webserver.
-
-To secure your installation, it is at least recommended that you change
-the default database password used by horde.
-Then, you might change the 'session.save_path' setting in php.ini to a
-directory only readable and writeable by your webserver.
-************************************************************************
diff --git a/security/horde-jeta/pkg-plist b/security/horde-jeta/pkg-plist
index abc4f3639768..0c74f5f445d4 100644
--- a/security/horde-jeta/pkg-plist
+++ b/security/horde-jeta/pkg-plist
@@ -1,60 +1,60 @@
-%%JETADIR%%/config/.htaccess
-%%JETADIR%%/config/conf.xml
-%%JETADIR%%/config/prefs.php.dist
-%%JETADIR%%/config/conf.xml.beforeJETA
-%%JETADIR%%/index.php
-%%JETADIR%%/jar/jta.conf
-%%JETADIR%%/jar/jta26.jar
-%%JETADIR%%/jar/SSHTermApplet-signed.jar
-%%JETADIR%%/jar/SSHTermApplet-jdk1.3.1-dependencies-signed.jar
-%%JETADIR%%/jar/SSHTermApplet-jdkbug-workaround-signed.jar
-%%JETADIR%%/lib/base.php
-%%JETADIR%%/lib/Applet.php
-%%JETADIR%%/lib/.htaccess
-%%JETADIR%%/lib/Applet/jta.php
-%%JETADIR%%/lib/Applet/sshtools.php
-%%JETADIR%%/lib/version.php
-%%JETADIR%%/locale/cs_CZ/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/de_DE/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/en_US/help.xml
-%%JETADIR%%/locale/es_ES/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/fi_FI/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/ro_RO/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/zh_TW/LC_MESSAGES/jeta.mo
-%%JETADIR%%/main.php
-%%JETADIR%%/po/README
-%%JETADIR%%/po/jeta.pot
-%%JETADIR%%/po/cs_CZ.po
-%%JETADIR%%/po/de_DE.po
-%%JETADIR%%/po/es_ES.po
-%%JETADIR%%/po/fi_FI.po
-%%JETADIR%%/po/ro_RO.po
-%%JETADIR%%/po/zh_TW.po
-%%JETADIR%%/templates/common-header.inc
-%%JETADIR%%/templates/main.html
-%%JETADIR%%/test.php
-%%JETADIR%%/themes/graphics/favicon.ico
-%%JETADIR%%/themes/graphics/jeta.png
-@dirrm %%JETADIR%%/themes/graphics
-@dirrm %%JETADIR%%/themes
-@dirrm %%JETADIR%%/templates
-@dirrm %%JETADIR%%/po
-@dirrm %%JETADIR%%/locale/zh_TW/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/zh_TW
-@dirrm %%JETADIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/ro_RO
-@dirrm %%JETADIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/fi_FI
-@dirrm %%JETADIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/es_ES
-@dirrm %%JETADIR%%/locale/en_US
-@dirrm %%JETADIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/de_DE
-@dirrm %%JETADIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/cs_CZ
-@dirrm %%JETADIR%%/locale
-@dirrm %%JETADIR%%/lib/Applet
-@dirrm %%JETADIR%%/lib
-@dirrmtry %%JETADIR%%/config
-@dirrmtry %%JETADIR%%/jar
-@dirrmtry %%JETADIR%%
+%%HORDIR%%/config/.htaccess
+%%HORDIR%%/config/conf.xml
+%%HORDIR%%/config/prefs.php.dist
+%%HORDIR%%/index.php
+%%HORDIR%%/jar/SSHTermApplet-jdk1.3.1-dependencies-signed.jar
+%%HORDIR%%/jar/SSHTermApplet-jdkbug-workaround-signed.jar
+%%HORDIR%%/jar/SSHTermApplet-signed.jar
+%%HORDIR%%/jar/jta.conf
+%%HORDIR%%/jar/jta26.jar
+%%HORDIR%%/lib/.htaccess
+%%HORDIR%%/lib/Applet/jta.php
+%%HORDIR%%/lib/Applet/sshtools.php
+%%HORDIR%%/lib/Applet.php
+%%HORDIR%%/lib/base.php
+%%HORDIR%%/lib/version.php
+%%HORDIR%%/locale/cs_CZ/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/de_DE/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/en_US/help.xml
+%%HORDIR%%/locale/es_ES/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/fi_FI/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/ro_RO/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/zh_TW/LC_MESSAGES/jeta.mo
+%%HORDIR%%/main.php
+%%HORDIR%%/po/README
+%%HORDIR%%/po/cs_CZ.po
+%%HORDIR%%/po/de_DE.po
+%%HORDIR%%/po/es_ES.po
+%%HORDIR%%/po/fi_FI.po
+%%HORDIR%%/po/jeta.pot
+%%HORDIR%%/po/ro_RO.po
+%%HORDIR%%/po/zh_TW.po
+%%HORDIR%%/templates/common-header.inc
+%%HORDIR%%/templates/main.html
+%%HORDIR%%/test.php
+%%HORDIR%%/themes/graphics/favicon.ico
+%%HORDIR%%/themes/graphics/jeta.png
+@dirrmtry %%HORDIR%%/config
+@dirrm %%HORDIR%%/jar
+@dirrm %%HORDIR%%/lib/Applet
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/cs_CZ
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/en_US
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_TW
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/themes/graphics
+@dirrm %%HORDIR%%/themes
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%
diff --git a/security/jeta/Makefile b/security/jeta/Makefile
index 4c2160ef6e17..ca764eb12513 100644
--- a/security/jeta/Makefile
+++ b/security/jeta/Makefile
@@ -8,72 +8,13 @@
PORTNAME= jeta
PORTVERSION= 1.0
CATEGORIES= security www
-MASTER_SITES= HORDE
-DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
COMMENT= Horde wrapper around various Java SSH applets
-RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
-
-NO_BUILD= yes
-USE_APACHE= 1.3+ # needed to test APACHE_VERSION
+USE_HORDE= base pkg-message
USE_GETTEXT= yes
-REINPLACE_ARGS= -i.beforeJETA
-
PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES
-CONFFILE= prefs.php conf.xml .htaccess conf.xml.beforeJETA
-SUB_DIRS= config jar lib locale po templates themes
-
-LHORDEDIR?= www/horde
-LJETADIR= ${LHORDEDIR}/jeta
-PEARDIR?= ${LOCALBASE}/share/pear
-
-PLIST_SUB= JETADIR=${LJETADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-install pkg-deinstall
-SUB_LIST= JETADIR=${JETADIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
-
-JETADIR= ${PREFIX}/${LJETADIR}
-CONFDIR= ${JETADIR}/config
-
-PORTREV_H?= ${LOCALBASE}/include/c-client/portrevision.h
-
-.include <bsd.port.pre.mk>
-
-.if ${APACHE_VERSION} >= 20
-HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
-.else
-HORDE_INC= ${LOCALBASE}/etc/horde/
-.endif
-
-post-extract:
- @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
-
-pre-configure:
- @${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
-
-do-install:
- @${INSTALL} -d ${JETADIR}/
-.for REP in ${SUB_DIRS}
- @${CP} -Rp ${WRKSRC}/${REP} ${JETADIR}/
-.endfor
- @${CP} -p ${WRKSRC}/*.php ${JETADIR}/
- @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${JETADIR}/
- @${CHMOD} -R o-rwx ${CONFDIR}/
-
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
-
-post-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
+.include <bsd.port.mk>
diff --git a/security/jeta/files/pkg-deinstall.in b/security/jeta/files/pkg-deinstall.in
deleted file mode 100644
index 9767bd6ef0f7..000000000000
--- a/security/jeta/files/pkg-deinstall.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD:
-#
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls %%JETADIR%%/config/*php`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
- case $? in
- 0) # original config file, delete it
- rm -f $cf
- ;;
- 1) # config file has been updated, leave it alone
- ;;
- *) # not found?
- ;;
- esac
- done
-fi
diff --git a/security/jeta/files/pkg-install.in b/security/jeta/files/pkg-install.in
deleted file mode 100644
index aece92a67bd8..000000000000
--- a/security/jeta/files/pkg-install.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD:
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-case $2 in
- PRE-INSTALL)
- ;;
-
- POST-INSTALL)
- if [ -z "${PACKAGE_BUILDING}" ]; then
- # Copy over sample config files unless they already exist
-
- for cf in `ls %%JETADIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
- if [ ! -f $cf ]; then
- cp -p $cf.dist $cf
- fi
- done
- fi
- ;;
-esac
diff --git a/security/jeta/files/pkg-message.in b/security/jeta/files/pkg-message.in
deleted file mode 100644
index eb5587e696b0..000000000000
--- a/security/jeta/files/pkg-message.in
+++ /dev/null
@@ -1,20 +0,0 @@
-************************************************************************
-Jeta has been installed in %%JETADIR%% with your blank
-configuration files.
-
-Horde must be configured and the tables created; if not, see
-`pkg_info -D -x horde'.
-
-Then, you might have to tune the configuration files located in
-%%CONFDIR%%/.
-
-Then, you must login to Horde as a Horde Administrator to finish the
-configuration. Please read %%DOCSDIR%%/INSTALL.
-
-To protect your configuration files, you have to restart your webserver.
-
-To secure your installation, it is at least recommended that you change
-the default database password used by horde.
-Then, you might change the 'session.save_path' setting in php.ini to a
-directory only readable and writeable by your webserver.
-************************************************************************
diff --git a/security/jeta/pkg-plist b/security/jeta/pkg-plist
index abc4f3639768..0c74f5f445d4 100644
--- a/security/jeta/pkg-plist
+++ b/security/jeta/pkg-plist
@@ -1,60 +1,60 @@
-%%JETADIR%%/config/.htaccess
-%%JETADIR%%/config/conf.xml
-%%JETADIR%%/config/prefs.php.dist
-%%JETADIR%%/config/conf.xml.beforeJETA
-%%JETADIR%%/index.php
-%%JETADIR%%/jar/jta.conf
-%%JETADIR%%/jar/jta26.jar
-%%JETADIR%%/jar/SSHTermApplet-signed.jar
-%%JETADIR%%/jar/SSHTermApplet-jdk1.3.1-dependencies-signed.jar
-%%JETADIR%%/jar/SSHTermApplet-jdkbug-workaround-signed.jar
-%%JETADIR%%/lib/base.php
-%%JETADIR%%/lib/Applet.php
-%%JETADIR%%/lib/.htaccess
-%%JETADIR%%/lib/Applet/jta.php
-%%JETADIR%%/lib/Applet/sshtools.php
-%%JETADIR%%/lib/version.php
-%%JETADIR%%/locale/cs_CZ/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/de_DE/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/en_US/help.xml
-%%JETADIR%%/locale/es_ES/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/fi_FI/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/ro_RO/LC_MESSAGES/jeta.mo
-%%JETADIR%%/locale/zh_TW/LC_MESSAGES/jeta.mo
-%%JETADIR%%/main.php
-%%JETADIR%%/po/README
-%%JETADIR%%/po/jeta.pot
-%%JETADIR%%/po/cs_CZ.po
-%%JETADIR%%/po/de_DE.po
-%%JETADIR%%/po/es_ES.po
-%%JETADIR%%/po/fi_FI.po
-%%JETADIR%%/po/ro_RO.po
-%%JETADIR%%/po/zh_TW.po
-%%JETADIR%%/templates/common-header.inc
-%%JETADIR%%/templates/main.html
-%%JETADIR%%/test.php
-%%JETADIR%%/themes/graphics/favicon.ico
-%%JETADIR%%/themes/graphics/jeta.png
-@dirrm %%JETADIR%%/themes/graphics
-@dirrm %%JETADIR%%/themes
-@dirrm %%JETADIR%%/templates
-@dirrm %%JETADIR%%/po
-@dirrm %%JETADIR%%/locale/zh_TW/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/zh_TW
-@dirrm %%JETADIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/ro_RO
-@dirrm %%JETADIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/fi_FI
-@dirrm %%JETADIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/es_ES
-@dirrm %%JETADIR%%/locale/en_US
-@dirrm %%JETADIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/de_DE
-@dirrm %%JETADIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%JETADIR%%/locale/cs_CZ
-@dirrm %%JETADIR%%/locale
-@dirrm %%JETADIR%%/lib/Applet
-@dirrm %%JETADIR%%/lib
-@dirrmtry %%JETADIR%%/config
-@dirrmtry %%JETADIR%%/jar
-@dirrmtry %%JETADIR%%
+%%HORDIR%%/config/.htaccess
+%%HORDIR%%/config/conf.xml
+%%HORDIR%%/config/prefs.php.dist
+%%HORDIR%%/index.php
+%%HORDIR%%/jar/SSHTermApplet-jdk1.3.1-dependencies-signed.jar
+%%HORDIR%%/jar/SSHTermApplet-jdkbug-workaround-signed.jar
+%%HORDIR%%/jar/SSHTermApplet-signed.jar
+%%HORDIR%%/jar/jta.conf
+%%HORDIR%%/jar/jta26.jar
+%%HORDIR%%/lib/.htaccess
+%%HORDIR%%/lib/Applet/jta.php
+%%HORDIR%%/lib/Applet/sshtools.php
+%%HORDIR%%/lib/Applet.php
+%%HORDIR%%/lib/base.php
+%%HORDIR%%/lib/version.php
+%%HORDIR%%/locale/cs_CZ/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/de_DE/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/en_US/help.xml
+%%HORDIR%%/locale/es_ES/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/fi_FI/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/ro_RO/LC_MESSAGES/jeta.mo
+%%HORDIR%%/locale/zh_TW/LC_MESSAGES/jeta.mo
+%%HORDIR%%/main.php
+%%HORDIR%%/po/README
+%%HORDIR%%/po/cs_CZ.po
+%%HORDIR%%/po/de_DE.po
+%%HORDIR%%/po/es_ES.po
+%%HORDIR%%/po/fi_FI.po
+%%HORDIR%%/po/jeta.pot
+%%HORDIR%%/po/ro_RO.po
+%%HORDIR%%/po/zh_TW.po
+%%HORDIR%%/templates/common-header.inc
+%%HORDIR%%/templates/main.html
+%%HORDIR%%/test.php
+%%HORDIR%%/themes/graphics/favicon.ico
+%%HORDIR%%/themes/graphics/jeta.png
+@dirrmtry %%HORDIR%%/config
+@dirrm %%HORDIR%%/jar
+@dirrm %%HORDIR%%/lib/Applet
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/cs_CZ
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/en_US
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_TW
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/themes/graphics
+@dirrm %%HORDIR%%/themes
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%