aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-08-23 12:39:43 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-08-23 12:39:43 +0000
commit38ec7d50e7005de8a694496d886fbafad08ee1bd (patch)
tree5caab9b4cad6acf4cf75ce52347029bcadf443ee /security
parent8ef5e1ca023ed9d2f6c6eb0dd46a81f7cac07998 (diff)
downloadports-38ec7d50e7005de8a694496d886fbafad08ee1bd.tar.gz
ports-38ec7d50e7005de8a694496d886fbafad08ee1bd.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/avcheck/Makefile43
-rw-r--r--security/avcheck/distinfo1
-rw-r--r--security/avcheck/pkg-comment1
-rw-r--r--security/avcheck/pkg-descr22
-rw-r--r--security/avcheck/pkg-plist12
6 files changed, 80 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4e8efde19d1e..8611eefd4237 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -13,6 +13,7 @@
SUBDIR += arirang
SUBDIR += audit
SUBDIR += authforce
+ SUBDIR += avcheck
SUBDIR += bcwipe
SUBDIR += beecrypt
SUBDIR += bfbtester
diff --git a/security/avcheck/Makefile b/security/avcheck/Makefile
new file mode 100644
index 000000000000..2181ffe875ea
--- /dev/null
+++ b/security/avcheck/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: avcheck
+# Date created: Fri Jun 14 14:31:42 MSD 2002
+# Whom: dsh@vlink.ru
+#
+# $FreeBSD$
+#
+
+PORTNAME= avcheck
+PORTVERSION= 0.9
+CATEGORIES= security
+MASTER_SITES= http://www.corpit.ru/ftp/avcheck/
+
+MAINTAINER= dsh@vlink.ru
+
+USE_REINPLACE= yes
+
+MAN1= avcheck.1
+
+AVCHECK_DOCS= README.AVP README.AVP.de README.DrWeb README.Exim \
+ README.Postfix README.Postfix.de README.Sendmail eicar.msg \
+ eicar.txt
+AVCHECK_SBINS= avcheck uchroot
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^CC/#CC/g ; s/^CFLAGS/#CFLAGS/g' ${WRKSRC}/Makefile
+
+do-install:
+.for i in ${AVCHECK_SBINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin/
+.endfor
+
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${MANPREFIX}/man/man1/
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${AVCHECK_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/avcheck/distinfo b/security/avcheck/distinfo
new file mode 100644
index 000000000000..671a51d1bcfb
--- /dev/null
+++ b/security/avcheck/distinfo
@@ -0,0 +1 @@
+MD5 (avcheck-0.9.tar.gz) = fba30c3992c97d93d07daeaa46f4df80
diff --git a/security/avcheck/pkg-comment b/security/avcheck/pkg-comment
new file mode 100644
index 000000000000..9133729da9ab
--- /dev/null
+++ b/security/avcheck/pkg-comment
@@ -0,0 +1 @@
+A simple antivirus solution for a mail system
diff --git a/security/avcheck/pkg-descr b/security/avcheck/pkg-descr
new file mode 100644
index 000000000000..f5e248844cdd
--- /dev/null
+++ b/security/avcheck/pkg-descr
@@ -0,0 +1,22 @@
+Avcheck is a simple program that allows you to call an antivirus
+software in order to check mail messages for viruses before actual
+delivery from within a Mail Transfer Agent, or MTA.
+
+Avcheck itself isn't a virusscanner, nor it is an MTA. It sits between
+the MTA and a real antivirus software. Most MTAs available today can
+call an external program for every mail message in order to perform
+various tasks, including virus scanning and content filtering. Avcheck
+can be used as that external program.
+
+Avcheck will receive a mail message from a mail system, pass it to an
+antivirus software, and, depending on the presence of a virus in that
+message, will either allow the message to be delivered or take
+appropriate actions to handle infected mail.
+
+Avcheck does nothing with a mail message contents -- it's task is to
+prepare file with a mail message and feed it to an antivirus
+progra. It's an antivirus task to decode MIME structure, handle
+embedded archives and so on. Many but not all antivirus products today
+have this ability.
+
+WWW: http://www.corpit.ru/avcheck/
diff --git a/security/avcheck/pkg-plist b/security/avcheck/pkg-plist
new file mode 100644
index 000000000000..78dccb787989
--- /dev/null
+++ b/security/avcheck/pkg-plist
@@ -0,0 +1,12 @@
+sbin/avcheck
+sbin/uchroot
+%%PORTDOCS%%share/doc/avcheck/README.AVP
+%%PORTDOCS%%share/doc/avcheck/README.AVP.de
+%%PORTDOCS%%share/doc/avcheck/README.DrWeb
+%%PORTDOCS%%share/doc/avcheck/README.Exim
+%%PORTDOCS%%share/doc/avcheck/README.Postfix
+%%PORTDOCS%%share/doc/avcheck/README.Postfix.de
+%%PORTDOCS%%share/doc/avcheck/README.Sendmail
+%%PORTDOCS%%share/doc/avcheck/eicar.msg
+%%PORTDOCS%%share/doc/avcheck/eicar.txt
+%%PORTDOCS%%@dirrm share/doc/avcheck