aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /security
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/denyhosts/Makefile1
-rw-r--r--security/pssh/Makefile18
-rw-r--r--security/pssh/pkg-plist4
-rw-r--r--security/py-cerealizer/Makefile1
-rw-r--r--security/py-clamav/Makefile1
-rw-r--r--security/py-crack/Makefile4
-rw-r--r--security/py-fchksum/Makefile1
-rw-r--r--security/py-gnupg/Makefile1
-rw-r--r--security/py-gnutls/Makefile1
-rw-r--r--security/py-m2crypto/Makefile1
-rw-r--r--security/py-mcrypt/Makefile1
-rw-r--r--security/py-mhash/Makefile1
-rw-r--r--security/py-openid/Makefile1
-rw-r--r--security/py-openssl/Makefile1
-rw-r--r--security/py-posix1e/Makefile1
-rw-r--r--security/py-pow/Makefile1
-rw-r--r--security/py-twistedConch/Makefile1
-rw-r--r--security/py-xmlsec/Makefile1
-rw-r--r--security/revelation/Makefile2
-rw-r--r--security/umit/Makefile1
-rw-r--r--security/vinetto/Makefile1
21 files changed, 26 insertions, 19 deletions
diff --git a/security/denyhosts/Makefile b/security/denyhosts/Makefile
index 7c94d9a5423a..0ce7a7e97366 100644
--- a/security/denyhosts/Makefile
+++ b/security/denyhosts/Makefile
@@ -18,6 +18,7 @@ COMMENT= Script to thwart ssh attacks
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= DenyHosts
USE_RC_SUBR= denyhosts
SUB_FILES= pkg-message
diff --git a/security/pssh/Makefile b/security/pssh/Makefile
index e3a4d8daf00c..543dc2737c66 100644
--- a/security/pssh/Makefile
+++ b/security/pssh/Makefile
@@ -16,23 +16,9 @@ MASTER_SITE_SUBDIR= brooks
MAINTAINER= brooks@FreeBSD.org
COMMENT= Parallel versions of the openssh tools
-BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
- rsync:${PORTSDIR}/net/rsync
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
USE_PYTHON= YES
-USE_PYDISTUTILS=yes
-
-PLIST_SUB+= PSSH_EGG=${PSSH_EGG} \
- EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
- PSSH_EGG=${PSSH_EGG} \
- EGG="pssh==${PORTVERSION}"
-
-PYDISTUTILS_BUILD_TARGET= bdist_egg
-PYDISTUTILS_INSTALL_TARGET= easy_install
-PYDISTUTILS_INSTALLARGS= -N -O1 -s ${PREFIX}/bin -S ${PYTHON_SITELIBDIR} dist/${PSSH_EGG}
-
-EASY_INSTALL_CMD= easy_install-${PYTHON_VER}
-PSSH_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+USE_PYDISTUTILS=easy_install
.include <bsd.port.mk>
diff --git a/security/pssh/pkg-plist b/security/pssh/pkg-plist
index 0ac9198fbad4..251f21024f2a 100644
--- a/security/pssh/pkg-plist
+++ b/security/pssh/pkg-plist
@@ -1,8 +1,6 @@
-@unexec %%EASY_INSTALL_CMD%% -q -N -m -x -S %D/%%PYTHON_SITELIBDIR%% %%EGG%%
bin/prsync
bin/pnuke
bin/pslurp
bin/pssh
bin/pscp
-%%PYTHON_SITELIBDIR%%/%%PSSH_EGG%%
-@exec %%EASY_INSTALL_CMD%% -q -x -N -S %D/%%PYTHON_SITELIBDIR%% %%EGG%%
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
diff --git a/security/py-cerealizer/Makefile b/security/py-cerealizer/Makefile
index d6b90d124d30..98e4983827de 100644
--- a/security/py-cerealizer/Makefile
+++ b/security/py-cerealizer/Makefile
@@ -19,5 +19,6 @@ COMMENT= Secure pickle-like module
USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Cerealizer
.include <bsd.port.mk>
diff --git a/security/py-clamav/Makefile b/security/py-clamav/Makefile
index 2aacd1349bd1..d4db878ce5ae 100644
--- a/security/py-clamav/Makefile
+++ b/security/py-clamav/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= clamav.2:${PORTSDIR}/security/clamav
DIST_SUBDIR= python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pyclamav
PYDISTUTILS_BUILDARGS= build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/security/py-crack/Makefile b/security/py-crack/Makefile
index f8d3c1b0c206..e8772d7b821b 100644
--- a/security/py-crack/Makefile
+++ b/security/py-crack/Makefile
@@ -33,6 +33,10 @@ CONFIGURE_ENV= "CPPFLAGS=-I${LOCALBASE}/include" \
MAKE_ENV= "CPPFLAGS=-I${LOCALBASE}/include -fPIC" \
"LDFLAGS=-L${LOCALBASE}/lib"
+post-patch:
+ ${REINPLACE_CMD} -e 's/setup(/setup(name="${PORTNAME}",version="${PORTVERSION}",/' \
+ ${WRKSRC}/distutil.py
+
post-install:
${INSTALL_DATA} ${WRKSRC}/crack.py ${PYTHONPREFIX_SITELIBDIR}
diff --git a/security/py-fchksum/Makefile b/security/py-fchksum/Makefile
index fbd49ff39bcb..9c32816a6964 100644
--- a/security/py-fchksum/Makefile
+++ b/security/py-fchksum/Makefile
@@ -19,5 +19,6 @@ COMMENT= Python module to find the checksum of files
PLIST_FILES= %%PYTHON_SITELIBDIR%%/fchksum.so
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-fchksum
.include <bsd.port.mk>
diff --git a/security/py-gnupg/Makefile b/security/py-gnupg/Makefile
index 7f74cc5c8b65..bd6e88793897 100644
--- a/security/py-gnupg/Makefile
+++ b/security/py-gnupg/Makefile
@@ -19,5 +19,6 @@ COMMENT= Python module for GnuPG interface
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= GnuPGInterface
.include <bsd.port.mk>
diff --git a/security/py-gnutls/Makefile b/security/py-gnutls/Makefile
index 5dc245c6c796..e12be8c48367 100644
--- a/security/py-gnutls/Makefile
+++ b/security/py-gnutls/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python_gnutls
EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index fc8abc0c54b5..8161e56b4447 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -21,6 +21,7 @@ USE_PYTHON= 2.3+
USE_PYDISTUTILS=yes
USE_OPENSSL= yes
WITH_OPENSSL_PORT= yes
+PYDISTUTILS_PKGNAME= M2Crypto
.if defined(WITH_OPENSSL_PORT)
PYDISTUTILS_BUILDARGS= --openssl="${LOCALBASE}"
diff --git a/security/py-mcrypt/Makefile b/security/py-mcrypt/Makefile
index 5f3b2cbd83dd..7a55a03ab5ee 100644
--- a/security/py-mcrypt/Makefile
+++ b/security/py-mcrypt/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= mcrypt:${PORTSDIR}/security/libmcrypt
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_BUILDARGS= -L${LOCALBASE}/lib
+PYDISTUTILS_PKGNAME= python-mcrypt
CFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= %%PYTHON_SITELIBDIR%%/mcrypt.so
diff --git a/security/py-mhash/Makefile b/security/py-mhash/Makefile
index ff58dc81efb4..92fe01f1ac4d 100644
--- a/security/py-mhash/Makefile
+++ b/security/py-mhash/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= mhash:${PORTSDIR}/security/mhash
PLIST_FILES= %%PYTHON_SITELIBDIR%%/mhash.so
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= python-mhash
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV= "LDFLAGS=-L${LOCALBASE}/lib"
diff --git a/security/py-openid/Makefile b/security/py-openid/Makefile
index 25aec06becb3..77c82da6dffb 100644
--- a/security/py-openid/Makefile
+++ b/security/py-openid/Makefile
@@ -20,5 +20,6 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/urljr:${PORTSDIR}/www/py-urljr \
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= python-openid
.include <bsd.port.mk>
diff --git a/security/py-openssl/Makefile b/security/py-openssl/Makefile
index ae17806d5db4..26216fa9c670 100644
--- a/security/py-openssl/Makefile
+++ b/security/py-openssl/Makefile
@@ -20,6 +20,7 @@ COMMENT= Python interface to the OpenSSL library
USE_PYTHON= yes
USE_PYTHON_PREFIX= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pyOpenSSL
USE_OPENSSL= yes
.include <bsd.port.mk>
diff --git a/security/py-posix1e/Makefile b/security/py-posix1e/Makefile
index 42ed64582cf6..f5c00c6e1379 100644
--- a/security/py-posix1e/Makefile
+++ b/security/py-posix1e/Makefile
@@ -18,6 +18,7 @@ COMMENT= Python module for manipulating POSIX.1e ACLs
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pylibacl
.include <bsd.port.pre.mk>
diff --git a/security/py-pow/Makefile b/security/py-pow/Makefile
index 170c6039c5a3..843ca977e3d0 100644
--- a/security/py-pow/Makefile
+++ b/security/py-pow/Makefile
@@ -19,6 +19,7 @@ COMMENT= Python OpenSSL Wrappers
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= POW
USE_OPENSSL= yes
PORTDOCS= POW.pdf
diff --git a/security/py-twistedConch/Makefile b/security/py-twistedConch/Makefile
index 5685f1b1ffe5..0fad61db51c6 100644
--- a/security/py-twistedConch/Makefile
+++ b/security/py-twistedConch/Makefile
@@ -21,5 +21,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Conch
.include <bsd.port.mk>
diff --git a/security/py-xmlsec/Makefile b/security/py-xmlsec/Makefile
index e03c96f9fc57..b5dc715d6d41 100644
--- a/security/py-xmlsec/Makefile
+++ b/security/py-xmlsec/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
USE_PYTHON= 2.2+
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= pyxmlsec
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
index 14384867c563..cf054647fb76 100644
--- a/security/revelation/Makefile
+++ b/security/revelation/Makefile
@@ -37,6 +37,8 @@ BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT} \
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|\(rvl_py_version=\)".*$$|\1""|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\(-Wl\)|$$(LDFLAGS) \1|' \
${WRKSRC}/src/wrap/crack/Makefile.in
@${REINPLACE_CMD} -e 's|#include <crack.h>||' \
diff --git a/security/umit/Makefile b/security/umit/Makefile
index a721bf1f75b9..45adb40b12cc 100644
--- a/security/umit/Makefile
+++ b/security/umit/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
USE_BZIP2= yes
USE_PYTHON= yes
USE_GNOME= pygtk2
+INSTALLS_EGGINFO= yes
.include <bsd.port.pre.mk>
diff --git a/security/vinetto/Makefile b/security/vinetto/Makefile
index 561c2ab3e1d0..f63db8766643 100644
--- a/security/vinetto/Makefile
+++ b/security/vinetto/Makefile
@@ -20,6 +20,7 @@ OPTIONS= IMAGING "Build with ability to extract graphic thumbnails" on
USE_PYTHON= 2.3+
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGVERSION= 0.06alpha
.include <bsd.port.pre.mk>