aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /security
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
cleanup: drop support for EOL FreeBSD 11.X
Search criteria used: - 11.4 - OSREL* - OSVER* - *_FreeBSD_11 Input from: - adridg: devel/qca-legacy - jbeich: _WITH_DPRINTF, _WITH_GETLINE, GNU bfd workarounds - sunpoet: security/p5-*OpenSSL* Reviewed by: doceng, kde, multimedia, perl, python, ruby, rust Differential Revision: https://reviews.freebsd.org/D32008 Test Plan: make index
Diffstat (limited to 'security')
-rw-r--r--security/afl++/Makefile4
-rw-r--r--security/botan2/Makefile4
-rw-r--r--security/dsniff/Makefile6
-rw-r--r--security/fwbuilder/Makefile1
-rw-r--r--security/gost-engine/Makefile5
-rw-r--r--security/ipsec-tools/Makefile2
-rw-r--r--security/isal-kmod/Makefile1
-rw-r--r--security/krb5-devel/Makefile2
-rw-r--r--security/libfido2/Makefile1
-rw-r--r--security/liboqs/Makefile1
-rw-r--r--security/libretls/Makefile2
-rw-r--r--security/ncrack/Makefile8
-rw-r--r--security/openiked-portable/Makefile8
-rw-r--r--security/p5-Crypt-OpenSSL-CA/Makefile2
-rw-r--r--security/p5-OpenCA-OpenSSL/Makefile6
-rw-r--r--security/pam_ssh_agent_auth/Makefile1
-rw-r--r--security/pkcs11-tools/Makefile4
-rw-r--r--security/pks/Makefile2
-rw-r--r--security/py-cryptography/Makefile11
-rw-r--r--security/py-openssl/Makefile9
-rw-r--r--security/racoon2/Makefile2
-rw-r--r--security/seahorse/Makefile6
-rw-r--r--security/softhsm2/Makefile2
-rw-r--r--security/tpm2-tools/Makefile8
-rw-r--r--security/uacme/Makefile2
-rw-r--r--security/wpa_supplicant-devel/Makefile2
-rw-r--r--security/zeek/Makefile1
27 files changed, 10 insertions, 93 deletions
diff --git a/security/afl++/Makefile b/security/afl++/Makefile
index 84f06b73fa17..2f662451201f 100644
--- a/security/afl++/Makefile
+++ b/security/afl++/Makefile
@@ -35,10 +35,6 @@ BINARY_ALIAS= install=ginstall
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES GCC LIBDISLOCATOR LLVM PYTHON
OPTIONS_DEFAULT= GCC LIBDISLOCATOR LLVM PYTHON
-# libdislocator fails to build on FreeBSD 11.x
-# error: typedef redefinition with different types ('struct max_align_t' vs '__max_align_t')
-OPTIONS_EXCLUDE_FreeBSD_11= LIBDISLOCATOR
-
# On non-x86 architectures LLVM is mandatory
OPTIONS_SLAVE= ${ARCH:Namd64:Ni386:S/${ARCH}/LLVM/}
OPTIONS_SUB= yes
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 7fd4ef24f366..1d1ce7043755 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -65,10 +65,6 @@ CONFIGURE_ARGS+= --cc-abi="-march=armv8-a+crypto"
CONFIGURE_ARGS+= --cpu="ppc64"
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
-CONFIGURE_ARGS+= --without-os-features=getentropy,elf_aux_info
-.endif
-
.if ${ARCH} == i386 || ${ARCH} == amd64
PLIST_SUB+= HAS_RDRAND_RNG=""
.else
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index a83e453d6d4f..ace01856a675 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -34,11 +34,7 @@ X11_CONFIGURE_WITH=x
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
-USES+= ssl
-.endif
-
-.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085) || ${SSL_DEFAULT} == openssl
+.if ${OPSYS} == FreeBSD || ${SSL_DEFAULT} == openssl
# Requires LibreSSL for old SSL interface
BUILD_DEPENDS+= ${NONEXISTENT}:security/libressl:stage
CPPFLAGS+= -nostdinc -I/usr/include -I${WRKDIR}/libressl/include
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 3963f92060e1..97cfb3211b9c 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -9,7 +9,6 @@ CATEGORIES= security
MAINTAINER= cy@FreeBSD.org
COMMENT= Firewall Builder GUI and policy compilers
-BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: libz library not found
BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: libz library not found
LIB_DEPENDS= libxslt.so:textproc/libxslt \
diff --git a/security/gost-engine/Makefile b/security/gost-engine/Makefile
index efe3f8160bce..a7196c482d49 100644
--- a/security/gost-engine/Makefile
+++ b/security/gost-engine/Makefile
@@ -30,11 +30,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
-BROKEN_SSL+= base
-BROKEN_SSL_REASON_base= needs features only available in OpenSSL 1.1.1+
-.endif
-
post-patch:
${REINPLACE_CMD} 's/-Werror //' ${WRKSRC}/CMakeLists.txt
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 602513817db6..4afe5d46c709 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -100,7 +100,7 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/src/racoon/doc/* ${STAGEDIR}/${DOCSDIR}
.if ${OPSYS} == FreeBSD
-. if ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} != openssl
+. if ${SSL_DEFAULT} != openssl
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ipsec-tools
PLIST_FILES+= include/racoon/openssl_compat.h
. endif
diff --git a/security/isal-kmod/Makefile b/security/isal-kmod/Makefile
index cc026c629c54..635b7c4e6172 100644
--- a/security/isal-kmod/Makefile
+++ b/security/isal-kmod/Makefile
@@ -9,7 +9,6 @@ COMMENT= Kernel crypto driver using Intel(R) ISA-L crypto
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/isa-l_crypto/LICENSE
-IGNORE_FreeBSD_11= requires FreeBSD 13.0 or later
IGNORE_FreeBSD_12= requires FreeBSD 13.0 or later
ONLY_FOR_ARCHS= amd64
diff --git a/security/krb5-devel/Makefile b/security/krb5-devel/Makefile
index af3a0a560c78..21d1ed6786c4 100644
--- a/security/krb5-devel/Makefile
+++ b/security/krb5-devel/Makefile
@@ -15,8 +15,6 @@ PATCH_DIST_STRIP= -p2
MAINTAINER= cy@FreeBSD.org
COMMENT= MIT implementation of RFC 4120 network authentication service
-BROKEN_FreeBSD_11= OpenSSL 1.0.2 is not supported
-
LICENSE= MIT
USE_GITHUB= yes
diff --git a/security/libfido2/Makefile b/security/libfido2/Makefile
index 335e0b4854ee..35ae7d707b56 100644
--- a/security/libfido2/Makefile
+++ b/security/libfido2/Makefile
@@ -15,7 +15,6 @@ LIB_DEPENDS= libcbor.so:devel/libcbor
USES= cmake compiler:c11 pkgconfig ssl
-CFLAGS+= -D_WITH_GETLINE
CMAKE_OFF= FUZZ LIBFUZZER NFC_LINUX USE_HIDAPI USE_WINHELLO
CMAKE_ON= BUILD_EXAMPLES BUILD_MANPAGES BUILD_SHARED_LIBS BUILD_STATIC_LIBS BUILD_TOOLS
diff --git a/security/liboqs/Makefile b/security/liboqs/Makefile
index 7e3a945980c6..0a6aacb4d1fb 100644
--- a/security/liboqs/Makefile
+++ b/security/liboqs/Makefile
@@ -8,7 +8,6 @@ COMMENT= C library for quantum-resistant cryptography
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_FreeBSD_11= Could NOT find OpenSSL, try to set the path to OpenSSL root folder [...]
BROKEN_i386= Unknown or unsupported processor: i386
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
diff --git a/security/libretls/Makefile b/security/libretls/Makefile
index 8b11089b147d..6c9445cf1733 100644
--- a/security/libretls/Makefile
+++ b/security/libretls/Makefile
@@ -8,8 +8,6 @@ COMMENT= TLS library designed to ease writing foolproof applications
LICENSE= ISCL
-BROKEN_FreeBSD_11= requires newer OpenSSL
-
USES= libtool ssl pkgconfig
INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
diff --git a/security/ncrack/Makefile b/security/ncrack/Makefile
index ab6f29e030b3..04cb8e20e660 100644
--- a/security/ncrack/Makefile
+++ b/security/ncrack/Makefile
@@ -19,10 +19,4 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-.include <bsd.port.pre.mk>
-
-.if ${SSL_DEFAULT} == base
-BROKEN_FreeBSD_11= OpenSSL > 1.0 required
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openiked-portable/Makefile b/security/openiked-portable/Makefile
index a65090b7ea04..bd92cd3f4de7 100644
--- a/security/openiked-portable/Makefile
+++ b/security/openiked-portable/Makefile
@@ -19,14 +19,8 @@ USE_RC_SUBR= iked
USERS= _iked
GROUPS= _iked
-.include <bsd.port.pre.mk>
-
-.if ${OSREL:R} < 12 && ${SSL_DEFAULT} == "base"
-BROKEN= requires OpenSSL 1.1.1, upgrade to FreeBSD 12.x/13.x or add DEFAULT_VERSIONS+=ssl=[openssl|libressl*] to /etc/make.conf
-.endif
-
post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/iked.conf \
${STAGEDIR}${PREFIX}/etc/iked.conf.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-CA/Makefile b/security/p5-Crypt-OpenSSL-CA/Makefile
index c96f83e3550d..ef25b7d52089 100644
--- a/security/p5-Crypt-OpenSSL-CA/Makefile
+++ b/security/p5-Crypt-OpenSSL-CA/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ARGS= --openssl-cflags=-L${OPENSSLINC} --openssl-ldflags="-I${OPENSSLL
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base
+.if ${OPSYS} == FreeBSD && (${SSL_DEFAULT} == base || ${SSL_DEFAULT} == openssl)
BROKEN= Does not support OpenSSL 1.1
.endif
diff --git a/security/p5-OpenCA-OpenSSL/Makefile b/security/p5-OpenCA-OpenSSL/Makefile
index 62c018f76b70..0698c2973ed8 100644
--- a/security/p5-OpenCA-OpenSSL/Makefile
+++ b/security/p5-OpenCA-OpenSSL/Makefile
@@ -11,10 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl crypto extension to OpenSSL
-BROKEN_SSL= openssl ${BROKEN_SSL_${OSREL:R}}
+BROKEN_SSL= base openssl
BROKEN_SSL_REASON_openssl= incomplete definition of type 'struct x509_st'
-BROKEN_SSL_12= base
-BROKEN_SSL_13= base
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Locale-libintl>=0:devel/p5-Locale-libintl \
@@ -27,7 +25,7 @@ MAKE_ARGS+= PASTHRU_INC=-I${OPENSSLINC}
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base
+.if ${OPSYS} == FreeBSD && (${SSL_DEFAULT} == base || ${SSL_DEFAULT} == openssl)
BROKEN= Does not support OpenSSL 1.1
.endif
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index 43be893df0b0..5de60f666c38 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -14,7 +14,6 @@ GH_TAGNAME= 7ff7858
GH_TUPLE= floodyberry:ed25519-donna:8757bd4:floodyberry_ed25519_donna/ed25519-donna
BROKEN_mips64= fails to compile: ed25519-donna-portable.h:85:4: Need a uint128_t implementation!
-BROKEN_FreeBSD_11_powerpc64= fails to compile on powerpc64 elfv1: ed25519-donna-portable.h: warning: ALIGN redefined
BROKEN_FreeBSD_12_powerpc64= fails to compile on powerpc64 elfv1: ed25519-donna-portable.h: warning: ALIGN redefined
USES= perl5 ssl tar:bzip2
diff --git a/security/pkcs11-tools/Makefile b/security/pkcs11-tools/Makefile
index 9a7deece7727..c605382b4c50 100644
--- a/security/pkcs11-tools/Makefile
+++ b/security/pkcs11-tools/Makefile
@@ -36,10 +36,6 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
-.if ${SSL_DEFAULT} == base && ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
-BROKEN= OpenSSL version is too old, lacks symbols: error: use of undeclared identifier 'EVP_PKEY_X25519', etc.
-.endif
-
post-extract:
@${RMDIR} ${WRKSRC}/.gnulib ${WRKSRC}/include/oasis-pkcs11
@${MV} ${WRKSRC_gnulib} ${WRKSRC}/.gnulib
diff --git a/security/pks/Makefile b/security/pks/Makefile
index af3c2c3db49c..6849f109f799 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -53,7 +53,7 @@ post-install-DOCS-on:
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base
+.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} == base
BROKEN= Does not build with OpenSSL 1.1
.endif
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 0e8e8337092e..18d7c316f41d 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -45,20 +45,9 @@ TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
# We need to keep old py-cryptography and py-openssl for 11.x release
# due to outdated OpenSSL version in base
-.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} == "base"
-. if ${OSVERSION} >= 1103500 && ${OSVERSION} < 1200085
-# 1103500 352193 2019-09-10 11.3-STABLE got OpenSSL 1.0.2t
-# 1200085 339270 2018-10-19 12.0-STABLE got OpenSSL 1.1.1
-PORTVERSION= 2.9.2
-EXTRA_PATCHES= ${PATCHDIR}/openssl102u
-. endif
-.endif
# Apply LibreSSL upstream patch that conflicts with above patch for 2.9.2
-# XXX convert back to unconditional when FreeBSD 11 goes EOL
-.if ${SSL_DEFAULT:Mlibressl*}
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Fix-build-with-LibreSSL-3.3.2-5988
-.endif
.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
post-patch:
diff --git a/security/py-openssl/Makefile b/security/py-openssl/Makefile
index d32114f89a09..c708b56d4d53 100644
--- a/security/py-openssl/Makefile
+++ b/security/py-openssl/Makefile
@@ -33,15 +33,6 @@ CPE_PRODUCT= py${PORTNAME}
# We need to keep old py-cryptography and py-penssl for 11.x release
# due to outdated OpenSSL version in base
-.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} == "base"
-. if ${OSVERSION} >= 1103500 && ${OSVERSION} < 1200085
-# 1103500 352193 2019-09-10 11.3-STABLE got OpenSSL 1.0.2t
-# 1200085 339270 2018-10-19 12.0-STABLE got OpenSSL 1.1.1
-#.sinclude "${.CURDIR}/Makefile.${OPSYS}-${OSREL:R}"
-PORTVERSION= 19.1.0
-PORTEPOCH= 1
-. endif
-.endif
# These tests will be skipped due the following reasons:
#
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 7fba1a932685..15fa87b3a565 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -10,8 +10,6 @@ RACOON2_COMMIT_DATE=202000908
MAINTAINER= cy@FreeBSD.org
COMMENT= Racoon2 IPsec daemon
-BROKEN_FreeBSD_11= Requires openssl to build
-
CONFLICTS= racoon2-legacy-*
USE_GITHUB= yes
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index c77ace19711d..366fbfd7aa6f 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -57,10 +57,4 @@ AVAHI_MESON_TRUE= key-sharing
LDAP_USE= OPENLDAP=yes
LDAP_MESON_TRUE= ldap-support
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
-LDFLAGS+= -fuse-ld=lld
-.endif
-
.include <bsd.port.mk>
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index e33cafb00e4f..0ff394d920ae 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -59,9 +59,7 @@ CONFIGURE_ARGS+= --disable-gost
.endif
# openssl-1.1.1 (default after 1200080) doesn't support GHOST (yet), punt for now.
-.if ${OSVERSION}>=1200080
CONFIGURE_ARGS+= --disable-gost
-.endif
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/p11-kit/modules
diff --git a/security/tpm2-tools/Makefile b/security/tpm2-tools/Makefile
index 30ff30f7b64d..b1eb83bcbcf3 100644
--- a/security/tpm2-tools/Makefile
+++ b/security/tpm2-tools/Makefile
@@ -20,10 +20,4 @@ CONFIGURE_ARGS= --disable-hardening --disable-fapi
BROKEN_SSL= openssl
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
-BROKEN_SSL+= base
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/uacme/Makefile b/security/uacme/Makefile
index 8db1905b8c31..0958aa6df956 100644
--- a/security/uacme/Makefile
+++ b/security/uacme/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ARGS= --datadir=${EXAMPLESDIR:H} \
--sysconfdir=${PREFIX}/etc
OPTIONS_DEFINE= DOCS EXAMPLES MANPAGES UALPN
-_OPENSSL_SAFE= ${(${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} == base) || ${SSL_DEFAULT} == libressl || ${SSL_DEFAULT} == libressl-devel:?no:yes}
+_OPENSSL_SAFE= ${${SSL_DEFAULT} == libressl || ${SSL_DEFAULT} == libressl-devel:?no:yes}
OPTIONS_DEFAULT= ${${_OPENSSL_SAFE} == no:?GNUTLS:OPENSSL} MANPAGES \
UALPN
OPTIONS_SINGLE= CRYPTO
diff --git a/security/wpa_supplicant-devel/Makefile b/security/wpa_supplicant-devel/Makefile
index aa7385ca0ead..57a9110f7ede 100644
--- a/security/wpa_supplicant-devel/Makefile
+++ b/security/wpa_supplicant-devel/Makefile
@@ -13,8 +13,6 @@ GH_PROJECT= hostap
GH_TAGNAME= b4f7506ff
COMMIT_DATE= 2021.07.14
-BROKEN_FreeBSD_11= Does not support OpenSSL 1.0.2
-
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/README
diff --git a/security/zeek/Makefile b/security/zeek/Makefile
index 06325a3c57be..ce5a831d706f 100644
--- a/security/zeek/Makefile
+++ b/security/zeek/Makefile
@@ -11,7 +11,6 @@ COMMENT= System for detecting network intruders in real-time
LICENSE= BSD3CLAUSE
-BROKEN_FreeBSD_11_powerpc64= Does not build: error: zero-size array 'names'
BROKEN_FreeBSD_12_powerpc64= Does not build: error: zero-size array 'names'
USES= bison cmake compiler:c++11-lang cpe gettext-runtime ninja perl5 \