aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-11 21:12:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-11 21:12:38 +0000
commitd17fb322a19a3e2871a8d624f0f0eda500f1e632 (patch)
treeaf044060b0969eb244eb0a99158149877b799b44 /security
parent1e0d2f28965b74abc16279729e3cd9e0a9f825aa (diff)
downloadports-d17fb322a19a3e2871a8d624f0f0eda500f1e632.tar.gz
ports-d17fb322a19a3e2871a8d624f0f0eda500f1e632.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Crypt_CHAP/Makefile26
-rw-r--r--security/pear-Crypt_CHAP/distinfo2
-rw-r--r--security/pear-Crypt_CHAP/pkg-descr9
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b9f847da2ce4..48ad974a6958 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -333,6 +333,7 @@
SUBDIR += pear-Auth_HTTP
SUBDIR += pear-Auth_SASL
SUBDIR += pear-Crypt_CBC
+ SUBDIR += pear-Crypt_CHAP
SUBDIR += pear-Crypt_HMAC
SUBDIR += pear-Crypt_RC4
SUBDIR += pear-File_HtAccess
diff --git a/security/pear-Crypt_CHAP/Makefile b/security/pear-Crypt_CHAP/Makefile
new file mode 100644
index 000000000000..30264d2c7f1c
--- /dev/null
+++ b/security/pear-Crypt_CHAP/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Crypt_CHAP
+# Date created: 09 March 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_CHAP
+PORTVERSION= 1.0.0
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class for generating CHAP packets
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= mcrypt mhash
+
+CATEGORY= Crypt
+FILES= CHAP.php
+TESTS= chaptest.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_CHAP/distinfo b/security/pear-Crypt_CHAP/distinfo
new file mode 100644
index 000000000000..6daf7752f20e
--- /dev/null
+++ b/security/pear-Crypt_CHAP/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Crypt_CHAP-1.0.0.tgz) = b09ba7b851f85528638d9a9dae67b1c9
+SIZE (PEAR/Crypt_CHAP-1.0.0.tgz) = 5437
diff --git a/security/pear-Crypt_CHAP/pkg-descr b/security/pear-Crypt_CHAP/pkg-descr
new file mode 100644
index 000000000000..b682fa5f2458
--- /dev/null
+++ b/security/pear-Crypt_CHAP/pkg-descr
@@ -0,0 +1,9 @@
+PEAR::Crypt_CHAP provides Classes for generating CHAP packets.
+Currently these types of CHAP are supported:
+* CHAP-MD5
+* MS-CHAPv1
+* MS-CHAPv2
+
+For MS-CHAP the mhash and mcrypt extensions must be loaded.
+
+WWW: http://pear.php.net/package/Crypt_CHAP/