aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-02-26 05:56:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-02-26 05:56:07 +0000
commit4857d67313d15b09e0eb7e78bbcf35759b2c8544 (patch)
tree29e66fbfae1297f0acf1c5d6d77f5a3374a4bafa /security
parentc600b831917ce7ab0fef85718f47bd82a6264fb3 (diff)
downloadports-4857d67313d15b09e0eb7e78bbcf35759b2c8544.tar.gz
ports-4857d67313d15b09e0eb7e78bbcf35759b2c8544.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/gnupg-idea/Makefile3
-rw-r--r--security/gnupg-idea/distinfo1
-rw-r--r--security/hpn-ssh/Makefile32
-rw-r--r--security/openssh-portable/Makefile32
-rw-r--r--security/openssh/distinfo2
-rw-r--r--security/openssl-beta/distinfo1
-rw-r--r--security/openssl/distinfo1
-rw-r--r--security/pgpin/distinfo1
-rw-r--r--security/pidentd/distinfo2
9 files changed, 41 insertions, 34 deletions
diff --git a/security/gnupg-idea/Makefile b/security/gnupg-idea/Makefile
index 6aedc679af5a..6c19ee7d6fee 100644
--- a/security/gnupg-idea/Makefile
+++ b/security/gnupg-idea/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnupg-idea
-PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTVERSION= 1.0.6
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
ftp://ftp.gnupg.org/gcrypt/%SUBDIR%/ \
diff --git a/security/gnupg-idea/distinfo b/security/gnupg-idea/distinfo
index ce39d42ee5bf..0e66561e7a71 100644
--- a/security/gnupg-idea/distinfo
+++ b/security/gnupg-idea/distinfo
@@ -2,3 +2,4 @@ MD5 (gnupg-idea/idea.c.gz) = 9dc3bc086824a8c7a331f35e09a3e57f
MD5 (gnupg-idea/idea.c.gz) = 374536bb2cdd68f5c0dce961ace26959
MD5 (gnupg-idea/idea.c.gz) = 05efff7f130bd99ae17c1d5ee1d18835
MD5 (gnupg-idea/rsa.c) = d8b6f26df0e3e0ccd93c2d0589d8766f
+SIZE (gnupg-idea/rsa.c) = 14302
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 356201652c55..5589503372f9 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -45,6 +45,22 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
+.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+PKGNAMESUFFIX= -gssapi
+CONFLICTS+= openssh-portable-*
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+.else
+CONFLICTS+= openssh-gssapi-*
+.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
+CONFIGURE_ARGS+= --with-kerberos5
+EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
+.endif
+.endif
+
+.if defined(BATCH)
+EXTRA_PATCHES+= ${FILESDIR}/batch.patch
+.endif
+
.if defined(OPENSSH_OVERWRITE_BASE)
WITH_OPENSSL_BASE= yes
PKGNAMESUFFIX= -overwrite-base
@@ -70,22 +86,6 @@ PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
-.if defined(BATCH)
-EXTRA_PATCHES+= ${FILESDIR}/batch.patch
-.endif
-
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-PKGNAMESUFFIX= -gssapi
-CONFLICTS+= openssh-portable-*
-CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
-.else
-CONFLICTS+= openssh-gssapi-*
-.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
-CONFIGURE_ARGS+= --with-kerberos5
-EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldes||g' ${WRKSRC}/configure
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 356201652c55..5589503372f9 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -45,6 +45,22 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
CONFIGURE_ARGS+= --disable-suid-ssh
.endif
+.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+PKGNAMESUFFIX= -gssapi
+CONFLICTS+= openssh-portable-*
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+.else
+CONFLICTS+= openssh-gssapi-*
+.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
+CONFIGURE_ARGS+= --with-kerberos5
+EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
+.endif
+.endif
+
+.if defined(BATCH)
+EXTRA_PATCHES+= ${FILESDIR}/batch.patch
+.endif
+
.if defined(OPENSSH_OVERWRITE_BASE)
WITH_OPENSSL_BASE= yes
PKGNAMESUFFIX= -overwrite-base
@@ -70,22 +86,6 @@ PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
CONFIGURE_ARGS+= --sysconfdir=${ETCSSH}
CONFIGURE_ARGS+= --with-privsep-path=${EMPTYDIR}
-.if defined(BATCH)
-EXTRA_PATCHES+= ${FILESDIR}/batch.patch
-.endif
-
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-PKGNAMESUFFIX= -gssapi
-CONFLICTS+= openssh-portable-*
-CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
-.else
-CONFLICTS+= openssh-gssapi-*
-.if !defined(WITHOUT_KERBEROS) && exists(/usr/include/krb5.h)
-CONFIGURE_ARGS+= --with-kerberos5
-EXTRA_PATCHES+= ${FILESDIR}/gss-serv.c.patch
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldes||g' ${WRKSRC}/configure
diff --git a/security/openssh/distinfo b/security/openssh/distinfo
index f22ccdb83207..0349532967d4 100644
--- a/security/openssh/distinfo
+++ b/security/openssh/distinfo
@@ -1,2 +1,4 @@
MD5 (openssh-3.6.1.tgz) = aa2acd2be17dc3fd514a1e09336aab51
+SIZE (openssh-3.6.1.tgz) = 407929
MD5 (openbsd28_3.6.1.patch) = bcd0e1e4603cfd4e1f2f457830d7842a
+SIZE (openbsd28_3.6.1.patch) = 51268
diff --git a/security/openssl-beta/distinfo b/security/openssl-beta/distinfo
index 4f159ed52ae9..c57ee9bedafe 100644
--- a/security/openssl-beta/distinfo
+++ b/security/openssl-beta/distinfo
@@ -1 +1,2 @@
MD5 (openssl-0.9.7c.tar.gz) = c54fb36218adaaaba01ef733cd88c8ec
+SIZE (openssl-0.9.7c.tar.gz) = 2791797
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 4f159ed52ae9..c57ee9bedafe 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1 +1,2 @@
MD5 (openssl-0.9.7c.tar.gz) = c54fb36218adaaaba01ef733cd88c8ec
+SIZE (openssl-0.9.7c.tar.gz) = 2791797
diff --git a/security/pgpin/distinfo b/security/pgpin/distinfo
index 1c1b04918c5d..6f9857f13b7e 100644
--- a/security/pgpin/distinfo
+++ b/security/pgpin/distinfo
@@ -1 +1,2 @@
MD5 (pgp263in010323.tgz) = b8a30328c1d3f2e40516e78ab1bdc3b2
+SIZE (pgp263in010323.tgz) = 624606
diff --git a/security/pidentd/distinfo b/security/pidentd/distinfo
index bff1d565a410..9c774a3cf56d 100644
--- a/security/pidentd/distinfo
+++ b/security/pidentd/distinfo
@@ -1,2 +1,4 @@
MD5 (pidentd-2.8.5.tar.gz) = 15d3d8b7ad9433b91634618b1f7b6417
+SIZE (pidentd-2.8.5.tar.gz) = 121835
MD5 (pidentd-2.8.5-ipv6-1.5.diff.gz) = a8bf86a6f00611c0e3f7e1e153c73d7d
+SIZE (pidentd-2.8.5-ipv6-1.5.diff.gz) = 9635