aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-07-21 17:51:43 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-07-21 17:51:43 +0000
commit94d3cac055cecaf22c6e783236f3b5c6405aaa0b (patch)
tree2cca1a45b5c4290da719551847438d5ce6501f9d /security
parent2252ff0ae8531f7c05150ff4603531662476bb23 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 7523ae8d5095..040740560401 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -855,7 +855,11 @@ MLINKS= dgst.1 md4.1 \
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
+.if ( ${OSVERSION} >= 800105 )
+OPENSSL_SHLIBVER?= 6
+.else
OPENSSL_SHLIBVER?= 5
+.endif
.if !defined(WITHOUT_SSE2)
# disable runtime SSE2 detection