aboutsummaryrefslogtreecommitdiff
path: root/shells/44bsd-csh
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-07-05 03:41:09 +0000
committerCy Schubert <cy@FreeBSD.org>2011-07-05 03:41:09 +0000
commit353ab88661a40dac539637a069da1d72a6fead6e (patch)
treec57ca1b222e908b3ec0a83ac0b4db27f3f639264 /shells/44bsd-csh
parent663be3b50ab96bbb43e5543c6ba791bb85bedfd2 (diff)
downloadports-353ab88661a40dac539637a069da1d72a6fead6e.tar.gz
ports-353ab88661a40dac539637a069da1d72a6fead6e.zip
Notes
Diffstat (limited to 'shells/44bsd-csh')
-rw-r--r--shells/44bsd-csh/Makefile1
-rw-r--r--shells/44bsd-csh/files/patch-file.c40
2 files changed, 41 insertions, 0 deletions
diff --git a/shells/44bsd-csh/Makefile b/shells/44bsd-csh/Makefile
index 3185ecce70f8..e71e761b7e8d 100644
--- a/shells/44bsd-csh/Makefile
+++ b/shells/44bsd-csh/Makefile
@@ -7,6 +7,7 @@
#
PORTNAME= 44bsd-csh
PORTVERSION= 20001106
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= cy
diff --git a/shells/44bsd-csh/files/patch-file.c b/shells/44bsd-csh/files/patch-file.c
new file mode 100644
index 000000000000..1c3344b0d554
--- /dev/null
+++ b/shells/44bsd-csh/files/patch-file.c
@@ -0,0 +1,40 @@
+--- file.c.orig 2011-07-04 06:54:10.348798410 -0700
++++ file.c 2011-07-04 16:23:57.199132280 -0700
+@@ -82,7 +82,7 @@
+
+ static void setup_tty __P((int));
+ static void back_to_col_1 __P((void));
+-static void pushback __P((Char *));
++static void pushback __P((Char *, int));
+ static void catn __P((Char *, Char *, int));
+ static void copyn __P((Char *, Char *, int));
+ static Char filetype __P((Char *, Char *));
+@@ -156,8 +156,9 @@
+ * Push string contents back into tty queue
+ */
+ static void
+-pushback(string)
++pushback(string, list)
+ Char *string;
++ int list;
+ {
+ Char *p;
+ struct termios tty, tty_normal;
+@@ -168,6 +169,8 @@
+ (void) tcgetattr(SHOUT, &tty);
+ tty_normal = tty;
+ tty.c_lflag &= ~(ECHOKE | ECHO | ECHOE | ECHOK | ECHONL | ECHOPRT | ECHOCTL);
++ if (list == LIST)
++ tty.c_lflag |= ECHO;
+ (void) tcsetattr(SHOUT, TCSANOW, &tty);
+
+ for (p = string; (c = *p) != '\0'; p++)
+@@ -660,7 +663,7 @@
+ should_retype = TRUE;
+ if (should_retype)
+ printprompt();
+- pushback(inputline);
++ pushback(inputline, command);
+ if (should_retype)
+ retype();
+ }