aboutsummaryrefslogtreecommitdiff
path: root/shells/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-03-29 19:40:04 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-03-29 19:40:04 +0000
commitda75a7a6dfd97fd198057cc6c1ab48234b74a0d8 (patch)
tree27fbeeef73c97fcf9c9da30423cf84e512c11178 /shells/Makefile
parent5b2388cfd7ae7afbd898267e6b0d229ea725e73e (diff)
downloadports-da75a7a6dfd97fd198057cc6c1ab48234b74a0d8.tar.gz
ports-da75a7a6dfd97fd198057cc6c1ab48234b74a0d8.zip
Add shells/antibody
This is a zsh plugin manager. Its syntax is similar to antigen, but is much, much faster. It's written in go (making it necessarily faster than antigen), but can also dump plugin info to a loadable script so that antibody doesn't need to run at all when spawning new shells. Antibody is a shell plugin manager made from the ground up thinking about performance. It is faster because it can do things concurrently, while Antigen does it sequentially. It also has the advantage of using a compiled language (go) instead of a scripting one. WWW: https://getantibody.github.io/
Notes
Notes: svn path=/head/; revision=497191
Diffstat (limited to 'shells/Makefile')
-rw-r--r--shells/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index aa93ae375011..3fe73cdb2a94 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -5,6 +5,7 @@
SUBDIR += 44bsd-csh
SUBDIR += ammonite
+ SUBDIR += antibody
SUBDIR += bash
SUBDIR += bash-completion
SUBDIR += bash-static