aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion-classic/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-18 20:43:09 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-18 20:43:09 +0000
commit45325003d1bbcc71e71013510a7a779eb3bb4777 (patch)
tree0c52b1a93b6036111a684c882aa686033560b252 /shells/bash-completion-classic/Makefile
parent25713576c7c1b8b3957990c48804ea9ef8b49016 (diff)
downloadports-45325003d1bbcc71e71013510a7a779eb3bb4777.tar.gz
ports-45325003d1bbcc71e71013510a7a779eb3bb4777.zip
Notes
Diffstat (limited to 'shells/bash-completion-classic/Makefile')
-rw-r--r--shells/bash-completion-classic/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 59ed9427c81f..e9b5940eb14f 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bash-completion
-PORTVERSION= 20040101
+PORTVERSION= 20040214
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
@@ -15,12 +15,22 @@ COMMENT= Programmable completion library for Bash 2.04 and up
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+.if defined(WITH_GSED)
+RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
+.endif
+
WRKSRC= ${WRKDIR}/bash_completion
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_FILES= etc/bash_completion
+pre-everything::
+ @${ECHO}
+ @${ECHO} "You can build ${PKGNAME} with the following options:"
+ @${ECHO} "WITH_GSED use GNU sed to enable additional completions"
+ @${ECHO}
+
pre-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}