aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion-classic/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2010-09-04 17:51:46 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2010-09-04 17:51:46 +0000
commit293b2c979ed4b1ec4befb07330bf2333930d9ad3 (patch)
treed36bca2650a44539460c850f96d537c84c614919 /shells/bash-completion-classic/Makefile
parent7cce6f025f6f52fc90b70fef14a0eaf80bec632f (diff)
Replace bash-completion with a new package.
The previous bash-completion package hadn't been updated since 2006. A new group has picked up the package and continued development. The old completions should remain, so I'm not going to update UPDATING. I'm taking maintainership of this as well. Many thanks to Kirk, the previous maintainer!
Notes
Notes: svn path=/head/; revision=260558
Diffstat (limited to 'shells/bash-completion-classic/Makefile')
-rw-r--r--shells/bash-completion-classic/Makefile47
1 files changed, 18 insertions, 29 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 566429633c12..6fffcfb66900 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -5,47 +5,36 @@
# $FreeBSD$
#
-PORTNAME= bash-completion
-PORTVERSION= 20060301
-PORTREVISION= 3
-CATEGORIES= shells
-MASTER_SITES= http://www.caliban.org/files/bash/
+PORTNAME= bash-completion
+PORTVERSION= 1.2
+PORTEPOCH= 1
+CATEGORIES= shells
+MASTER_SITES= http://bash-completion.alioth.debian.org/files/
-MAINTAINER= kirk@strauser.com
-COMMENT= Programmable completion library for Bash 2.04 and up
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Programmable completion library for Bash
-WRKSRC= ${WRKDIR}/bash_completion
-NO_BUILD= yes
-
-SUB_FILES= pkg-message
-PLIST_FILES= etc/bash_completion
-
-OPTIONS= GSED "Use GNU sed to enable additional completions" off
-
-.include <bsd.port.pre.mk>
+USE_BZIP2= yes
+SUB_FILES= pkg-message
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-.if defined(WITH_GSED)
-RUN_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
-.endif
+GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
- s|/usr\(/sbin/postconf\)|${LOCALBASE}\1|g; \
- s|/usr\(/lib/rpm/macros\)|${LOCALBASE}\1|g; \
+ s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \
+ s|/usr\(/lib/rpm/macros\)|${PREFIX}\1|g; \
s|/usr/share\(/ssl/openssl.cnf\)|/etc\1|g; \
s|/usr/ports|${PORTSDIR}|g; \
- s|/usr/lib\(/aspell\)|${LOCALBASE}/share\1|g; \
- s|/usr/share/info|&:${LOCALBASE}/info|g; \
+ s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
+ s|/usr/share/info|&:${PREFIX}/info|g; \
+ s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
s|\(FLAC\)|\1\|flv\|FLV|' \
- ${WRKSRC}/bash_completion
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc
+ ${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>