aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2012-11-02 23:35:31 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2012-11-02 23:35:31 +0000
commit97796d9ef99e4b46e609c1e49d73e025dfc26aa4 (patch)
tree78ab059669953585d71d261762f5b67b1c337ce3 /shells/bash-completion/Makefile
parent4ccdcec4f08a7b67945183e07b3ca51da9128a00 (diff)
downloadports-97796d9ef99e4b46e609c1e49d73e025dfc26aa4.tar.gz
ports-97796d9ef99e4b46e609c1e49d73e025dfc26aa4.zip
Notes
Diffstat (limited to 'shells/bash-completion/Makefile')
-rw-r--r--shells/bash-completion/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index da4d2d48c093..53079dec32c3 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: bash_completion
-# Date created: 29 May 2003
-# Whom: kirk@strauser.com
+# Created by: kirk@strauser.com
#
# $FreeBSD$
#
PORTNAME= bash-completion
-PORTVERSION= 1.3
-PORTREVISION= 4
+PORTVERSION= 2.0
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
@@ -15,18 +12,21 @@ MASTER_SITES= http://bash-completion.alioth.debian.org/files/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Programmable completion library for Bash
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
CONFLICTS= bash-completion-classic-[0-9]*
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
USE_BZIP2= yes
SUB_FILES= pkg-message
+SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
+PORTDOCS= *
post-patch:
- @${ECHO_CMD} You can safely ignore this next error...
- -@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \
s|/usr\(/lib/rpm/macros\)|${PREFIX}\1|g; \
@@ -35,11 +35,20 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|FLAC|&\|flv\|FLV|' \
+ s|FLAC|&\|flv\|FLV|; \
+ s|\(profiledir = \)${PREFIX}/bin|\1${DATADIR}|g; \
+ s|\$$(datadir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in \
- ${WRKSRC}/completions/* ${WRKSRC}/completions/helpers/*
+ ${WRKSRC}/completions/*
post-install:
+.if !defined(WITHOUT_DOCS)
+ ${MKDIR} ${DOCSDIR}
+. for i in README doc/bash_completion.txt doc/bashrc doc/inputrc
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+. endfor
+.endif
+
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>