aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-12-28 16:38:11 +0000
committerJohn Marino <marino@FreeBSD.org>2013-12-28 16:38:11 +0000
commit6a1286cd581519802f73d2f47790e8149fc65df1 (patch)
treed44913e2cf683b55f81557c1f3e71ee058aae4c8 /shells/bash-completion
parent84ff337b02a41ca8f428353e59cfd595a72defcf (diff)
downloadports-6a1286cd581519802f73d2f47790e8149fc65df1.tar.gz
ports-6a1286cd581519802f73d2f47790e8149fc65df1.zip
Notes
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile11
-rw-r--r--shells/bash-completion/files/patch-Makefile.am19
2 files changed, 21 insertions, 9 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index ed40ff6ec688..39531cfe6462 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bash-completion
PORTVERSION= 2.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
@@ -32,6 +33,9 @@ RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|FLAC|&\|flv\|FLV|;' ${WRKSRC}/bash_completion
+
post-configure:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
@@ -40,12 +44,7 @@ post-configure:
s|/usr/share\(/ssl/openssl.cnf\)|/etc\1|g; \
s|/usr/ports|${PORTSDIR}|g; \
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
- s|/usr/share/info|&:${PREFIX}/info|g; \
- s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|FLAC|&\|flv\|FLV|; \
- s|\(profiledir = \)${PREFIX}/bin|\1${DATADIR}|g; \
- s|\$$(datadir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in \
+ s|/usr/share/info|&:${PREFIX}/info|g;' \
${WRKSRC}/completions/*
post-install:
diff --git a/shells/bash-completion/files/patch-Makefile.am b/shells/bash-completion/files/patch-Makefile.am
index 007eb00a36f5..73fe3ca79f9c 100644
--- a/shells/bash-completion/files/patch-Makefile.am
+++ b/shells/bash-completion/files/patch-Makefile.am
@@ -1,6 +1,19 @@
---- Makefile.am.orig 2013-12-20 13:44:12.000000000 -0500
-+++ Makefile.am 2013-12-20 13:44:17.000000000 -0500
-@@ -20,8 +20,10 @@
+--- Makefile.am.orig 2013-04-05 09:43:56.000000000 +0000
++++ Makefile.am
+@@ -5,10 +5,10 @@ pkgdata_DATA = bash_completion
+ # Empty, but here just to get the compat dir created with install
+ compat_DATA =
+
+-profiledir = $(sysconfdir)/profile.d
++profiledir = $(prefix)/share/bash-completion
+ profile_DATA = bash_completion.sh
+
+-pkgconfigdir = $(datadir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = bash-completion.pc
+
+ bash_completion.sh: bash_completion.sh.in Makefile
+@@ -20,8 +20,10 @@ EXTRA_DIST = CHANGES $(sysconf_DATA) $(p
.dir-locals.el
install-data-hook: