aboutsummaryrefslogtreecommitdiff
path: root/shells/bash2/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-28 19:27:28 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-28 19:27:28 +0000
commit2492f124254fc7d5797923799b91735381cb87ad (patch)
treec1e3b0e034a0cac35d5a5bca54478278a3bd5196 /shells/bash2/Makefile
parentb37b345fdbbb39fbacef73cfa93aaf343fb467e0 (diff)
downloadports-2492f124254fc7d5797923799b91735381cb87ad.tar.gz
ports-2492f124254fc7d5797923799b91735381cb87ad.zip
Notes
Diffstat (limited to 'shells/bash2/Makefile')
-rw-r--r--shells/bash2/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 45c2a8666123..99ffea9dd5f8 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= bash
PORTVERSION= 2.05b.007
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/bash/
@@ -50,11 +50,19 @@ post-patch:
@${REINPLACE_CMD} -e "s,.FN /bin/bash,.FN ${PREFIX}/bin/bash," \
${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/doc/bash.1
-post-install:
+update-etc-shells:
+ @${ECHO_MSG} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @( ${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
+ @${RM} /etc/shells.bak
+
+post-install: update-etc-shells
${LN} -f ${PREFIX}/bin/bash ${PREFIX}/bin/bash2
- ${CP} /etc/shells /etc/shells.bak
- (${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
- ${RM} /etc/shells.bak
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples ; ${PAX} -rw . ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} -type d -print | xargs chmod a+rx
+ @${CHMOD} -R a+r ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} \