aboutsummaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
commit42542fb07642b8336e808272918f3ae46aa67e0b (patch)
tree98ff235c33c6493aa26457284f122652c38935f7 /shells/bash
parent4c9cd257fd4e6eca46807a43e128d298429ee3cd (diff)
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=197075
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile10
-rw-r--r--shells/bash/pkg-install2
2 files changed, 6 insertions, 6 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 8fa0d105e064..08764fbb96aa 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -107,22 +107,22 @@ pre-build:
@${ECHO_CMD} $$((${PORTREVISION}-1)) > ${WRKSRC}/.build
pre-install:
- @${SETENV} PKG_PREFIX="${PREFIX}" PKG_DESTDIR="${DESTDIR}" \
+ @${SETENV} PKG_PREFIX="${PREFIX}" \
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
@cd ${PREFIX}/bin ; ${LN} -sf bash rbash
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DESTDIR}${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.if !defined(WITH_INCLUDED_FAQ)
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/FAQ \
- ${WRKSRC}/doc/INTRO ${DESTDIR}${DOCSDIR}
+ ${WRKSRC}/doc/INTRO ${DOCSDIR}
.else
@${INSTALL_DATA} ${WRKSRC}/doc/FAQ \
- ${WRKSRC}/doc/INTRO ${DESTDIR}${DOCSDIR}
+ ${WRKSRC}/doc/INTRO ${DOCSDIR}
.endif
@for d in ${PORTDOCS:NFAQ:NINTRO}; do \
- ${INSTALL_DATA} ${WRKSRC}/$${d} ${DESTDIR}${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/$${d} ${DOCSDIR}; \
done
.endif
@${SETENV} PKG_PREFIX="${PREFIX}" PKG_DESTDIR="${DESTDIR}" \
diff --git a/shells/bash/pkg-install b/shells/bash/pkg-install
index 37a63a755364..99417b66ba6e 100644
--- a/shells/bash/pkg-install
+++ b/shells/bash/pkg-install
@@ -5,7 +5,7 @@
BASH="$(echo ${PKG_PREFIX-/usr/local}/bin/bash | /usr/bin/sed -e 's|//|/|g')"
RBASH="$(echo ${PKG_PREFIX-/usr/local}/bin/rbash | /usr/bin/sed -e 's|//|/|g')"
-SHELLS="${PKG_DESTDIR-}/etc/shells"
+SHELLS="/etc/shells"
case $2 in
POST-INSTALL)