aboutsummaryrefslogtreecommitdiff
path: root/shells/dash
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-11-21 05:17:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-11-21 05:17:19 +0000
commit536ff8a1f72fee66b2a454507b52c007ce2cb304 (patch)
tree964eefea91b723be68a9dc49e47f91b4668d4fa6 /shells/dash
parente39fc810a4d303ec4937b664a65669533d757075 (diff)
downloadports-536ff8a1f72fee66b2a454507b52c007ce2cb304.tar.gz
ports-536ff8a1f72fee66b2a454507b52c007ce2cb304.zip
Notes
Diffstat (limited to 'shells/dash')
-rw-r--r--shells/dash/Makefile27
-rw-r--r--shells/dash/distinfo3
-rw-r--r--shells/dash/pkg-descr5
3 files changed, 35 insertions, 0 deletions
diff --git a/shells/dash/Makefile b/shells/dash/Makefile
new file mode 100644
index 000000000000..c204e191cde6
--- /dev/null
+++ b/shells/dash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: dash
+# Date created: Nov 10, 2009
+# Whom: Eitan Adler
+#
+# $FreeBSD$
+#
+
+PORTNAME= dash
+PORTVERSION= 0.5.5.1
+CATEGORIES= shells
+MASTER_SITES= http://gondor.apana.org.au/~herbert/dash/files/
+
+MAINTAINER= EitanAdlerList@gmail.com
+COMMENT= A POSIX-compliant implementation of /bin/sh
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CFLAGS+= -DUNUSABLE_RT_SIGNALS
+
+PLIST_FILES= bin/dash
+MAN1= dash.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/COMMON_CFLAGS =/ s|$$| ${CFLAGS}|' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/shells/dash/distinfo b/shells/dash/distinfo
new file mode 100644
index 000000000000..5a7bf1d6fa0d
--- /dev/null
+++ b/shells/dash/distinfo
@@ -0,0 +1,3 @@
+MD5 (dash-0.5.5.1.tar.gz) = 7ac832b440b91f5a52cf8eb68e172616
+SHA256 (dash-0.5.5.1.tar.gz) = 1c6717a1014c73aa16bc78a4767f1e00b40ff2a01a6c2cf2cce9a5335c24493f
+SIZE (dash-0.5.5.1.tar.gz) = 208094
diff --git a/shells/dash/pkg-descr b/shells/dash/pkg-descr
new file mode 100644
index 000000000000..9b4b07cb3567
--- /dev/null
+++ b/shells/dash/pkg-descr
@@ -0,0 +1,5 @@
+DASH is a POSIX-compliant implementation of /bin/sh that aims to be as small as
+possible. It does this without sacrificing speed where possible. In fact, it
+is significantly faster than bash (the GNU Bourne-Again SHell) for most tasks.
+
+WWW: http://gondor.apana.org.au/~herbert/dash/