aboutsummaryrefslogtreecommitdiff
path: root/shells/esh
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-05-28 21:01:51 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-05-28 21:01:51 +0000
commit5f65a2b3dde5bd9a425cf3f60adcb46f9bef9f2b (patch)
tree4fe4a8519550ec6e6b61befd85481a20572d4216 /shells/esh
parentaf10ff898c7ea24b0d0f9dbc07439afda6d3650c (diff)
downloadports-5f65a2b3dde5bd9a425cf3f60adcb46f9bef9f2b.tar.gz
ports-5f65a2b3dde5bd9a425cf3f60adcb46f9bef9f2b.zip
Notes
Diffstat (limited to 'shells/esh')
-rw-r--r--shells/esh/Makefile34
-rw-r--r--shells/esh/distinfo1
-rw-r--r--shells/esh/files/patch-aa20
-rw-r--r--shells/esh/files/patch-ab20
-rw-r--r--shells/esh/pkg-comment1
-rw-r--r--shells/esh/pkg-descr14
-rw-r--r--shells/esh/pkg-plist7
7 files changed, 97 insertions, 0 deletions
diff --git a/shells/esh/Makefile b/shells/esh/Makefile
new file mode 100644
index 000000000000..7340a1033db4
--- /dev/null
+++ b/shells/esh/Makefile
@@ -0,0 +1,34 @@
+# Ports collection Makefile for: esh
+# Version required: 0.8
+# Date created: 05/20/1999
+# Whom: nectar@FreeBSD.ORG
+#
+# $Id$
+#
+
+DISTNAME= esh-0.8
+CATEGORIES= shells
+MASTER_SITES= http://esh.netpedia.net/ \
+ http://www.nectar.cc/distfiles/
+
+MAINTAINER= nectar@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/esh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/esh ${PREFIX}/bin/esh
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/esh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/esh) > /etc/shells
+ @${RM} /etc/shells.bak
+.if !defined(NOPORTDOCS)
+ if [ -f ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > \
+ ${PREFIX}/info/dir; \
+ fi
+ ${INSTALL_DATA} ${WRKSRC}/doc/esh.info ${PREFIX}/info/esh.info
+ install-info ${PREFIX}/info/esh.info ${PREFIX}/info/dir
+.endif
+
+.include <bsd.port.mk>
diff --git a/shells/esh/distinfo b/shells/esh/distinfo
new file mode 100644
index 000000000000..4faa924e1fe1
--- /dev/null
+++ b/shells/esh/distinfo
@@ -0,0 +1 @@
+MD5 (esh-0.8.tar.gz) = b59022b88bae24420156d25869b8be54
diff --git a/shells/esh/files/patch-aa b/shells/esh/files/patch-aa
new file mode 100644
index 000000000000..9cb43fca561c
--- /dev/null
+++ b/shells/esh/files/patch-aa
@@ -0,0 +1,20 @@
+--- Makefile.orig Thu May 20 14:08:23 1999
++++ Makefile Thu May 20 14:10:30 1999
+@@ -1,8 +1,3 @@
+-
+-# Your C compiler.
+-
+-CC=gcc
+-
+ # Where your readline library is.
+ # You can compile with a hacked replacement of readline instead by
+ # doing this:
+@@ -18,7 +13,7 @@
+ # -DMEM_DEBUG Check for memory leaks.
+ #
+
+-CFLAGS=-g -Wall -DMEM_DEBUG $(INC) -pg
++CFLAGS+=$(INC)
+
+ # No need to change this stuff.
+
diff --git a/shells/esh/files/patch-ab b/shells/esh/files/patch-ab
new file mode 100644
index 000000000000..93f73ad712dc
--- /dev/null
+++ b/shells/esh/files/patch-ab
@@ -0,0 +1,20 @@
+--- esh.c.orig Thu May 20 14:13:25 1999
++++ esh.c Thu May 20 14:22:34 1999
+@@ -657,7 +656,9 @@
+
+ void job_wait(job_t* job) {
+ int tmp;
++ sig_t oldsig;
+
++ oldsig = signal(SIGCHLD, SIG_DFL);
+ if (interactive) {
+ waitpid(job->last_pid, &tmp, WUNTRACED);
+
+@@ -676,6 +677,7 @@
+ } else {
+ waitpid(job->last_pid, &tmp, WUNTRACED);
+ }
++ signal(SIGCHLD, oldsig);
+ }
+
+
diff --git a/shells/esh/pkg-comment b/shells/esh/pkg-comment
new file mode 100644
index 000000000000..83da8df48661
--- /dev/null
+++ b/shells/esh/pkg-comment
@@ -0,0 +1 @@
+The ``easy shell'', a small shell with Lisp-like syntax.
diff --git a/shells/esh/pkg-descr b/shells/esh/pkg-descr
new file mode 100644
index 000000000000..4aaa23ff7252
--- /dev/null
+++ b/shells/esh/pkg-descr
@@ -0,0 +1,14 @@
+esh is a new shell for Unix, written completely from scratch. It is
+very small, both in number of lines of source code and in memory
+consumption. The whole shell is about 5000 lines of C source code, and
+occupies about twice as little memory as bash in some cases.
+
+However, esh is also extremely flexible, with a real programming
+language at the core. The syntax is a simplified form of Scheme. The
+current version is 0.8, though it is already stable and
+featureful. The reason for the low version number is lack of
+real-world testing. It is released under the GPL, of course.
+
+WWW:http://esh.netpedia.net/
+
+Jacques Vidrine <nectar@FreeBSD.ORG>
diff --git a/shells/esh/pkg-plist b/shells/esh/pkg-plist
new file mode 100644
index 000000000000..d325c90e3646
--- /dev/null
+++ b/shells/esh/pkg-plist
@@ -0,0 +1,7 @@
+bin/esh
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
+@unexec install-info --delete %D/info/esh.info %D/info/dir
+info/esh.info
+@exec test -f %D/info/dir || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
+@exec install-info %D/info/esh.info %D/info/dir