aboutsummaryrefslogtreecommitdiff
path: root/shells/fish/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-21 11:35:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-21 11:35:38 +0000
commit279a1d6cef350fa63c1f2591fd35eaed308cc289 (patch)
tree99df93fe2c6cb138e8bf38b448c1f7ba6dde7343 /shells/fish/Makefile
parent43166060310d849ddcd279d3347dea95638ff39a (diff)
Notes
Diffstat (limited to 'shells/fish/Makefile')
-rw-r--r--shells/fish/Makefile37
1 files changed, 15 insertions, 22 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 5cb52b08a20c..327c3db1e8c2 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -6,14 +6,11 @@
#
PORTNAME= fish
-PORTVERSION= 1.22.3
-PORTREVISION= 4
+PORTVERSION= 1.23.1
CATEGORIES= shells
-MASTER_SITES= http://www.fishshell.org/files/1.22.3/ \
- http://roo.no-ip.org/fish/files/1.22.3/ \
- http://web.student.chalmers.se/~kaiw/FreeBSD/disfiles/
+MASTER_SITES= SF
-MAINTAINER= kaiw27@gmail.com
+MAINTAINER= rfarmer@predatorlabs.net
COMMENT= A user friendly command line shell
USE_AUTOTOOLS= autoconf:262
@@ -30,18 +27,18 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LIBS="${LDFLAGS}" \
OPTIONS= NLS "Native language support" on \
XSEL "Build with xsel" on
-MAN1= count.1 fish.1 fish_pager.1 fishd.1 \
- mimedb.1 set_color.1 alias.1 and.1 begin.1 \
- bg.1 bind.1 block.1 break.1 builtin.1 \
- case.1 cd.1 command.1 commandline.1 complete.1 \
- contains.1 continue.1 dirh.1 dirs.1 else.1 \
- end.1 eval.1 exec.1 exit.1 fg.1 for.1 \
- function.1 functions.1 help.1 if.1 isatty.1 \
- jobs.1 math.1 nextd.1 not.1 open.1 or.1 \
- popd.1 prevd.1 psub.1 pushd.1 random.1 \
- read.1 return.1 save_function.1 set.1 \
- source.1 status.1 switch.1 trap.1 type.1 \
- ulimit.1 umask.1 vared.1 while.1
+MAN1= alias.1 and.1 begin.1 bg.1 bind.1 block.1 \
+ break.1 breakpoint.1 builtin.1 case.1 cd.1 \
+ command.1 commandline.1 complete.1 contains.1 \
+ continue.1 count.1 dirh.1 dirs.1 else.1 \
+ emit.1 end.1 eval.1 exec.1 exit.1 fg.1 fish.1 \
+ fish_indent.1 fish_pager.1 fish_prompt.1 \
+ fishd.1 for.1 funced.1 funcsave.1 function.1 \
+ functions.1 help.1 if.1 isatty.1 jobs.1 math.1 \
+ mimedb.1 nextd.1 not.1 open.1 or.1 popd.1 \
+ prevd.1 psub.1 pushd.1 random.1 read.1 return.1 \
+ set.1 set_color.1 source.1 status.1 switch.1 \
+ trap.1 type.1 ulimit.1 umask.1 vared.1 while.1
.include <bsd.port.pre.mk>
@@ -66,10 +63,6 @@ post-install:
.if !defined(WITHOUT_XSEL)
${MV} ${PREFIX}/man/man1/xsel.1x ${PREFIX}/man/man1/xsel.1
.endif
-# remove duplicate manpages
-.for i in count.1 fish.1 fish_pager.1 fishd.1 mimedb.1 set_color.1
- cd ${DATADIR}/man && ${RM} -f ${i}
-.endfor
${CP} ${DATADIR}/man/*.1 ${PREFIX}/man/man1/
${RM} -rf ${DATADIR}/man
if ${GREP} -q '${PREFIX}/bin/${PORTNAME}' /etc/shells; then \