aboutsummaryrefslogtreecommitdiff
path: root/shells/flash/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 13:13:03 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 13:13:03 +0000
commit8750d5977c299976eb553c6508c51cbd8b22b81b (patch)
treec164b717d58f0014e785fc5aa81290a10c1607ed /shells/flash/Makefile
parent493c742ea29f92e89e076afc6f10a99eb4f724f2 (diff)
Use SUB_FILES for pkg-message
Notes
Notes: svn path=/head/; revision=158552
Diffstat (limited to 'shells/flash/Makefile')
-rw-r--r--shells/flash/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index 6f12de9dd81d..39e0b78722a7 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -26,6 +26,8 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -rdynamic" \
LDFLAGS="${LDFLAGS} -rdynamic"
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= flash.1
@@ -69,6 +71,6 @@ post-install:
@(${GREP} -v ${PREFIX}/bin/flash /etc/shells.bak; \
${ECHO_CMD} ${PREFIX}/bin/flash) > /etc/shells
@${RM} /etc/shells.bak
- @${SED} -e "s:/usr/local:${PREFIX}:g" ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>