aboutsummaryrefslogtreecommitdiff
path: root/shells/ibsh
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-22 10:02:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-22 10:02:45 +0000
commit2cc98306171da12e88f4e6f135a6dd9ec7e9db2f (patch)
tree5e3886832bd5ae67fd79ffa80a0b03557d1492eb /shells/ibsh
parent640dfb58d92fb9302a1f85d9693c96f7dd8a7472 (diff)
downloadports-2cc98306171da12e88f4e6f135a6dd9ec7e9db2f.tar.gz
ports-2cc98306171da12e88f4e6f135a6dd9ec7e9db2f.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=409325
Diffstat (limited to 'shells/ibsh')
-rw-r--r--shells/ibsh/Makefile11
-rw-r--r--shells/ibsh/files/patch-Makefile6
2 files changed, 11 insertions, 6 deletions
diff --git a/shells/ibsh/Makefile b/shells/ibsh/Makefile
index bd780ba4a7e2..a2f75fb6581a 100644
--- a/shells/ibsh/Makefile
+++ b/shells/ibsh/Makefile
@@ -9,7 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Restricted unix shell
-OPTIONS_DEFINE= DOCS
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake
ALL_TARGET= ibsh
@@ -20,13 +21,17 @@ SUB_FILES= pkg-message
PORTDOCS= AUTHORS BUGS CONTRIBUTORS COPYING COPYRIGHT ChangeLog \
INSTALL README TODO VERSION
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|PATH_MAX|PATH_MAXb|g' ${WRKSRC}/delbadfiles.c ${WRKSRC}/ibsh.h
@${REINPLACE_CMD} -e 's|/etc/ibsh|${PREFIX}/etc/ibsh|g' ${WRKSRC}/ibsh.h
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ibsh
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ibsh
.include <bsd.port.mk>
diff --git a/shells/ibsh/files/patch-Makefile b/shells/ibsh/files/patch-Makefile
index 6168d71f5751..eee459054000 100644
--- a/shells/ibsh/files/patch-Makefile
+++ b/shells/ibsh/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Fri Jun 3 15:47:32 2005
-+++ Makefile Sat Nov 12 13:47:53 2005
-@@ -30,12 +30,12 @@
+--- Makefile.orig 2005-06-03 13:47:32 UTC
++++ Makefile
+@@ -30,12 +30,12 @@ delbadfiles.o: delbadfiles.c ibsh.h
${CC} -c delbadfiles.c
ibsh_install: