aboutsummaryrefslogtreecommitdiff
path: root/shells/lshell/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-08-05 13:10:00 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-08-05 13:10:00 +0000
commit2abe41f067a8e12f58c4a67bc731806147b62faa (patch)
tree95c084d25f6cb317b9b912d83b7323fe368cff1e /shells/lshell/Makefile
parent2a7126171947c53254b64586213d85501ee87967 (diff)
downloadports-2abe41f067a8e12f58c4a67bc731806147b62faa.tar.gz
ports-2abe41f067a8e12f58c4a67bc731806147b62faa.zip
Notes
Diffstat (limited to 'shells/lshell/Makefile')
-rw-r--r--shells/lshell/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
new file mode 100644
index 000000000000..d8d979c93b14
--- /dev/null
+++ b/shells/lshell/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lshell
+# Date created: 2009-08-01
+# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lshell
+PORTVERSION= 0.9.5
+CATEGORIES= shells
+MASTER_SITES= SF
+
+MAINTAINER= scjamorim@bsd.com.br
+COMMENT= Shell environment to limited sets of commands to user's
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USE_PYDISTUTILS= yes
+USE_PYTHON= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/lshell.py \
+ %%PYTHON_SITELIBDIR%%/lshell.pyc \
+ %%PYTHON_SITELIBDIR%%/lshell.pyo \
+ bin/lshell \
+ etc/lshell.conf
+
+MAN1= lshell.1
+
+DOCS= README COPYING CHANGES
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>